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Std-Barc Features 

Std-Barc is a highly focused solution designed specifically to meet the requirements 
of Mil-Std-129/130 barcode labeling.  It includes many features to speed and simplify 
the job of compliance labeling: 

 Extensive support for compliance label formats: 

o Unit, Intermediate and Exterior Container Labels 

o Military Shipment Label (with linear and 2D barcodes) 

o RFID-tagged Exterior, Pallet and UID-Unit labels  

o Unique Identifier (UID) Labels  (with linear and 2D barcodes) 

o Ammunition/Explosives Load Labels (with 2D barcodes) 

 Offers the ability to print just one label whenever needed, or all labels for a 
complete shipment. 

 Automatically routes labels to printers based on label stock size. 

 Automatically generates labels using DD250 data from Mil-Pac products 
such as DD-FormStation, and DD-Master, as well as data from other 
applications and enterprise systems. 

 Compiles RFID-tag data necessary for the generation of Advanced Shipment 
Notice (ASN) transactions. 

 Includes built-in tools for speedy and accurate manual label generation. 
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Std-Barc Overview 

Std-Barc has been specifically designed for one purpose only: creating the labels that are 
necessary for compliance with Mil-Stds 129 and 130.  Every effort has been made with the 
goal to make that job as quick and easy as possible for the user.  Rather than being a general-
purpose label designer, Std-Barc focuses solely on the needs of the defense contractor.  Mil-
Pac is committed to eliminating the concern over meeting the stringent requirements of the 
military standards, even as they continually evolve. 

Std-Barc makes labeling simple, by allowing the user to fill in a simple form to create a 
label, and then creating other labels from that one.  Embedded databases for addresses and 
part descriptions make data entry fast and accurate.  Importing a DD250, or other shipment 
data, can almost entirely automate the process of label generation, nearly eliminating all of the 
data entry necessary to produce labels. 

Throughout this manual you will see references made to other Mil-Pac products.  DD-
FormStation is a Mil-Pac application that organizes and shares documents, such as the 
DD250.  DD-Master is a highly automated document manager supporting contracts that 
require multiple DD250/WAWF shipments.  RFID Load Manager+ compiles RFID and UID 
data into Advance Shipment Notices (ASN).  

Both Mil-Pac forms products are capable of submitting DD250s both to Wide-Area 
Workflow (WAWF) and Std-Barc. Using a WAWF DD250 to generate labels is one more way 
Std-Barc can help to guarantee accuracy and eliminate rejections. 
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Introduction 

Using This Manual 
This manual has been designed to assist the user through each step of using the Std-Barc 

barcode labeling software.  The principles of operation are generally the same as those for 
any other Microsoft Windows application.  

While every effort is made to keep this User Manual up to date, the current release of the 
software often includes features not yet incorporated in the manual.  This is particularly true of 
label formats, which are added as the military standards change, and as standard practices 
evolve.  Therefore, please be sure to refer to the product ReadMe.Txt files for updated 
product features.   
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Installation 

Get Ready to Install Std-Barc 

Set Up Personal Computer(s) 
System Requirements 

Computer:   Any Windows compatible system with at least 3.0 MB of free disk 
space. 

Operating System:  Windows-95 or later, or a compatible operating system. 

Set up one or more personal computers that meet or exceed the minimum hardware 
requirements. Configure security and connectivity in accordance with your organizational 
policies. 

Decide Where to Store Std-Barc Data 
You will need to decide where to save Std-Barc data. You can save Std-Barc data on the 

individual user’s/users’ personal computer(s) or on a centralized, networked computer. The 
following sections describe the differences between these two approaches. 

Option 1: Save Std-Barc Data on Individual Personal Computers 

When Std-Barc data is stored on individual personal computers, Std-Barc data is 
accessible from only one personal computer. Each personal computer with Std-Barc installed 
would not be able to use the data from any other computers where Std-Barc is installed. This 
installation is most appropriate when one or more of the following conditions are true: 

o Only one personal computer has Std-Barc installed. 

o There is no desire to share data between Std-Barc personal computers. 

o Connectivity between personal computers where Std-Barc is installed is either 
non-existent or unreliable. 
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Option 2: Save Std-Barc Data in a Shared Database 

Std-Barc can be installed with a shared database, so that users on different personal 
computers can all share the same data from different personal computers. Shared Std-Barc 
Database is most appropriate when: 

o Std-Barc is installed on more than one computer. 

o Users on different personal computers use the same data, such as shipping 
addresses, contracts, etc. 

o Connectivity between personal computers is reliable and full-time. 

If you choose to save Std-Barc data on individual personal computers, then you can skip to 
the next topic. Std-Barc will offer a default folder in which to save this data and allow you to 
change to a folder of your choosing during installation. 

If you choose to save Std-Barc data in a shared database, you will need to set up a 
network folder that has read and write permissions for each Std-Barc user. Map the network 
folder on each personal computer where Std-Barc will be installed, using traditional eight-
character directory path names, such as M:\Shipping\DD250s. Network administrators 
typically assist in this step. Mil-Pac software does not support UNC (Universal Naming 
Convention) names, such as \\Shipping\MilitarySoftware. 

Setup Printers 
Std-Barc works on many printers supported by Windows.  The best results are found on 

laser and other high resolution (300+ DPI) standard Windows printers and thermal printers 
designed for label printing.  Many thermal transfer printers are supported; contact Mil-Pac for 
information. 

For standard Windows printers, such as laser printers, Std-Barc prints using the Windows 
printer driver for the specific printer.   

For Thermal Printers Std-Barc (version 4.0 and later) prints using the printer 
manufacturer’s printer driver. For Std-Barc versions prior to 4.0, contact Mil-Pac Technology 
Technical Support. 

Set up printer(s) on which you will print labels.  

For Microsoft Windows Standard [plain paper] printers: 
Follow the printer manufacturer instructions. Use the “Print Test Label” feature in the 

Microsoft Windows print driver to make sure you have the printer set up correctly. You can 
also use Notepad or a word processor (such as Microsoft Word) to verify proper printer set up. 

For Thermal and Thermal Transfer printers: 
Follow the printer manufacturer instructions. Use the “Print Test Label” feature in the 

printer manufacturer printer driver to make sure you have the printer set up correctly. The test 
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label will most likely not all fit on the label media, but you should see some text and the 
Microsoft Windows logo.  

Install Std-Barc 
Std-Barc install files are typically distributed either via internet download or CD. 

Installing from Internet Download 
If you received Std-Barc install files via internet download: 

1. Double-click the install file. The install files are in a compressed file that will 
now uncompress. Just click Finish. 

 

2. When the extraction completes, answer “Yes” to the following question. 

3. The Std-Barc install wizard begins. 
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Installing from CD 
If you received Std-Barc install files via CD, insert the CD into your personal 

computer. The Std-Barc install wizard begins. 

1. If more than one product or more than one copy of Std-Barc is provided on the 
disk, select the appropriate one by the serial number assigned to you.  Std-
Barc is licensed by seat, so each computer installed with Std-Barc should use a 
different serial number. 

2. Evaluation copies of Std-Barc do not need to be removed.  Installing the 
licensed copy of the software from the CD-ROM will simply update the 
software, turning it into a fully licensed copy.  Data used during the evaluation 
should not be affected. 

3. Click “Ok” on the initial screen 
of the Std-Barc install wizard. 

4. You can enter a different 
directory/folder in which to 
install Std-Barc or just accept 
the default (recommended). 

5. Click Ok on the final screen. 

6. Std-Barc is now installed. 

 

 

Configure Std-Barc 
There are basically three areas in Std-Barc that may need configuration: 

o Std-Barc operating defaults. 

o Location of files 

o Printers 
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Configure Std-Barc Operating Defaults 
Std-Barc allows the entry of certain default values to guide how it behaves.  

In Std-Barc, click on Options Defaults. 

Enter values in the following fields:  

o Prime Contractor – The data entered in 
these fields will appear as an address that 
can optionally be used on labels. When 
you import DD250 data from another 
source, such as another Mil-Pac 
Technology software application like DD-
FormStation or DD-Master, Std-Barc gives 
you the choice of using the DD250 Ship 
From address or using the address you 
enter here. Additionally, you can check the 
“Always use as Ship-From address” to use 
this data as the default Ship-From address 
and never automatically use the DD250 
Ship-From address.  

o Preservation Method – Enter the default 
value that you would like to appear on all 
Unit and Exterior Containers. If you use 
Commercial Preservation Methods, enter “COM” or leave blank.  

o Print Immediately – There are two ways to print—immediately and to queue. You 
can over-ride this selection for each print job, but this will be the default selection. 
The Std-Barc User Manual contains details about this selection, but basically if 
you plan to print the majority of your labels on sheets of labels, you would most 
likely want to choose to print to queue (uncheck “Print Immediately”). If you plan 
to print the majority of your labels on rolls of labels, such as on a thermal printer, 
you would most likely want to print immediately (check “Print Immediately”).  

o Automatically Assign RFID Tags – There is a setting on RFID versions of labels 
to automatically assign RFID data to the RFID tag or to allow you to manually 
enter RFID data. You would most likely want this set to Automatically Assign 
RFID Tags, since this is the most common use of this setting. 

o Burn RFID Tag – There is a setting on RFID versions of labels to “Burn RFID 
tag,” which is to write RFID data to the tag, or to not write any data to the RFID 
tag. If you most commonly print RFID labels, you would check this option.  

o Generate 96-bit RFIDs – This is provided for backwards compatibility with 
previous generations of RFID tags. Unless you know that you have 64-bit RFID 
tags, you should check this box. 

o Update RLM-Plus Database – If you are using RFID Load Manager+, check this 
box. If you are using the older RFID Load Manager, do not check this box. 
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o Transportation Priority – This is the default transportation priority that will print on 
Military Shipping Labels (MSLs). Typically this is “3” or blank.  

o For blank Mark-For blocks – These fields control what prints in the Ultimate 
Consignee / Mark For Consignee section of the Military Shipment Label, when no 
Mark For information is entered into Std-Barc. Just the DODAAC prints the 
barcoded Ship-To DODAAC in the Consignee section, and is a recommended 
setting. Copy Ship-To Address copies the Ship-To address to the Consignee 
section as well. 

o Automatically assign filenames – Checking the block causes Std-Barc to 
automatically generate file names when saving files, which is the recommended 
setting.  

Configure File Locations 
During pre-installation steps you should have decided where to save Std-Barc data--either 

on the individual user’s/users’ personal computer(s) or on a centralized, networked computer.  

Start Std-Barc, either by double-clicking the Std-Barc icon or through the Start button on 
your personal computer. 

If you are saving Std-Barc Data on a single personal computer (not 
sharing data between multiple computers): 

No file location configuration is necessary. 

If you are sharing Std-Barc data between more than one personal 
computer: 

1. Click Options->Directories. 

2. Enter the mapped network 
folders where you plan to store 
Std-Barc data in both the 
Label Order Directory field and 
the Address Database field. 
This is the network mapped 
drive and folders that you 
should have created during 
the pre-installation steps. This 
must be formatted using 
traditional eight-character 
directory path names, such as 
M:\Shipping\DD250s. Network 
administrators typically assist 
in this step. Mil-Pac software 
does not support UNC 
(Universal Naming 
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Convention) names, such as \\Shipping\MilitarySoftware. 

3. Click Ok. 

4. Click Options->Parts Database. 

5. Enter the mapped network folders 
where you plan to store Std-Barc 
data in the Database Directory field. 
This is the network mapped drive 
and folders that you should have 
created during the pre-installation 
steps. 

6. Click Ok.  

7. Click Options->Paradox Engine. 

8. Enter the mapped network 
folders where you plan to store 
Std-Barc data in the Paradox 
Network Control File Directory 
field and the Application Data 
Directory field. You can just click 
the “Copy Data Path” button to 
copy the Std-Barc data directory 
information into the Application 
Data Directory field. Leave the 
other fields at their default 
values unless instructed to 
change them by Mil-Pac 
technical support. 

9. Click Ok. 

NOTE: In situations in which other Mil-Pac software is installed, such as DD-Master, DD-
Formstation, and RFID Load Manager+, we recommend creating a directory structure as 
follows: 

Network share (such as \\Shipping\MilitarySoftware) which would be mapped to a drive 
letter (such as M:\). 

Std-Barc folder (M:\Std-Barc) 

Std-Barc Data folder (M:\Std-Barc\Data) 

Other Std-Barc sub-folders, as required 

DD-Master folder (M:\DDMaster) 

DD-Master Data folder (M:\DDMaster\Data) 

Other DD-Master sub-folders, as required 

Other Mil-Pac folders, following the same organization as noted above… 
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In this situation, we recommend configuring the Paradox Network Control File Directory for 
all applications to be the root of the network share, M:\ in our above example.  

Configure Std-Barc Printer(s) 
We need to configure Std-Barc to know which printer to use to print each label type, and 

configure a few settings for those printers. 

Label Stock Selection 
Std-Barc includes layouts for popular commercially available label stock.  Each label format 

is associated with a default stock size, appropriate to its data requirements.  Non-standard 
layouts may be added to the list by request.   

Laser stocks are laid out according to standard Avery formats because they are widely 
available and many label stock manufacturers use Avery as a layout standard.  Mil-Pac’s 
identification of label stock sizes by Avery numbers is not a recommendation for their use.  
Nor does Mil-Pac guarantee that labels supplied by any specific manufacturer will meet 
military standards, which in general require labels to use permanent adhesive, with waterproof 
printing on a stock offering high contrast (low opacity). 

Laser vs. Therm  
Std-Barc is designed to print on two kinds of label stock, sheet (“Laser”) labels such as 

those used in laser printers, and roll stock such as used in thermal printers.  Std-Barc refers to 
the first type as Laser stock and the other as Therm stock. RFID is the same as Therm but 
adds the ability to encode RFID tags at the same time that Therm labels are printed. 

The difference between the two is how printers handle them.  Laser labels come several to 
a sheet, and Std-Barc will print to each label on the sheet in succession until it is done or runs 
out of labels on the sheet.  Then it ejects the sheet and loads another, if necessary.   

With Therm stock each label is on its own “sheet” which Std-Barc “ejects” after printing, 
allowing the printer to move to the top of the next one.  Some Therm stock may, in fact, have 
more than one label across, such as a “3-up” roll stock, but it always has just one row per 
“sheet”, and Std-Barc will always print one row of labels then eject, or “form feed” the printer, 
allowing it to line up the next set of labels. 

Printer/Label Setup  
 Std-Barc uses Label Stock names not only to assure proper printing of labels, but to route 

labels to the appropriate printer.  In practice, you could have a different printer set up with 
each kind of label stock used, and Std-Barc will automatically select the appropriate printer 
and apply its specific configuration settings. 

It is typically not necessary to set up printers for Laser Printers. Just select the correct 
printer at the time that you print the labels. If the printed image on Laser-printed labels needs 
some small adjustment, then follow the steps below. Always follow the steps below for 
Thermal Transfer printers. 
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1. Click Options->Printers. 

2. Click the Add button to add a printer configuration. 

3. Highlight the printer name that you created when you installed the printer. 

4. Click the Select 
button. 

5. Fill in these fields: 

o Label Stock – Select 
the label stock that 
you will use from the 
drop down list. 

o Show Label Edges – 
If you need to fine-
tune the position of 
the print on the label, 
you can click this box 
to print a border on the label to make it easier to do this. For normal production 
operation you would typically un-click the option. 

o Printer Type – Select 
Standard Windows 
Printer for laser and 
ink-jet printers. Select 
Thermal Transfer 
Printer for thermal 
transfer printers. 

o Print Adjustment – 
These settings allow 
you to fine-tune the 
position of the print on 
the label. Negative 
numbers move the 
print image up/left and 
positive numbers move 
the print image 
down/right. Example: to 
move the printed image 
up and left ¼ inch, enter 25 in both the vertical and the horizontal fields. Do not 
enter decimal numbers. Suggest leaving these settings at zero until you print 
some labels to see if any fine-tuning is necessary. 

o Thermal Transfer Printer Settings – These are for Thermal/Thermal Transfer 
printers only. 

a. Connection Method – Select Direct to Print SPOOLer and Use RAW 
Spool Data as shown above. 
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b. Thermal Printer Type – Select the printer type. This will likely cause the 
Printer Configuration window to appear; if not, click the “Configure” 
button. 

c. Select the proper options for your printer. NOTE: You should always 
select “Gen2 Label Stock” and “Upgraded Firmware” unless you know 
these are the wrong settings. 

d. Click Ok and Ok again to 
return to the “Assigned 
Printers” window. 

e. Continue to add printers for 
each different label type. 

f. Click Done when you finish.  

g. Click Yes to save the 
configuration. 
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Confirm Installation and Configuration 
Now that we’ve completed the installation and configuration, we need to make sure that 

everything is installed and configured properly. Here are a few tests to complete. 

Print Labels 
1. In Std-Barc, click on File->Open File. 

2. Highlight the SAMPLE file that is provided as part of the Std-Barc install. 

3. Click Open. 

4. Double-Click on the 129MSL or some other label that is a correct size for your label 
stock. 

5. Std-Barc displays the data entry screen for the label.  
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6. Select the proper label stock at 
the bottom of the screen. This 
must be a label stock that you 
selected when you set up your 
printer, meaning that this must 
be a label stock that is in the 
Assigned Printers list that you 
can see when you click 
Options->Printers. 

7. Click Print. A label should print 
on the printer. 

8. Repeat this process for each 
label type for which you set up 
printers. 

Confirm Multi-User Operation 
1. Bring up a label format on a pc.  

2. Make a change to the data on the format.  

3. Save the label.  

4. Open Std-Barc on a different pc.  

5. Bring up the changed label format and make sure the change shows on the screen.  
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Tutorial - Getting Started  

Creating a Unit Container Label  
Creating labels requires just a few simple steps.  Start by clicking on New Label:  

 

The New Label command will present a list of common formats from which to select.  The 
most common starting point is the Unit Container label.   

Click on: 129UCL – MS-129 Unit Container Label and then on [Select]. 

  

 
Note:  Your version of Std-Barc may include more formats than shown in this manual, 
since the software tends to evolve faster than production of the documentation process 
can accommodate. 
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Selecting a new Unit Container Label 
will present a blank dialog into which you 
can enter the data for the item to be 
shipped. We have already done that in the 
example at right. 

To create your own label: 

1. Fill in the blanks.  For help on 
completing the fields, click on 
[Help] or refer to the Unit 
Container Labels description in 
Mil-Pac’s Guide to Mil-Std 129P.  
Your contract may not require 
data for all fields, so skip over 
those that do not apply. 

2. Enter the number of labels to 
be printed in the box next to the 
[Print] button, then click on 
[Print] and choose Print 
Immediately (when prompted). NOTE: The label stock you are printing on, shown in 
the label form, must either be a Laser format (like 2x4 Laser) or be a label stock 
that is set up for a specific printer in Options->Printers. Details on how to set up 
label stock to print on specific thermal transfer printers is in the Std-Barc Installation 
Guide. 

3. Select Yes when asked to Save Changes to Label ?. 

 

Creating Exterior Container Labels  
It is that easy to create your first label in Std-Barc.  Of course, you will probably need to 

create some other formats, such as the Exterior Container Label (XCL). 
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The Unit Container Label (129UCL) just created now appears in the Label Order Item List, 
as shown above.  The next step is to create an Exterior Container Label.  To save time, we 
will simply copy the 129UCL that we just created. 

First, select the Label > Copy Label command: 

 

Then, select the MS-129 
Exterior Container Label.  
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The Unit Label has almost all of the data 
needed for an Exterior Container Label.  So, the 
only thing you would need to enter is the weight 
of the packaged item, as shown here.   

Print the labels just as we did for the Unit 
Container Label. 

 

The Exterior Container Label can print 
as a single 4x6 label (as shown to the left) 
or on separate 2x4-inch labels, as shown 
below.  This allows you to use the same 
label stock for both unit and exterior labels.   
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Creating Military Shipment Labels (MSL) 
The Military Shipment Label (MSL) replaced the standard address label in Revision P of 

Mil-Std-129.  It may have some fields that are unfamilar to you, in which case, refer to the 
lastest revision of Mil-Std-129.  It is available from a number of sources, including the Mil-Pac 
web site.  The following section includes excerpts from the Mil-Std-129.   

Two aspects of the Military Shipment Label distinguish it from other labels: 

o Two-dimensional (2-D) PDF-417 symbol, which is comprised of many small rows 
of data.  In fact, the symbol contains all of the data printed on the label, and then 
some.  The data is organized as a data structure defined by Mil-Std-129.  No 
special action is required by the user to print the 2-D symbol, other entering data 
in the label editor.   

o Piece Number Barcode, which assigns a sequence number to each container in a 
shipment, which is identified by a Transportation Control Number (TCN).  Each 
individual exterior container in a shipment should have an MSL, numbered 1 of n, 
2 of n, n of n, where n is the total number of containers.  Std-Barc automatically 
increments and prints the Piece Number barcode. 

To create an MSL, copy either the Unit Container Label or the Exterior Container Label that 
we created previously and select 129MSL as the label to which we are copying. 

MSL Fields 
The following description is taken from Mil-Std-

129 with some additional instructions specific to Std-
Barc.  Not all fields on the MSL are required for 
every shipment.  Consult with your contract officer or 
quality assurance specialist for assistance.   

The current implementation of the Military 
Shipment Label in Std-Barc is designed only for 
General Cargo.  A Unit Move version can be made 
available on special order. 

Transportation Control Number (TCN). Enter the 
(alphanumeric) TCN For consolidated shipments, 
place a lead TCN in this block. The lead TCN 
shall not duplicate any internally packed TCNs.  
Use the label editor’s TCN Wizard to generate a 
TCN when not supplied by DoD. [17 characters] 

Transportation Account Code (TAC). When 
applicable, enter the TAC for shipments moving 
from POE to POD. For mail and other shipments, 
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leave blank.  Enter TAC on the first line of block.  On RFID tagged labels, separate TAC 
and Type Service with a slash (‘/’) character.  [4 characters] 

Type Service. Enter abbreviation for the type of transportation service to the “Ship To” 
address (e.g., Frt LTL, Air Expss, Expss Mail, TGBL UB, DPM HHG).  The MSL label editor 
includes a drop-down list of appropriate abbreviations.  [Up to 10 characters] 

From. Enter the Consignor DoDAAC/CAGE and in-the-clear address of the shipping activity. 
For mail include the ZIP code. [Up to 3 lines of 35 characters]. 

POE. Enter the three digit air/water Port of Embarkation (POE) code, if applicable. [3 chars] 

Ship To in-the-clear shipping address [5 lines of up to 35 characters]. 

Priority. Enter the applicable transportation priority (TP). TP 1, 2, 3, or 4 (deferred air freight) 
should be clearly identified in the priority block of the MSL using bold text that is 3/4 inch 
high.  [1 digit] 

POD. Enter three-digit air/water Port of Debarkation (POD) port designator, if applicable. In-
the-clear location name may be included. Blank for mail shipments.  [3 characters] 

Project Code. Enter project code, if applicable.  [3 chars] 

Ultimate Consignee/Mark For Consignee. Enter the in-the-clear complete address(s)  and 
the corresponding DoDAAC.  [Up to 5 lines of 35 characters] 

Weight.  Enter actual gross weight (of this piece) in pounds. Round to next whole digit, do not 
use commas or include ‘LB’ or ‘#’.  [Up to 5 digits]. 

RDD. Enter the Required Delivery Date (RDD) in Julian format, or enter the code specified by 
the requisitioner, if appropriate.  Use the RDD Calculator for Julian Dates  [3 digits]. 

Cube. Enter the volume (of this piece) in cubic feet. Round to next whole digit.  Do not include 
‘CU’ or ‘FT’.  Use the Cube Calculator 
to simplify this.  [Up to 4 digits] 

Date Shipped. Enter an in-the-clear date 
(DD/MM/YY or YYYYMMMDD).   

FMS Case Number. Enter as FMS case 
identifier as appropriate.  [3 
characters]. 

Piece of Pieces 
Control 

Number of labels 
to print

Piece Number. Enter the piece number 
(numeric value assigned to this piece) 
of the cargo documented by the TCN 
for this shipment unit. Do not zero fill.  
[Up to 4 digits] 

Total Pieces. Total number (numeric 
value) of pieces documented by the 
TCN for this shipment unit.  [Up to 4 
digits] 
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Printing a Series of MSL Labels 
Printing one MSL is easy.  Set Piece Num and Total Pieces to 1, ignore Auto Increment 

Piece and [Print] 1 label.  Printing three labels, (1 of 3, 2 of 3 and 3 of 3) is not much more 
difficult.  Set the Piece Num to 1 and Total Pieces to 3, enable Auto Increment Piece and 
[Print] 3 labels. 

Printing a series of labels where one or more have different weights and cubes or item data 
counts is a little more difficult.  (We are working on a better method.) 

Let’s say the third container is different.  Start by printing the first two labels:   

Piece Num:     1 
Piece Total:   3 
Auto Increment:  Yes 
Print [ 2 ] labels 

Then, change the Weight, or whatever, and print the last label:   

Piece Num:     3
Piece Total:   3 
Auto Increment:  (ignored) 
Print [ 1 ] label 
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Label Wizards 

 

Each label format has its own specialized editor, like the one shown above for the Unit 
Container Label.  Most have a variety of “wizards” that can help you enter data into the label.  
Clicking on field labels that look like a buttons, will help you complete that field. 

Wizards for Container Labels 
The Unit, Intermediate and Exterior labels have a number of wizards, including: 

Parts Database allows you to store and retrieve parts by NSN and/or Part Number. 

Unit of Issue Codes is a drop-down list of the Unit of Issue codes defined by MS-129. 

Shelf Life generates the proper abbreviations and date formats for the shelf life. 

Serial Number List Editor allows you to edit and manage lists of Serial Numbers. 

Look Up by NSN 

Look Up by P/N 

Unit of Issue 
Codes 

Shelf Life Wizard 

Serial Number 
List Editor 
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Military Shipment Label Wizards 

 

 

 

Address Databases 

TCN Generator 

Cube Calculator 

RDD (Julian 
Date) Calculator 

Method of 
Shipment Codes 

Unit of Issue 
Codes 

 
 

 

 

 

 

 

 

 

 

 

 

The complex Military Shipment Label has an even greater number of wizards than the Unit 
Container and other label formats.  Each can help you create or locate data for the label.  As 
with the other formats, a field label that looks like a button (such as for TCN above) brings up 
its wizard/helper.  The Military Shipment Label wizards include: 

   TCN Generator allows you to create Transportation Control Numbers (TCN) for shipments 
that are FOB Destination, for which you are allowed to create your own TCN so long 
as you can assure that is unique.  The TCN Generator uses the rules defined by the 
Defense Transportation Regulations (DTRs) for doing so, and logs the TCN so you 
can later retrieve information about the shipment. 

   Address Database allows you to quickly retrieve an address you have used and stored in 
the past.  To retrieve an address, enter the DODAAC or CAGE code in the 
appropriate blank and click on [Get].  Leaving the code blank will allow you to browse 
through the list to select an address.  To store an address, simply fill it in, and click on  
[Put]. 

These wizards are explained in more detail in the following sections. 
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Using Label Wizards 
There are wizards which help the user generate data and/or correctly format it for 

compliance with military standards.  The sections that follow describe these wizards and their 
use. 

TCN Generator 
The TCN wizard simplifies the task of creating the Transportation Control Number (TCN) 

for an FOB Destination shipment, or such situation.  While the TCNs for FOB Source 
shipments are routinely provided on contract documents, or by the DCMA, the contractor is 
responsible for generating TCNs when not otherwise provided.   Contractor TCNs are required 
to be unique, and the contractor must be able to retrieve the details for a shipment by its TCN. 

The Defense Transportation Regulations (DTR) provides a guideline for military shippers 
that is commonly recommended for contractors as well, and has been implemented in Std-
Barc.  This creates a tracking number based on the contractor’s CAGE code and the Julian 
date of shipment, which when combined looks like: 1HLD9X4294X001XXX. 

The same TCN must applied to each 
container in a shipment, unless otherwise 
indicated by your contract.  For example, 
say you are shipping 100 widgets in 10 
exterior containers.  The same TCN would 
be used on all ten Military Shipment 
Labels required, and they would be 
numbered piece 1 through 10.  A shipment 
of wombats on the same day would use a 
different TCN number.   

Using the example above the boxes of 
widgets would marked with  

TCN:   1HLD9X4294X001XXX  
Pieces: 1 of 10  ..  10 of 10 

and the wombats would be marked with  

TCN:   1HLD9X4294X002XXX.   
Piece: 1 of 1 
 

25 



Std-Barc                                                                                                                 Label Wizards 
  

Cube Calculator 
The Cube Calculator simplifies the task of 

calculating the size of an exterior container, which 
must be expressed in cubic feet, rounded up to the 
next whole number. 

This illustration shows the entry of the container 
dimensions, which are expressed in inches.  The 
total (actual) number of cubic feet and inches is 
calculated, and then rounded up to the next whole 
cubic foot.  Clicking [Ok] will insert the Cube into 
the current label. 

 

 

Required Delivery Date (RDD) 
The RDD Calculator converts a standard MM/DD/YY date into the Julian Date format 

required for certain labels, such as the Military Shipment Label. 
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Method of Shipment Codes 
The Military Shipment Label (MSL) 

includes a table for Method of 
Shipment codes.  The left column 
shows the Mil-Std-129 code, as you 
might see on a DD250.  The right 
column shows standardized 
abbreviations that fit into the 10-
character field that is encoded into the 
2D-symbol on the MSL. 

 

 

 

 

 

 Unit of Issue Lookup 
Many labels include a Unit of Issue lookup, 

which allows you to find less common UOI/UM 
codes defined by Mil-Std-129.  
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Parts Database 
 

 
The parts database allows you to store item data that you can then use in a variety of label 

formats.  The Parts Database is accessed via the [Browse] button found on most format 
editors, like the one below. 

The easiest way to save data into the database is to enter the information into a label 
format editor as you create a label, then click on [Save Part].  You can also click on [Copy] or 
[New] while browsing the database.  

Once saved, the item can be retrieved 
by either the NSN or the Part Number, or 
by clicking on [Browse] to scan through 
the items in the database.   

The fastest way is to simply enter the 
NSN or Part Number into the appropriate 
field on a label and click on either [Find 
NSN] or [Part Num], respectively.  
Clicking on either of those buttons when 
the corresponding field is blank will bring 
up a list of Part Numbers / NSNs that you 
can browse through to find the item. 
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Address Databases 

 

Address Databases 

Each of the address blocks is supported by the Address Database. The Military Shipment 
Label has three address blocks. With a [Get] and [Put] for each address.  To save a part, 
simply enter the address and its CAGE or DODAAC into the appropriate block, and then click 
on [Put].  Clicking on [Get] will retrieve the address stored for the Address ID (CAGE or 

DODAAC).  If the Address 
ID is blank you will be 
shown the address 
browser, from which you 
can select an address. 
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Printing Labels 

There are two ways to print labels in Std-Barc, the first of which is to select a label from the 
list, and then select Print > Selected Labels.  This example will print four “1 EA” Exterior 
Container (129XCL) Labels.  

The other way to print labels is to do so while editing the label.  We double-clicked on the 
entry above, to bring up the label.  Now just click on the [Print] button.  The number of labels 
to be printed is next to the [Print] button.  In both cases we would get the same result, four 
labels with the quantity “1 EA” on them, printed on 2”x4” Laser stock.   

Printing Immediately or To Queue 
You may have noticed that each time you print you are presented with a choice: 

 

The Print Immediately option does just that, immediately sending the label to the printer.  
However, one of the handy features of Std-Barc is its ability to collect labels in its queue, also 
referred to as a SPOOL.  Doing this allows you to print some Unit labels, then some Exterior 
labels and Serial Number labels, and finally some NCC labels, and have Std-Barc print them 
all on the same label sheet, or at least as few label sheets as possible.  This saves time and 
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money. If you are printing labels of different sizes, Std-Barc will collect them for printing on the 
appropriate label stock. 

Once you have queued up all the labels you want to print, simply use the Print > Queued 
Labels command to print them out: 

 

Selecting Print > Queued Labels brings up the Label Stock to Print dialog.  In the 
example shown below, we can see that there are three labels waiting in the queue to be 
printed on 2x4-inch laser stock.  We can also see one 6x4-inch label is waiting.  That was a 
Military Shipment Label that we had sent to the queue earlier.  You can also use this handy 
feature of Std-Barc to gather up labels for multiple shipments, allowing you to minimize the 
number of label sheets used on small shipments. 

 

Another way to collect different labels onto the same page is to select multiple labels you 
want to print, then select the Print > Selected Labels command. 
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Creating a Label File 

There are several different ways to create a set of labels in Std-Barc:  

o Starting with a Blank File:  Creates an empty file with new labels created from 
information entered by the user. 

o Copying an Existing Label File:  The Std-Barc user can take advantage of 
data entered for similar shipments by recycling an existing label file. 

o Importing Mil-Pac DD250s:  This method allows the user to eliminate almost 
all data entry by utilizing the shipment data that has already been entered 
onto a DD250 created by any Mil-Pac DD250 product; i.e. FormStation, 
DD-Master, ShipMan and EDiForm.  

o Importing Data From Other Systems:  Std-Barc can create a label order from 
shipment data supplied by other business and enterprise systems in 
plain-text format. 
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Starting with a New Label File
Use the File > New File to manually create a new label file (then Label > New Label):   

Use Label>New Label to 
create new labels,   
 
Use Label>Copy Label to 
copy similar labels. 

 

 

You can save your set of 
labels when you are done, 
using File>Save.  Or just 
throw them away by starting a 
new set (File>New, Open, 
Browse) or exiting out of Std-
Barc. 

File names are limited in 
length (with a maximum of 
eight characters, no spaces, 
etc.).  However, it easy to find 
them by contract, TCN or by 
picking from the Recent Files 
list. 
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Copying an Existing Label File 
One quick way to create labels is to use labels from a previous shipment, or a template file 

that you might have created.  Open the file with File > Open File or File > Recent Files.  You 
will be presented with a list of files, ordered by contract and order number.  The Browse 
command allows you to search by file name, and in folders other than your designated data 
directory. 

 

File > Recent Files lists only 
the last ten files accessed. 

Click Read-Only to protect 
the original file from change. 

 

 

 

With your template file 
open, you can either change 
the existing labels and reprint 
them, or use Label > Copy 
Label to create new versions 
of existing labels. 
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Generating Labels from Mil-Pac DD250s 
Std-Barc has been designed to take utmost advantage of DD250 documents created by 

FormStation and DD-Master. Given that most of the data on Mil-Std-129/130 labels is found 
on a DD250, this capability can save a considerable amount of time and eliminate costly data-
entry errors. 

All Mil-Pac DD250 products can easily send their DD250s to Std-Barc.  The DD250 
programs can run Std-Barc itself to quickly create the labels for a shipment, provided both 
programs are on the same PC.  Or the DD250 can simply be deposited into Std-Barc’s In-Box 
for later processing, at the user’s convenience.  If Std-Barc is on a different machine than the 
originator, the DD250 must be placed into the Std-Barc In-Box, which would simply be a 
shared network folder.  

 
 

Click here to generate barcode 
labels for a DD250 

(This example shows 
FormStation, others are similar) 
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Selecting Labels to Automatically Create  
 The first thing Std-Barc does with an imported file is to confirm which label formats you 

wish to create.  The ‘x’ in the right column in the figure indicate that for each item in the 
DD250, Std-Barc will create Unit Container, Exterior Container and Exterior Barcoded NSN-
Contract-CAGE (NCC) labels, along with both the standard and RFID version of the Military 
Shipment Label (MSL). 

We do not need both kinds of Military Shipment Label, so we will turn off the RFID version 
for now.  Do this by double-clicking on the RFID Military Shipment Label line (or click once, 
then click on [Select]).  Click off the Create format when importing files option.  Use the 

same procedure to enable other 
desired formats that are not 
currently selected for automatic 
generation.  Remember, you can 
always create other formats or 
delete unwanted ones later, using 
the New Label and/or Copy Label 
commands.  

 

 

Click here to control 
automatic format creation 

during data import.

 
Click on [Done] when you are satisfied with the label formats selected for automatic 

generation from the imported data.  Then, there are just a couple more easy steps. 

   Hint:   You can set up the default selection of labels to created during import, in the 
Options > Labels dialog.  You can also select the default label stock for each. 
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Before automatically 
generating labels from 
imported data, Std-Barc will 
ask you to supply a couple 
more pieces of data.  The first 
is Packaging Date, which is 
something not normally found 
on a DD250 or in imported 
data.  This date, expressed 
MM/YY, is the date when the 
Mil-Std-2073 Method of 
Preservation was applied to the 
item(s), as required by the 
contract.  If Mil-Std packaging 
was not required, simply enter 
the date of packaging.  For your convenience, this date will be applied to each label format 
generated, but can be set individually for each label. 

We must also quickly verify the Ship From address to be used on the Military Shipment 
Label.  It is not always possible to accurately determine this address from imported data, so 
Std-Barc will make its best guess, and leave it to the user to confirm the address to be used.   

 
 
Hint: The Default Ship-From Address is 

created in Options > Defaults. 
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Printing Automatically Generated Labels 
With a few clicks you can go from a DD250 to all the barcode labels for a shipment, and with a 
simple Print > Selected Labels, you could be done.  Although first, you should review each 
label to make sure the data is correct.  For some formats, you will still need to add some data, 
such as Weight on the Exterior Container Label, and several fields on the Military Shipment 
Label.  Then you can print them all. 

Manually Selecting Files to Import 
You may find it is easier to just send DD250 files to Std-Barc, and then open them later to 

create labels.  When the DD250s are created on a different machine, this is the only option.   

To open a file that has been placed in the Std-Barc In-Box, just select File > Import File.  
A list of the data files, by Contract, Order and Shipment numbers, along with a Reference 
Number that may have been assigned are listed in the In-Box Preview.    
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Import data files that are not located in the Std-Barc In-Box can be located and opened 
using the [Browse] button.  Be careful using this feature, because Std-Barc may delete import 
files once it has processed it. 
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Configuring Mil-Pac DD250 Software 
Mil-Pac DD250 products 

(FormStation and DD-Master) come 
ready to send DD250s to Std-Barc 
for automated label generation.  
This feature is generally disabled by 
default (the None option checked) 
so as to prevent any undesired 
results should the [Barcodes] button 
be clicked accidentally.   

 

As an example, to configure 
FormStation go to its Options > 
Barcoding dialog.  Click on the 
Std-Barc option of Run Barcode 
Application.  If you would rather just 
export the data to Std-Barc to be 
processed later, or if Std-Barc is on 
a different machine, click on Std-
Barc under Create Import File Only.  
Some earlier versions of DD250 
software may not have an option to 
allow you to run Std-Barc, and thus, 
your choice would be to create 
Create Import File Only, sending 
the data to C:\Std-Barc\In-Box. 

When Std-Barc and the DD250 software are on different machines it will be necessary to 
create a shared network folder for the purposes of passing the DD250 to Std-Barc.  The 
network folder should be mapped so that it can be addressed with a drive letter and 8.3-style 
path names, e.g. S:\shipping\labels\in-box. 

The Std-Barc user must have read-write permission for the In-Box folder so that Std-Barc 
can delete import files as they are processed.  Otherwise, the list of files to be processed will 
continue to grow.  
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Importing From Other Systems 

Std-Barc supports several different methods of importing data from non-Mil-Pac systems, 
both to generate labels for a shipment, and to populate its parts and address databases. 

Importing Data for Shipment Labels 
Std-Barc’s plain-text import capability allows users of other software, including enterprise 

systems, to automatically create Mil-Std-129 labels for a shipment.  Supplied with externally 
generated address and line item data, Std-Barc can greatly speed label generation and 
increase its accuracy.  This capability makes Std-Barc an excellent back-end barcode labeling 
application. 

Data can be passed into Std-Barc in a plain-text file, in what is referred to as M12 format, 
defined in the Import File Specification found on the Mil-Pac Technology website.  Your 
software may not be able to export data in the M12 format. In this case, you may need to 
contact your technical support provider or Mil-Pac Technical Support for help with interfacing 
your system.  A simple utility program may be necessary to convert data from a third-party 
application.  Import filters for Excel/Access type comma separated (CSV) files are available 
upon request. 

The first step before importing data from another system is to designate a directory in 
which to receive imported files, then inform Std-Barc to look there.  Do this by setting the 
Options > Directories In-Box to this directory path (see Directory Locations).  If both 
applications are on the same computer, simply use the In-Box directory path that is created 
when Std-Barc is installed (normally C:\Std-Barc\In-Box).  Imported data can also be 
provided on a floppy disk. Directory paths should be to mapped drives, and expressed in 
legacy 8.3 format, e.g. X:\shared\shipping\label\in-box. 

To process an imported file, start by using the File > Import File command.  A list of files 
waiting in the In-Box will be shown.  Select one of them and a new label order will be created 
from the file’s data.   

Refer to the previous section entitled Selecting Labels to Automatically Create, for more 
details on the use of imported shipment data. 
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Importing Into Parts Database 
Std-Barc can import data in Excel/Access type comma separated (CSV) files into its Parts 

Database   File data columns can be in any order, such as: 

Part Number,Description,NSN 
12549784,LOCK ASSEMBLY,1992-01-233-1223 
12901254,"BOX,AMMUNITION STOW",1992-01-233-8887 
12549108,"CHUTE,AMMUNITION",1946-01-552-1996 
12549716,TRIGGER ASSEMBLY,1992-01-538-0087 
12932161,"SUPPORT,CHUTE AMMUN",1255-01-669-4423 

with column headings optional.  The import file does not have to have all of the same data 
fields as the database itself.  Use the Import File Mapper to interface the file.  

Import File Mapping 
    The Import File Mapping enables Std-Barc to relate each column of import data to the 

fields in the Parts Database.  The figure below shows after we have opened the file on the 
previous page.  The left windowpane shows the columns in the file.  The right pane shows all 
of the Parts Database fields.  Column numbers starting with an ‘x’ have yet to be mapped, and 
are displayed with their default mappings.   

 The example above, the Part Number columns (01) have already mapped.  We are about 
to map the import column named Vendor # (03) with the database field pntItemNSN (x03).  
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Clicking [Set] would do so.  Next we would match Description (02) with pntItemName (x04) 
and click again on [Set]. 

If your import file does not have column headings, you will be shown an a row of data to 
use for mapping purposes.  You can click on [Next] to cycle through import data records to 
find one with data that you can recognize. 

It is not necessary to supply import data for every database field.  For some fields it makes 
sense to use default values.  To do this, select the database field in the right pane, and then 
enter a value into Default Value, and click on [Set].  This has already been done in the 
example for MfrCAGE, Item UOI, Preservation Method, and Condition Code. 

The CSV Heading is the column heading (first line) that would be generated for each field 
when exporting the Parts Database. 
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Label Formats 

There are many different label formats to select from whenever you create a new blank 
label, create a copy of a label, or change the format of an existing label.  The Label Stock 
Column shows the default for each format.  It can be changed for each individual instance of a 
label format.  The default label stock for each format is set in Options > Labels. 

 

Label formats are categorized into order to make finding them easier. Click on one of the 
category buttons: [More], [RFID] , [HazMat] or [Special] to see other categories.  Click on 
[Common] to return to the list above.  Clicking on the [All] button will display all categories. 

A list of currently supported label formats starts on the next page.  

Std-Barc Label Formats 
This list may vary somewhat from your software version, as Mil-Pac maintains the formats 
meet current defense industry requirements. At the time this manual was published the 
following formats were supported: 
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Format ID Horizontal 
Dimension 

Vertical 
Dimension 

Format Description 

Unit Containers 
129UCL 4.00 2.00 MS-129 Unit Container Label 
129UCLSN 4.00 3.00 MS-129 Unit Cntr, Barcoded SN 
129UCLUI 4.00 3.00 MS-129 Unit Cntr, Barcoded SN/UID 
129UCLs 2.66 2.00 MS-129 Small Unit Cntr Label 
129UCL 3.00 2.00 MS-129 Small Unit Cntr Label 
129UID1R 4.00 1.00 MS-129 RFID UID-Unit Construct 1 
129UID2R 4.00 1.00 MS-129 RFID UID-Unit Construct 2 
Intermediate Containers 
129ICL 4.00 2.00 MS-129 Intermediate Cntr Label 
Exterior Containers 
129XCL 3.90 2.00 MS-129 Exterior Container Label 
129XCLb 3.90 3.00 MS-129 Extr Cntr with NSN Barcode 
129XCL2b 3.90 3.00 MS-129 Extr Cntr with NSN/PIIN Barcodes 
129XCL 3.00 2.00 MS-129 Exterior Container Label 
129XCLb 3.00 3.00 MS-129 Extr Cntr with NSN Barcode 
129XCL2b 3.00 3.00 MS-129 Extr Cntr with NSN/PIIN Barcodes 
129XCL3b 4.00 6.00 MS-129 Extr Cntr with NSN/PIIN/SN Barcodes 
129XCL4b 4.00 6.00 MS-129 Extr with NSN/PIIN/CAGE/SN Barcodes 
129XCL4b 4.00 5.00 MS-129 Extr with NSN/PIIN/CAGE/SN Barcodes 
129XCL4R 4.00 6.00 MS-129 Extr with NSN/PIIN/CAGE/SN Barcodes 
129XCL4R 4.00 5.00 MS-129 Extr with NSN/PIIN/CAGE/SN Barcodes 
129XC2D 4.00 4.00 MS-129 Extr Cntr with 2D Symbol 
129XC2DR 4.00 4.00 MS-129 Extr Cntr with 2D Symbol 
129NCC 3.90 2.00 MS-129 NSN/Contract/CAGE Barcodes 
129NCC 3.90 3.00 MS-129 NSN/Contract/CAGE Barcodes 
129NCC 2.90 2.00 MS-129 NSN/Contract/CAGE Barcodes 
129NCC 2.90 3.00 MS-129 NSN/Contract/CAGE Barcodes 
129NCCRF 3.90 2.00 MS-129 NSN/Contract/CAGE Barcodes(RF) 
129NCCRF 3.90 3.00 MS-129 NSN/Contract/CAGE Barcodes(RF) 
129SNL 8.00 10.00 Mil-Std-129 Barcoded Serial Number List 
129CRX 8.00 10.00 MS-129 Exterior Crate Label(8x11) 
129CRXCT 8.00 10.00 MS-129 Clothing/Textiles Crate Label(8x11) 
Hazardous Material 
129HXCSN 3.90 3.00 MS-129 HazMat Exterior Cntr Label 
129HXC 3.90 2.00 MS-129 HazMat Extr Cntr - No SerNo 
129Ammo1 4.00 4.00 Ammo/Explosives Load Label 
Military Shipment Labels (MSL) 
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Format ID Horizontal 
Dimension

Vertical Format Description 
Dimension

129MSL 4.00 6.00 MS-129 Military Shipment Label 
129MSLRF 4.00 6.00 MS-129 RFID Military Shipment Label 
DLA and DVD 
129DLA 4.00 3.00 MS-129 DLA 4-Bar Label 
129DLA 4.00 2.00 MS-129 DLA 4-Bar Label 
DSCDVD1 4.00 2.00 DVD Label(MS-129P) 
DSCDVD1 4.00 3.00 DVD Label(MS-129P) 
GSA-XCL 4.00 6.00 GSA Extr Cntr / Trans Pkg Label 
UID  
130UID1 4.00 2.00 MS-130 UID Construct 1 
130UID1H 4.00 1.00 MS-130 UID Construct 1H 
130UID1 3.00 2.00 MS-130 UID Construct 1 
130UID1H 3.00 1.00 MS-130 UID Construct 1H 
130UID2 4.00 2.00 MS-130 UID Construct 2 
130UID2H 4.00 1.00 MS-130 UID Construct 2H 
130UID2 3.00 2.00 MS-130 UID Construct 2 
130UID2H 3.00 1.00 MS-130 UID Construct 2H 
130UID1D 1.00 0.00 MS-130 UID Mark-Only Type 1 
130UID2D 1.00 0.00 MS-130 UID Mark-Only Type 2 
130CPNH 3.00 1.00 MS-130 UID Current Part Num H 
130CPN 4.00 1.00 MS-130 UID Current Part Num 
130CPN 3.00 1.00 MS-130 UID Current Part Num 
130CPNH 4.00 1.00 MS-130 UID Current Part Num H 
129UIDCL 4.00 2.00 UID 2D Label 
Miscellaneous 
129Item 4.00 1.00 MS-129 Item NSN Label 
129Item 4.00 2.00 MS-129 Item NSN Label 
129Addr 4.00 2.00 MS-129 Ship-To Address Label 
129Ship2 4.00 3.00 MS-129 Ship-To/MarkFor Label 
Gen3BC 4.00 2.00 Generic 3 Barcode Label 
Gen4BC 4.00 3.00 Generic 4 Barcode Label 
Gen3NoHR 4.00 2.00 Generic 3 Barcode (No HRI) 
Gen4NoHR 4.00 3.00 Generic 4 Barcode (No HRI) 
Gen4BC 4.00 6.00 Generic 4 Barcode Label 
AutoTxt1 4.00 6.00 Auto-Fill Text Label (Internal Use) 
GenTxt-0 4.00 2.00 General Purpose Text Label 
GenTxt-1 4.00 2.00 General Purpose Label with 1 Barcode 
GenTxt-2 4.00 3.00 General Purpose Label with 2 Barcode2 
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Format ID Horizontal 
Dimension 

Vertical Format Description 
Dimension 

GenTxt-2 4.00 2.00 General Purpose Label with 2 Barcode2 
SNTxtD1 4.00 2.00 Generic S/N Barcode Label (DRS Variant) 
ArmyInv1 3.00 1.00 Army Inventory Tag (Style 1) 
Boe3-301 4.00 6.00 Boeing 3.301B (Douglas) Shipping Label 
Oshkosh1 4.00 6.00 Oshkosh Basic Label 
Generic RFID 
129RFTag 4.00 2.00 MS-129 Generic RFID Tag 
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Other Topics 

RFID Labels 
What makes an RFID label different from other labels is the very thin chip and antenna that 

are embedded in each label.  These labels are designed to work with RFID readers, which 
send a radio frequency signal to the RF chip causing it to respond with some data.  In the 
current DOD implementation, this data is simply an identifier (like a license plate) that you 
have assigned to a package that you have shipped.   

RFID tags are really little different than 
the tracking number barcodes put on 
commercially shipped packages.  But what 
makes them very useful to the DOD is the 
way they are used.  When you send an 
RFID-tagged container, you must also tell 
DOD what is in the container, using an 
Advance Shipment Notice (ASN) or by 
entering the data into the WAWF web 
interface.  When an RFID-tagged container 
arrives at the destination, the receiver knows 
that they have received a certain number of 
specific line items (CLIN) shipped in a 
specified shipment number for a specified 
contract number.  All this without having to 
scan any barcodes on any boxes. 

The actual appearance of a label with an 
RFID tag is not defined by Mil-Std-129.  The 
tag itself is a thin strip approximately four 
inches by one-half inch.  It can be a plain, 
unmarked tag, or it can be embedded in an 
Exterior Container Label (XCL) or Military 
Shipment Label (MSL).  It can also be 
embedded in a generic non-Mil-Std-129 
label.   

Std-Barc supports a variety of RFID 
formats.  Each approach has its own 
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advantages.  Encoding the RFID tag at the same time the XCL and/or MSL is printed allows 
Std-Barc to collect the data necessary to create the Advance Shipment Notice (ASN), which is 
sent ahead of your shipment to inform the receiver of the contents of each pallet and 
container.  The generic label formats can be independent of a specific contract and/or 
shipment, so they may be printed separately, and then applied as needed for different 
shipments and contracts. 

Generating an RFID-tagged label is not as difficult as it may seem. It does require an 
RFID-capable printer.  Std-Barc supports the most popular RFID printers. 

The label editors for the RFID-
tagged versions of the Exterior 
Container Label and the Military 
Shipment Label are distinguished by 
the RFID section on the right, which 
controls the RFID-chip programming.   

The relevant controls to be set are: 

RFID Container Type – is the type of 
container to which this RFID tag 
will be attached. 

Auto-Print RFID Pallet Labels – See 
the separate section on this topic 
for details. 

Ship From – is the CAGE code for the 
entity that is assigning the RFID-tags, and is responsible to ensure that they are unique.  
Generally, this will be the prime contractor.  The nature of the ASN, however, makes it 
feasible for third-party shippers to assign RFID tags and submit ASNs for shipments 
without knowing many specific contract details. 

RFID Tag ID Assignment – would generally be set to Automatic, allowing Std-Barc to 
sequentially allocate RFIDs.  However, should you wish to use a specific ID, perhaps to 
create a replacement label, you can set this option to Manual, and fill in the blank. 

RFID Tag Programming – determines whether or not the printer will be instructed to encode 
the embedded RF chip.  Generally this will be set to Burn/Verify RFID Chip.  However, if 
you are using a non-RFID thermal transfer printer and a separate encoder, set the option 
to Print Tag Data Only. The Print-Only option used with the Generic RFID-Tag format 
would allow you to use RFID encoders that can read the RFID from the linear barcode and 
use that ID for encoding the RF chip. 

RFID Verification 
RFID-capable thermal transfer printers include a reader as part of the encoder.  This allows 

the printer to verify that the RFID data was successfully encoded in the tag.  Std-Barc fully 
utilizes this feature, actually printing on the label the RFID that was read from the tag.  Though 
the specifics vary with manufacturer, Std-Barc first encodes the RF chip with the tag number 
(ID), then reads the RFID tag and prints the ID on the label.  Labels that fail verification are 
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automatically printed with VOID in place of the ID, or otherwise marked as invalid by the 
printer. 

Advance Shipment Notice (ASN) Preparation 
A requirement for RFID-compliance is the submittal to Wide Area Workflow (WAWF) of a 

list of the containers shipped, including the following data for each one: 

o RFID tag number 

o Container Type (Pallet, Case or UID-Unit) 

o Contract Line Item Number(s) (CLIN) 

o Quantity of CLIN 

When exterior containers (cases) are placed onto pallets, and/or when UID-Units are 
placed into cases, the relationship between all three RFID-tagged container types must also 
be submitted.   

All of this data, referred to as the Load Configuration, is necessary to allow the receiving 
activity to know what is in each of the containers and on each of the pallets it receives. The 
Load Configuration can be manually entered into the WAWF web interface, or via an 
electronic transaction known as an Advance Shipment Notice (ASN). 

Whenever Std-Barc generates an RFID-tagged label, it saves the contract and shipment 
information necessary to create the ASN. This data is then used by Mil-Pac’s RFID Load 
Manager software to create and transmit the Advance Shipment Notice to WAWF. 

To view and manage the RFID data saved by Std-Barc, click on File->Databases->RFID 
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Database->Browse RFID Pack Data. 

This example shows a shipment of 44 cases on 4 pallets. Double-click any pallet or case 
for more information or to modify the entry. 

Filtering Enabled is turned on by default and set to the current shipment. You can change 
these values to see different data, or turn filtering off altogether to see all data for all 
shipments. 

Select any one or more entries and click on the following buttons: 

• Copy (may only be used on one pallet or case at a time) – creates a copy of the 
selected entry, allowing you to change data for the new entry. 

• Modify – changes data for the selected entry, such as contract, order, shipment 
clin, quantity, unit of issue, and pallet or case assignment. 

• Delete – permanently deletes the selected entries. NOTE: There is no reversing 
this action. 

• Archive – permanently archives the selected entries. This can clean up the active 
list of RFID data, but still allow view-only access to the archived entries. 

• Pack In/On (Case or Pallet) – Allows you to associate Unit RFID tags with Case or 
Pallet RFID tags, and to associated Case RFID tags with Pallet RFID tags. You 
can also break these associations. 

Sort View By changes the sort order for the displayed data. 

UID (Unique Identification) 
The government UID mandate consists of four basic elements—mark the part, mark the 

shipping container, register the UID, and perhaps to report how the UID shipment is 
configured. Mil-Pac software can assist with all of these 
elements. Std-Barc can print a limited number of part mark 
labels, has robust shipping container labeling capability and 
can associate UID data to RFID data when that is 
appropriate. 

Std-Barc can print UID labels on thermal transfer 
printers. If the part to be marked requires other marking 
methods, such as dot-peen or laser etch, then that would 
need to be done independent of Std-Barc. To print UID 
labels on thermal transfer printers, simply create a new label 
as you would with any other label, selecting a label format 
from the UID label group. 

To print UID container labels, you can type serial 
numbers into a label editor or bring in serial numbers from a 
Mil-Pac Technology Forms Automation application (like DD-
Master or DD-Formstation), as described in the section titled 
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Generating Labels from Mil-Pac DD250s on page 35. For UID Construct 2, simply check box 
“UID Type 2” to use the prime CAGE code, the CLIN part number and the list of serial 
numbers to generate a list of UIDs to print.  

 When a contract calls for both UID and RFID, the Advance Shipment Notice (described in 
section titled Advance Shipment Notice (ASN) Preparation, page 50) must contain both RFID 
and UID data. Std-Barc can automatically associate UIDs to the RFIDs. Simply print one RFID 
container label for each UID marked part. If you need to put more than one UID marked part in 
each RFID marked container, contact Mil-Pac Technology Technical Support for guidance.   
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Serial Number Processing 
Labels can be printed with serial numbers that are either sequentially generated or taken 

from a list.  These serial numbers are entered with the other information describing an item 
using the Edit Line Item Data dialog. 

Sequential Serial Number Generation 

 Std-Barc can automatically increment serial numbers, as long as they meet two criteria. 
They must be no more than twenty-five (25) characters in length, and the incremented part 
must be at the end of the string.  The remainder can be composed of any other characters. 
Here are several examples: WDG001018; 351-135155; A-020535; or 01-BETA-01235. 

Enter first serial 

Check this box 
for incremental 
serial numbers. 

number here. 

To generate labels with sequential serial numbers, enter the first one in the Serial Num 
field and check the Auto Increment S/N’s box.  Std-Barc will increment the serial numbers as 
the labels are printed. 
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Non-Sequential Serial Numbers 

Std-Barc can also handle lists of serial numbers that appear individually in any order and 
may include ranges of numbers.  These are entered into Std-Barc by clicking on the Serial 
Num button, which brings up the Serial Number List dialog. 

 Individual numbers can be 
separated by spaces, commas or 
placed on individual lines.  Ranges 
are separated by either a dash or 
the word “thru” with a space on 
either side. The following example 
represents several samples of 
acceptable styles of listing serial 
numbers. 

Lists can be entered in any 
desired order and will print in the 
order they are entered.  The list 
processor will count the items in the 
list and warn you if it does not 
match the quantity to be shipped.  If 
ranges are used, they must meet 
the same criteria described for 
automatically incremented serial 
numbers; the numbers must be no 
more than twenty-five (25) 
characters in length, and the 
incremented part must be at the end of the string. 

NOTE: The dash used to separate a range of serial numbers must be preceded and 
followed by a space. This is acceptable RD9982-0012 – RD9982-0020. This is not acceptable 
RD9982-0012–RD9982-0020. In the first example, RD9982-0012 is the first serial number in 
the range followed by space dash space and then followed by RD9982-0020, which is the last 
serial number in the range. In the second, unacceptable example, there are no spaces 
surrounding the dash, so Std-Barc just thinks that the range is one long serial number. Pay 
attention to the count field and compare that to the number of serial numbers that you expect. 
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Paradox Engine Configuration 

Paradox Overview 
Many Mil-Pac applications use Paradox databases to manage many types of data seen by 

the user.  Generally speaking, Paradox Engine configuration must be considered only 
whenever one or more of the following conditions apply: 

1. Databases are stored on a network and shared with others 

2. Databases are moved to a new location or machine 

3. Windows XP (or other versions requiring administrative rights) is used. 

Paradox Engine Lock Files 
Paradox creates two types of lock files in order to manage databases:  

NET files - are used to identify the various users of a database, so as to know who is 
using each record.  These files, referred to as the Network Control Files, are 
named PARADOX.NET and PDOXUSRS.NET. 

LCK files - are hold the current locks placed on database records by the various users 
identified by the NET files.  The LOCK files keep users from changing the 
same records simultaneously.  These files are named PARADOX.LCK and 
PDOXUSRS.LCK. 

These lock files are transient files and can be deleted without problem, as long as the 
databases are not currently in use.  In many cases, obsolete or invalid lock files are the source 
of database access errors and simply removing them solves the problem. 
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Sharing Databases on a Network Drive 
Sharing databases used by Mil-Pac applications is fairly simple, although the assistance of 

a network administrator may be required.  First a network directory is defined that is 
accessible to all users.  Then a drive mapping is established using a traditional eight-character 
directory path names, such as M:\Shipping\DD250s.  This is entered into the General 
Configuration Options of the application to be shared.   

Next the Paradox Engine must be told where to store its Network Control (.NET) File(s). 
This can be on any shared directory; one of the shared application data directories will work 
just fine.  This can be set with the Mil-Pac PXConfig Tool.   

Moving Databases to a New Machine or Network Location 
Moving databases is simple, yet also the common cause of Paradox access errors.  First it 

is important to remember that Paradox tables consist of at least two, and often three files, all 
with the same name.  The extensions of these files are .PX, .DB and .MB.  The FormStation 
directory consists of, for example, FS-IDX.PX, FS-IDX.DB and FS-IDX.MB.  In some rare 
cases there will not be an MB file.  It is important to move the entire set of files at the same 
time.   

The final step is to remove the lock files. as they will cause the database to be inaccessible 
in its new location.   The PXConfig Configuration Dialog can do this for you. 

These same steps should be followed when moving a database from a local drive to a 
network directory.  First it is important to follow the steps on database sharing above.   

Using Paradox on Windows XP  
Paradox-based applications such as Mil-Pac software will work on Windows XP.  However, 

if you are not are operating with administrator privileges, the default Paradox configuration 
must first be altered.  This is something that is simple to do with PXConfig.   

The problem with Paradox and XP is that Paradox wants to store its Network Control 
(.NET) files in the root directory, which XP does not like, and in order to change that the 
application must change WIN.INI, something that XP allows only administrators to do.   

To solve these two problems, run PXConfig as the administrator (right-click on icon, and 
select Run-As), then: 

1. Click on [Copy Data Path] which will tell Paradox to use the application database 
folder for its Network Control (.NET) files. 

2. Click on [Remove Lock Files] to remove any persistent lock files.   

Once the Paradox Engine is set to put its Network Control Files in other than the root 
directory, the application should work fine.  Of course, locating the database and the Network 
Control Files on a shared network drive by following the steps above works as well.   
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Glossary of Std-Barc Terms 

CAGE 

A Commercial and Government Entity (CAGE) is the code assigned by the Government 
to identify an address of a commercial or government entity.  Formally referred to as FSCM 
codes.  See also:  DODAAC. 

Contract Line Item (CLIN) 

The Contract Line Item (Number) is the basic deliverable unit of a contract, designating a 
single NSN or item description.  The CLIN can be found in the contract schedule immediately 
to the left of the NSN and/or item description.  CLINs are always four numeric digits, from 
‘0001’ to ‘9999’.  Sub-CLINs are noted by the addition of two alphabetic characters at the end 
of the CLIN, e.g. ‘0001AB’. 

Contract Sub-line Item (Sub-CLIN) 

Contract sub-line items provide a further subdivision of the basic contract line item when 
it is necessary for contract performance or administration purposes to separately identify 
subordinate requirements.  There are only two categories of contract sub-lines: 
 

(a)  The first category comprises those sub-line items that are included in the PIIN for 
information purposes only and are identified by a numeric suffix.  These sub-line items 
are an integral part of the associated contract line item but shall not be scheduled 
separately for delivery, separately identified for shipment or performance or separately 
priced for payment purposes. 
 
(b)  The second category comprises those sub-line items that have a separate delivery 
schedule, require separate identification at the time of shipment or performance and/or 
are separately priced for payment purposes.  These sub-line items are identified by an 
alpha suffix. 

DD-FormStation 

DD-FormStation is a Mil-Pac Technology electronic forms application, which generates 
documents on forms such as the DD250 and DD1149.  DD250s created by the DD-
FormStation can be imported into the Std-Barc to automatically generate LOGMARS labels. 
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DODAAC 

A Department of Defense Activity Address Code (DoDAAC) is a distinct six-position 
alphanumeric code assigned to identify specific units, activities, or organizations as found in 
the Department of Defense Activity Address Directory. The DoDAAC may also be found in the 
acquisition document “SHIP TO” information. 

In-Box (Std-Barc) 

The In-Box is a shared directory, usually on a network in which other applications can 
deposit a data file to be imported into Std-Barc.  If these other applications are on the same 
computer, the In-Box that is created when Std-Barc is installed can be used.  See Directory 
Locations in the Guide to Dialogs section for information on setting up the In-Box.  

Label Order 

The term label order originated in Std-Barc, and refers to all of the labels required for a 
single shipment.  They generally share common data items such as Contract Number, Prime 
Contractor and Contractor Address.  Each label order is stored in a separate file, named by 
the user. 

National Stock Number (NSN) 

The National Stock Number identifies a contract deliverable unit according to a standard 
catalog of items and services. 

Noun 

The Noun is a shorthand term for “descriptive noun of the item nomenclature”, which 
generally appears on the first line of a CLIN or ELIN description in block 16 of a DD250.  This 
field should be completed, as it is to appear on shipping documents, such as the DD250. 

PIIN / SPIIN 

The PIIN and SPIIN are the abbreviations for Procurement Instrument Identification 
Number and the Supplemental Procurement Instrument Identification Number.  Together they 
serve to identify the contract against which your shipments are credited by the paying office 
and the receiving activity.  These numbers appear in the contract on the upper part of the face 
page. 

QUP / QIP / QEP  

These are the abbreviations for Quantities per Unit, Intermediate and Exterior Packages, 
respectively. For an example, a case of eggs may come in unit packages of a dozen (QUP = 
12).  Six unit packages (dozens) might be placed in an intermediate container, such as a 
cardboard box for protection (QUP = 12 x 6 = 72).  Then four intermediate boxes packed 
together in an exterior package to make up a case (QUP = 72 x 4 = 288). 
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Queue (Print) 

A queue is a list of labels that are waiting to be printed. 

 

59 



Std-Barc                                                                                                              Troubleshooting 
 

Troubleshooting 

Error Messages 
The troubleshooting information is provided here to help you resolve problems you may 

encounter while using Std-Barc.  We encourage you to make full use of Mil-Pac Technical 
Support should the resolution to your problem not be apparent. 

 

Error Message: Fatal error initializing Paradox Engine (134) 

Problem: The Paradox Engine has not been proper configured. 

Solution:  The Paradox Engine is used by Std-Barc to manage some of its underlying 
databases.  Paradox relies on a Network Control File for managing access 
to the database tables.  By default, Paradox wants this to be in the root 
directory of the C drive, which Windows no longer allows.  Run Options > 
Paradox Engine, which will automatically correct this.  On some systems, 
you will have to run Std-Barc as the administrator for this to be effect.  To 
do this, right-click on the Std-Barc icon, and select [Run As]. 

 
 
Error Message: File Error.  Cannot find xxxxx.DLL 

Problem: The application cannot locate a required Dynamic Link Library (DLL). 

Solution:   If this occurs immediately after installation, then the cause is incomplete 
installation of the StdBarc program or a defective product disk.  In this 
instance, please contact Mil-Pac Technical Support. 

If the application has been run successfully in the past, first check to see if 
the working directory has been altered, by doing the following:  Right click 
on the StdBarc shortcut icon.  Go to Properties and click on the Shortcut 
Tab.  In the “Start in” field, verify that the path is entered correctly (i.e.: 
C:\Std-Barc, which is the default path).  The other possibility is that the 
DLL has been inadvertently deleted. 

 
Condition:   Labels do not print correctly on thermal-transer printer 

Problem: The printer driver supplied by the manufacturer is not properly rendering 
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the graphic image. 

Solution:  Follow instructions for thermal transfer printer setup in Printer/Label Setup 
section.   

 
Condition:   Labels print slightly off the label stock 

Problem: Generally, the default margins for the printer are affecting print. 

Solution:  Follow instructions in the Standard Printer Setup section for setting the 
Print Adjustment.  Be sure that you have the correct label stock selected 
for the type of label, i.e. a “Pin” stock for thermal transfer, and “Laser” 
stock for sheet labels. 

 
 
Error Message: Multiple PARADOX.NET files (15) 

Problem: The Paradox Engine lock files are corrupted. 

Solution:  Generally, this means this occurs when the database files have been 
moved, or their mapping changed, or shared by in improperly configured 
system.  Simply removing the lock files generally corrects this.  Run 
Options > Paradox Engine, and select [Remove Lock Files]. 

Problems 

Windows Standard (sheet) Labels Won’t Print 
Is the Printer Setup and Connected Properly? 
Make sure you can print from a simple program, such as Notepad or a Word Processing 
program such as Microsoft Word. If you can’t print from Notepad or a Word Processing 
program, get your printer vendor or manufacturer to help you. 

Is the Print Job Getting out of Std-Barc? 
Pause the print queue for the printer so that you can be sure the print job is getting that far. 

A) Open Printers and Faxes. 

B) Double-click the printer. 

C) Select Printer->Pause. 
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D) The title bar for the printer should tell you that the printer is paused, as shown in this 
example. 

E) Print a label. You should see a print job show up in the print queue, as shown below, 
and stay there until you release it. 

i) If the print job appears in the queue, then the print job is getting from Std-Barc to 
the Windows print queue. Unpause the print queue. You can first delete the print 
job if you wish. Contact Mil-Pac Technology Technical Support. 

ii) If the print job does not appear in the queue, there is a problem between Std-Barc 
and the printer setup. Unpause the print queue. Go back to the instructions on 
setting up the printer in Std-Barc in the section titled Configure Std-Barc Printer(s) 
on page 11. If all else fails, contact Mil-Pac Technology Technical Support. 

Thermal/Thermal Transfer Labels Won’t Print 
The Most Common Cause of Problems – Std-Barc Printer Configuration 
The most common cause of thermal/thermal transfer label printer problems is not setting up 
the printer definition in Std-Barc. Before you go further, please go back and check the set-up 
instructions in the section titled Configure Std-Barc Printer(s) on page 11. 

The Second Most Common Cause of Problems – Physical Printer 
Installation 
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The second most common cause of thermal/thermal transfer printer problems is that the 
printer is either not set up properly or there is a problem with connectivity between the pc and 
the printer. To verify if this is your problem, follow these steps. 

A) Find the thermal transfer printer in your pc Printers and Faxes. You were asked to 
install this during the installation procedures.  

B) Right-click on the thermal transfer printer and select Properties.  

C) Print a test label by clicking on the button for Print Test Page. You should get 
something printing on the printer, including some text and the Windows logo, although 
they will most likely be formatted strangely and run off the edge of the label. 

i) If a label prints on the printer, then the printer appears to be configured 
adequately and the pc has adequate connectivity to the printer. Continue with the 
instruction in section Print Immediately. 

ii) If you do not get anything printing on the printer, you may try re-booting both the 
pc and the printer. If this does not help, contact your printer vendor or printer 
manufacturer for assistance. 

Print Immediately 
Make sure you select “Print Immediately” in Std-Barc when you print. Otherwise the print 

job will remain in queue in Std-Barc. 

Is the Print Job Getting out of Std-Barc? 
Pause the print queue for the thermal transfer printer so that you can be sure the print job is 
getting that far. 

A) Open Printers and Faxes. 

B) Double-click the printer. 

C) Select Printer->Pause. 

D) The title bar for the printer should tell you that the printer is paused, as shown in this 
example. 
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E) Print a label. You should see a print job show up in the print queue, as shown below, 
and stay there until you release it.  

i) If the print job appears in the queue, then the print job is getting from Std-Barc to 
the Windows print queue. Unpause the print queue. You can first delete the print 
job if you wish. Contact Mil-Pac Technology Technical Support. 

ii) If the print job does not appear in the queue, there is a problem between Std-Barc 
and the printer setup. Unpause the print queue. Go back to the instructions on 
setting up the printer in Std-Barc in the section titled Configure Std-Barc Printer(s) 
on page 11. If all else fails, contact Mil-Pac Technology Technical Support. 

Contact Mil-Pac Technical Support 
Mil-Pac Technology encourages users to make use of Technical Support: 

Phone: 760-788-3030 

Email: support@milpac.com 

Mail:  Mil-Pac Technology 
   PO Box 2066 
   Ramona, CA 92065 
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