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INTRODUCTION 

Featured Products 
Mil-Pac Technology currently offers two contract management software applications 

designed to create government forms and to manage Department of Defense contracts.  
These programs are DD-Master and DD-FormStation which are described in this manual. 

All Mil-Pac Technology contract management software programs are built around our 
integrated DD-FormEditor (herein referred to as FormEditor), a graphical form processor that 
is specifically designed for the specialized requirements of completing government forms. 

While each of these programs can be used as a stand-alone application, they are also 
designed to enable the user to link them with other Mil-Pac Technology software programs 
and ERP/MRP systems.  Data can be shared through import and export capabilities built into 
each of our applications. 

The following diagram illustrates one example of how DD-Master can generate several 
detailed reports and forms, and link to other applications within a company’s workflow to share 
contract information. 
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Defense Shipping Automation 

Mil-Pac Technology has taken an open-systems approach to ensure compatibility with 
today’s workgroup and collaborative computing environments.  DD-Master and DD-
FormStation are designed to fit into a company’s document-related workflow while enhancing 
the quality of that work. 

How to Use This Manual 
This User Manual is divided into separate chapters for the software applications, and 

has been designed to assist you through each step of using the DD-Master and DD-
FormStation software. The principles of operation are generally the same as those for any 
other program designed for Microsoft Windows.  The programs are user friendly and can be 
easily mastered. 
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A Tutorial Guide is included for each program to assist users in producing practice 
documents with the different software applications.  The Tutorial Guide introduces the 
functions of each program through a number of easy-to-complete walk-through exercises.  
The Tutorial Guide can also be used in conjunction with the detailed Reference sections of the 
User Manual as a quick reference tool for the functions and capabilities of the program. 

While every effort is made to keep the User Manual up to date, the current release of 
the software often includes features not yet incorporated in the manual.  Be sure to refer to the 
product ReadMe files for news of the latest product features, as well as the online help, which 
is accessed via the Help command found on the main menu bar of each application. 

Getting Assistance from Mil-Pac 
If you need assistance or wish to make comments concerning the manual or software 

program, please contact our Technical Support Division at: 

Phone: (760) 788-3030  

Email: Support@milpac.com  

Mail: Mil-Pac Technology 
  PO Box 2066 
  Ramona, CA  92065 

System Requirements 
Operating System – DD-Master and DD-FormStation require a current Microsoft 

Windows operating system. 

Hardware Requirements - The DD-Master and DD-FormStation require computer 
hardware that meets the Microsoft minimum recommended hardware requirements 
for the installed operating system. Additionally, they require at least 25MB of 
available hard drive space. 

Printer – DD-Master and DD-FormStation can be used with most printers that use 
standard Windows drivers (in non-PostScript mode). 

NOTE: A connection to a Value Added Network (VAN) or a government Network 
Entry Point (NEP), such as the   Ogden GEX (Government Exchange), may be 
required for submitting transactions to WAWF.   

For additional information or if you experience any problems, please contact our 
Technical Support. 
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Keyboard Commands 
Throughout this manual, data or commands that are to be entered by the user will 

appear in bold printing. 

DD-FormStation makes use of several of the function keys, which will be referred to as 
<F1> through <F12>. 

The <Control> and <Alt> keys are used in conjunction with other keys.  For example 
the notation "<Alt-X>" means to press the X key while holding down the <Alt> key. 

Typographical constructs, such as File>Save, refer to the menu selections found below 
the application’s title bar.  In this particular case the user is directed to select the Save option 
from the File menu.  This is done by clicking on each word in order, first File, then Save, in 
this example.  The selections on the application’s main menu also may be selected by 
pressing the underscored character while holding down the <Alt> key.  For example, the File 
option can be selected by pressing <Alt-F>.  Selections in the drop down menu may be 
clicked on, cursored up or down to, or immediately selected by pressing the underscored 
character (without pressing the <Alt> key). 

Although we recommend using a mouse with the software, most operations can easily 
be performed using the keyboard.  A summary of relevant keystroke combinations is listed on 
the following page. 
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Common Terms and Keystrokes 
<Tab>  Used to move forward to the next block or command.  The Tab key 

will be the main function key and will be available for use at any time 
in the program. 

<Shift-Tab> This keyboard function is used to move backwards to a previous 
block or command.  It is used in conjunction with the Tab key to move 
freely through the screen. 

<Enter> In some screens, the <Enter> key will move the cursor forward to the 
next block or selection. 

<Spacebar> Activates a selected button or checks a selected box for a value. 

<Fn> Function key # (usually <F1> through <F12>). 

<Alt-Spacebar> Opens the Control menu for the application. 

<Alt-Hyphen> Opens the Control menu for the dialog box. 

Dialog (Box) A window that pops up and contains fields to be completed and/or 
buttons which may invoke other similar windows. 

Cursor ( | ) The cursor indicates where text will be inserted on the screen. It is 
sometimes referred to as the insertion point. 

Check The user positions the mouse pointer on a check box and clicks the 
left mouse button to select it. 

Click The user positions the mouse pointer on a check box and clicks the 
left mouse button to select an object.  For example, to follow the 
instruction “Click OK,” move the pointer to the [OK] button, then click 
the left mouse button. 

Drag The user holds down the left mouse button while moving the mouse.  
Depending on the type of the object selected, dragging will create, 
resize, or move an object. 

FTP File Transfer Protocol. 

Selected A field or button that is active and will accept input, which is indicated 
by the dashed-line box surrounding it, or by being highlighted. 
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PRODUCT OVERVIEW 
 

DD-Master 
 An electronic form generator that makes it easy to create documents of a 

repetitive nature quickly and easily. 

 Creates and submits Receiving Reports, Invoices and Combos to Wide Area 
Workflow (WAWF) 

 Generates DD250s for multiple shipment contracts. 

 Tracks what items have been shipped and what items remain to be shipped for 
each contract. 

 Assigns and manages shipment number sequences, even for contracts being 
shipped from multiple locations. 

DD-FormStation 
 An effective document preparation and management tool for Department of 

Defense contracts. 

 Creates and submits Receiving Reports, Invoices and Combos to Wide Area 
Workflow (WAWF) 

 Greatly speeds and simplifies the preparation of government forms, such as the 
DD250, in accordance with the Defense Acquisition Regulations (DFARs). 

 Connects easily with other business systems to exchange data and automate 
form generation. 

 Provides a database for cataloging and accessing the documents created by the 
FormEditor, and manages the interchange of these documents and form-related 
data with other systems and applications. 

 A powerful back-end processor for third party business systems such as ERP and 
other systems that benefit from having Department of Defense form processing 
capabilities. 

 Supports a wide variety of Department of Defense and commercial forms.  
Contact Mil-Pac for a list of forms currently supported. 
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DD-Master versus DD-FormStation 
The choice between using DD-Master and DD-FormStation depends mostly on the 

number of shipments expected for a contract.  DD-Master’s shipment number management 
and reporting capabilities make it the obvious choice for multiple shipment contracts.  DD-
FormStation is perfect for short run contracts and to produce other forms, such as the 
SF1034, DD1659 and DD1387.  DD-FormStation is included with DD-Master software for this 
reason. 

DD-Master 
DD-Master’s forms generator creates documents of a repetitive nature quickly and 

easily.  While designed specifically for use with the DD250, DD-Master can work with many 
similar forms such as the DD1149 and commercial shippers and invoices. 

CONTRACT

DD-MasterReport
Generation

Form
Generation

Open Items

Contract
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Shipment
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DD250

Contract Information
is Entered into DD-Master
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DD-Master starts with a template of the form to be created called a Master Document.  
In the case of DD250 shipments, the Master is simply a DD250, which is created as if all items 
for a contract were to be shipped at one time. Each time a shipment is to be made, the user 
simply picks the item(s) to ship and DD-Master generates the DD250 from the Master 
Document. 

For simple contracts with all shipments going to the same location and Mark-For, DD-
Master uses the information in the Ship-To and Mark-For blocks on the Master.  However, the 
unique Ship-From, Ship-To and Mark-For address can be specified for each line item, and 
DD-Master will make sure that particular item is addressed correctly. 

Item # |      Stock/Part No. / Description        |   Qty |Unit |   Price  
-------|------------------------------------------|-------|-----|--------- 
       |                                          |       |     |    
0043   | 8470-00-141-0443                         |    12 | EA  | 2,700.00 
       | Operators Console                        |       |     |        
       | P/N: CON-23-07053                        |       |     |     
       |                                          |       |     |   
       | This article was manufactured with       |       |     |   
       | CFC-free materials and processes.        |       |     |     
       |                                          |       |     |   
       |                                          |       |     |   
0044   | 8470-00-141-0443                         |    12 | EA  |   100.00 
       | Users Manual                             |       |     |        
       | P/N: MAN-23-00553                        |       |     |     
       |                                          |       |     |   
       | @S/T: DAAL04-D6                          |       |     |   
       | @M/F: *RCV-OFCR                          |       |     |   
       |                                          |       |     |   
       |                                          |       |     |       
0045   | 8470-00-141-0936                         |    12 | EA  |   150.00 
       | Field Service Kit                        |       |     |       
       | P/N: FSK-23-00723                        |       |     |       
       |                                          |       |     |       
       | This article conforms in all respects to |       |     |  
       | the following contract clauses:          |       |     |       
       | @INCLUDE: CFC-Free                       |       |     |       
       | @INCLUDE: Recyc-Pkg                      |       |     |       
       |                                          |       |     |       

 
Contract Master using Predefined Address and Text Blocks 

 



User Manual  Product Overview 

 10 

 

DD-Master keeps track of what has been shipped and what still remains to be.  It knows 
where each line item is to go, and makes sure the Ship-To and Mark-For blocks are filled in 
correctly.  It ensures that nothing is over-shipped, and tells you when it is time to close out the 
contract. 

 
Drawing from a DD-Master Contract 

Shipping is as easy as point and click. DD-Master generates the DD250 using the 
correct address information for each item.  It keeps track of shipment numbers, maintaining a 
separate sequence for each Ship-From address. 
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DD-Master’s report generator keeps you informed about the status and history of each 
contract.  It’s most basic report is the Contract Status Report.  It is also capable of creating 
other reports as detailed in the Reports section of the User Manual. 

 

DD-Master interfaces easily with other systems.  It can receive contract definitions from 
other systems in plain-text format, and share the data from documents it creates in that same 
format.  DD-Master connects directly with DD-FormStation to make it simple to pass 
documents along for additional processing, such as automatically creating an invoice from a 
DD250. 

DD-Master can create EDI documents such as the ANSI X12 856 Ship Notice/Manifest 
and the 810 Invoice, as well as driving custom flat-file generators for interfacing with other 
systems.  Its barcode label linkage allows it to use software, such as Mil-Pac’s Std-Barc 
barcode labeling software, to automatically create Mil-Std 129-compliant barcode labels. 

mpt/DD-Master
CONTRACT NUMBER (PIIN) ORDER NUM (SPIIN) REPORT DATE SHIPMENTS PAGE

DLA900-98-B-2001 R918 4/19/00-13:07:09 2 1

ITEM
NUMBER UNITS PRICE DOLLARS UNITS DOLLARS

0001 100 1,922.18 192,218.00 52 99,953.36

0002 200 466.67 93,334.00 0 0.00

0003 300 2,799.57 839,871.00 4 11,198.28

0004 400 3,695.50 1,478,200.00 15 55,432.50

0005 500 3,875.00 1,937,500.00 0 0.00

0006 600 2,389.00 1,433,400.00 0 0.00

0007 0 0.00 0.00 0 0.00

5,974,523.00 166,584.14 5,807,938.86

600 1,433,400.00

0 0.00

385 1,422,767.50

500 1,937,500.00

200 93,334.00

296 828,672.72

UNITS DOLLARS

48 92,264.64

CONTRACT STATUS REPORT
  CONTRACT STATUS

OPEN

CONTRACT REQUIREMENTS SHIPPED REMAINING
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DD-FormStation 
DD-FormStation is a tool designed for organizing and sharing documents, such as the 

DD250, created by its integrated FormEditor.  Documents are stored by reference number, 
contract and order number, and form type.  This provides a number of ways to access and 
retrieve documents. 

Document Details Dialog 

DD-FormStation has a number of features which allow documents to be created from 
templates and from outside data sources, such as plain-text files imported from other systems.  
Notes regarding a document can be attached and passed along when the document is shared 
with others.  Document databases may be shared, or documents can be passed from user to 
user. 
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Document Sharing Capabilities 
The real power of DD-FormStation is realized when it is placed in the flow of document 

data in a workgroup.  DD-FormStation is designed to be the originating source and/or ultimate 
consumer of contract data.  DD-FormStation can be placed anywhere in the data/work flow as 
an intermediate data processor and generator of applicable forms and reports. 

DD-FormStation has an integrated In-Box and Out-Box to simplify the exchange of data 
with other DD-FormStations and business systems via Email, shared LAN/WAN areas, ANSI 
X12 transactions, or other site-defined methods.  Documents to be processed by a user are 
placed into the In-Box by background processes to provide the user a simple method of 
managing the work to be done.  When the user is finished with a document, it is placed into 
the Out-Box for automatic printing or dissemination. 

In-Box Features 

A document in plain text format from an external system can be imported to a DD-
FormStation user via a shared network directory.  The plain text file document with the 
information to be imported to the DD250 will be placed in the appropriate boxes on the 
DD250.  DD-FormStation can also import data into other forms supported by DD-FormStation, 
such as the DD1149.  By having the necessary information provided by another data source, 
the DD-FormStation user’s workload is reduced, allowing better accuracy. 

When the import file is ready to be sent to the DD-FormStation user, the file is placed in 
the In-Box of the DD-FormStation user.  Once received, the DD-FormStation user’s screen will 
show a new icon or button flashing on the taskbar at the bottom of the application window to 
show there is a new document waiting to be reviewed.  Clicking on the flashing icon then 
opens the In-Box, showing the files waiting in the In-Box.  Clicking on a file name will open the 
Document Details window and you can preview the new form’s contract-order number, 
shipment number, originator, etc.  Clicking on [Edit] will open the actual DD250 form and 
show the form filled in appropriately with the imported information.  You can now jump to any 
block and edit as necessary. 

Linking DD-FormStation In/Out Boxes 

Once the DD250 is edited, it can be sent to another user’s In-Box for final changes, then 
printed and signed to go with the shipment.  This linking of one person’s In-Box to another’s 
Out-Box is a simple method for efficient flow of documents. 
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Typical Workgroup with ERP/MRP and Two DD-FormStations 

 

When the Out-Box sends the document on, the next user’s screen will show a new 
button flashing on the taskbar at the bottom of the application window, which the user then 
clicks on to open his In-Box.  The In-Box application is opened the same way, enabling the 
final user to print the DD250 after making the final changes.  The form can now be signed and 
distributed. 

If the department that printed the final copy needs to send a copy onto another 
department such as accounting, this can be done using the Out-Box feature.  The form is sent 
electronically to the accounting department’s In-Box in plain text file format for that user to 
read and/or to upload into another software package. 

DD-FormStation documents travel in a package-format that allows for automatic routing 
and permits individual users to add notes and other status information along the way.  The 
open systems design of the DD-FormStation allows it to be easily connected to external 
business systems, such as manufacturing, accounting and shipping systems. 

NOTE:  The example shown at the top of the page entails only four users: Data coming 
from an external system, to the one who first creates the DD250, to the one who prints the 
DD250, and back to an external user.  However, the In-Box/Out-Box feature can chain 
together as few or as many users as necessary in a particular organization’s system. 

DD-FormEditor  
The integrated FormEditor used by DD-FormStation and DD-Master employs an 

enhanced graphical approach to form processing.  The user is presented with a nearly exact 
replica of a DD250 or other such form.  Rather than simply using a scanned image of a form, 



User Manual  Product Overview 

- 15 - 

the FormEditor exploits advanced printer technology to produce the crispest possible form 
image. 

FormEditor DD250 Edit Session 

  

The FormEditor’s form images are adjusted in scale to achieve the best fit around the 
form’s text fields.  The form’s block titles and instructions may also be enhanced or reduced to 
maximize readability.  For example, the “M/S” label and block have been added to Block 4 in 
the DD250 form displayed above to depict the Method of Shipment field, which is required but 
not shown on the government-issue form.  When the form is printed, just the data is 
transferred into an exact replica of the real form using Mil-Pac’s field-proven form generation 
technology. 

 

Method of 
Shipment label 

and block. 
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Block Selection by Name 

Features of the DD250 FormEditor include: 

 Context-sensitive help screens associated with each block. 
 Data format checking to ensure greater DFARS compliance. 
 DFARS Appendix F excerpts to aid in form completion. 
 Databases for address blocks, part descriptions, Block-23 text, Block-16 

certifications and declarations. 
 Selection Lists for mil-std abbreviations and codes, and other distinct data. 
 Print Manager interface for background and network printing. 
 Quick form navigation via keystroke and mouse commands which jump to a 

specific block, field, or page. 

 
Address Database Dialog 

DD-FormStation maintains databases that are created as you generate them for each 
of the address blocks as well as for part descriptions and Block-23 text formats.  It adds a 
database for other Block-16 text blocks, such as certifications and declarations.  DD-
FormStation has interactive database managers which allow the user to page through the 
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entries, as well as modify and delete them.  The user can also copy text to create similar 
items.  .  

DD-FormStation assists the user in determining the special codes that must be placed 
on certain forms.  For example, when entering the Method of Shipment into a DD250, the user 
can open the selection list shown below to look up the appropriate code, which will then be 
placed into the document automatically. 

 
Block Code Lookup 

Form Specific Printer Selection 

All of Mil-Pac’s powerful form processing applications are further enhanced by the 
ability to designate specific printers and print trays for each type of form created.  This enables 
the user to print a specific form to a designated printer and/or print tray with just the click of a 
button. 
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Value Added Network (VAN) Support  
EDI transactions with the Department of Defense go through Value Added Networks 

(VAN) certified by the government's Electronic Commerce Interoperability Process (ECIP).  
Mil-Pac Network Services provides a low cost ECIP-certified VAN, easily accessible via the 
Internet.  Mil-Pac Technology software works automatically with the Mil-Pac VAN, but also 
supports the option of using other VANs. 
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DD-MASTER 
 

Tutorial Section 
In this section, we will go through the following processes step by step: 

 Creating a Contract Master from a blank form 

 Selecting and opening an existing contract 

 Making shipments from the Contract Master 

 Editing the DD250 Shipper 

 Generating reports 

Creating a Master Document 

A Master Document is created by using the information contained in a contract.  Once 
this information in entered, DD-Master will automatically generate the DD250 (or other 
shipping document), assign a sequential shipment number, and update the status of the 
contract.  DD-Master does all this based on a Contract Master created by the user.  This 
document contains shipping instructions and addresses, a description of all the items to be 
shipped, the quantity to be shipped and other information.  It is like a shipper that would be 
used if the entire contract were being delivered in a single shipment.  When making a 
shipment, DD-Master extracts the selected items from the Master, using it as a template. 

The Master can also contain instructions to control how shippers are generated for each 
item.  This information can include addresses to be used in the Ship-From, Ship-To and Mark-
For blocks.  Lengthy descriptive and certification text can be included for each item, which can 
be imported from associated text files. 
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To create a new Contract Master, start by selecting the Contract>New command from 
the main menu.  The Create New Contract Master dialog will be presented. 

From this dialog, you would choose one of the following methods for creating a new 
Master: 

Create New Master: Allows the user to create a Master from a blank form. 

Use Master Template: Creates a new document using the Master Template. See the 
chapter titled Creating a Master Template in the Reference 
section. 

Copy Existing Master: Allows the user to copy an existing contract to create a new 
Master. 

Import Master From: 

DD-FormStation - Imports a Master from an existing DD-FormStation form. 

Text File (M12) - Creates a new Master from a text file that is in M12 format. 

In this example, we will create a new Master from a blank form.  To begin, select the 
Create New Master option and then click on [Ok]. 
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The Add New Contract dialog will be 
presented into which you must enter a 
Reference Number, the Contract Number and 
the Form Type that will be used (e.g. DD250).  
If the contract has an order number, enter that 
also.  The Reference Number is intended to 
be a number by which DD-Master users can 
find the Contract, such as a Sales Order 
Number. Generally speaking the Contract and 
Order numbers will be the PIIN and SPIIN of a 
contract, and in the case of a DD250, will be 
placed in block 1.  However, these two 
numbers can be whatever you want to use to identify the contract, such as a subcontract or 
purchase order number.  The Contract Number is limited to 25 characters and the Order 
Number to 10 characters. 

Once the Add New Contract dialog has been completed, press the [Ok] button and a 
blank DD250 form will be presented by the FormEditor. 

 

In this example we will be using a DD250 with a Single Point Contract.  This is the 
simplest type of Master, in which all shipments come from one Ship-From point and share the 
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same Ship-To and Mark-For addresses.  In this case the Master is completed just as if the 
entire contract were being delivered in a single shipment.  The Shipment Number and Date 
Shipped blocks will be filled in automatically by DD-Master.  Other blocks that will change with 
each shipment can be left blank, and then completed when the shipment is made. 

NOTE:  For instructions on how to create a Master Document for a Multi-Point Contract, 
refer to the chapter titled Defining A Master Document in the DD-Master Reference section of 
this manual. 

The Jump To Block dialog enables you to ‘jump’ directly to a particular field in the 
DD250.  You can also look through the list of blocks and select one by name.  This list also 
includes fields within a block, such as Block 4 that contains Bill of Lading information as well 
as Method of Shipment.  You will find this feature particularly helpful if you are less familiar 
with using the DD250 form. 

To see just how the dialog works, press <Tab> to change the focus to the list of block 
descriptions, and notice that the first one is now surrounded by a faint box.  Now use your 
<Down Arrow> to scroll down through the list, noticing many of the sub-blocks in the list.  
Press the M key three times until the Method of Shipment entry is selected.  Press <Enter> 
and the cursor will jump right to the selected field, which is located within Block 4.  Once an 
entry has been made using the Jump To Block dialog, the dialog will be closed.  To access the 
Jump To Block dialog again, press the <F7> function key. 

In blocks 4 and 8 (Acceptance Point and Method of Shipment) that can only contain 
entries specified by the Department of Defense, a Selection List has been provided.  To 
access the list, place the cursor in the block and use the Ctrl>F command.  Select the 
appropriate entry and press <Ok>. 
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Opening a Contract 
Once you have created a Master document for the contract, the next step is to open it.  

This is done with the Contract>Open command from the main menu bar. 



DD-Master  Tutorial 

- 25 - 

Status Screen 

Once a contract is opened, the Status Screen will appear.  This screen indicates that a 
contract is open.  Notes that are entered here will only appear on this screen and will not be 
printed on the document. 

 

From this screen, you can edit some of the items shown simply by clicking on them.  
Once you have checked one of the boxes, the edit dialog will appear, allowing you to make 
changes to the document. 

Making a Shipment - Drawing from the Contract Master 
Making shipments with DD-Master is easy.  Just open the contract, then select the items 

to ship and indicate how many of each item is to be shipped at that time.  DD-Master does the 
rest, automatically generating the DD250 (or other shipping document), assigning a shipment 
number, and updating the status of the contract. 



DD-Master  Tutorial 

 26 

 

The shipping process is referred to as ‘Drawing from the Master’ because each time an 
item is shipped, the quantity remaining to be shipped is ‘drawn down’. 

To begin, open the contract that you wish to ship from by using the Contract>Open 
command.  Choose the contract you want to open and click [Select]. 

Then access the Ship command from the main menu bar, which will bring up a list of the 
items remaining to be shipped under the contract.  A list of the contract items will be displayed 
within the Draw from Contract Master dialog. 
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When this dialog is brought up for the first time, the shipment number and address blocks 

will all be blank.  Selecting the first item for shipment determines this information, which will be 
filled in at that point.  After selecting the first item, the list of items to ship may be reduced by 
the actions of the Item Filter, which pares the list down to just those items with the same Ship-
From, Ship-To, and Mark-For addresses as the first item.  Pressing the [Show All] button 
turns the filter off. 

The Item Filter excludes those items with zero units remaining to be shipped.  Turning on 
the Item Filter before the first item is selected will reduce the list of items to just those 
remaining to be shipped. 

To select an item to ship, either double-click on the item or click the item once then use 
the [Select] button.  This will access the Line-Item To Be Shipped dialog: 
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Line Item to be Shipped dialog 

 

NOTE:  The first time you ship from a contract you may receive an error message stating 
that the program cannot find the Shipment History file.  This message can be ignored since 
there is no history yet. 
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A description of the selected item will be displayed by the Line Item To Be Shipped 
dialog.  The information displayed includes the item number, NSN, noun, part number, price 
and the quantity remaining to be shipped.  Enter the number of units to be sent in this 
shipment in the Quantity to be Shipped field. 

Serial numbers can be entered at this point, if known, by clicking on the [Edit Serial 
Numbers] button.  For more information, refer to the Serial Number Processing and Edit 
Serial Number List sections.  Serial numbers can be entered at this point, if known. 

UIDs can be attached to the shipment by clicking the [Ship UIDs From Database] 
button. For more information refer to the UID Processing section. 

Press the [Ok] button to accept the item and include it in the shipment.  Several things 
will happen after the first item is selected.  The Ship-From, Ship-To and Mark-For blocks will 
be filled in and a shipment number will be proposed.  The quantity selected for shipment will 
appear in the Quantity column and the number in the Remains column will be decreased 
accordingly. 

Selecting the first item to ship may also reduce the number of items listed because doing 
so turns on the Item Filter, which limits the list to just those items that could be on this same 
shipper.  Excluded are all items with a different Ship-From, Ship-To or Mark-For address, and 
those with zero remaining quantity. This may inadvertently eliminate an item that should be 
shipped, due to the way it appears on the Master.  Pressing the [Show All] button will restore 
the list to include all items. 

Additional items may be selected for shipment by following the same procedure.  
Pressing the [Done] button will cause DD-Master to generate the shipping document including 
the selected items and copying all of the other blocks from the Master. 
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Editing the Shipper (DD250) 
Once each of the items to be shipped has been selected, DD-Master will generate the 

shipping document and present it in the FormEditor.  Here additional information not included 
on the contract Master can be added, including new line items.  Normally there should be little 
need to make any corrections or additions to shipping documents. 

Changes made to the shipper after its creation by DD-Master are reflected in the 
contract’s shipment history.  This allows the user to include any changes that may occur at the 
last minute, such as those that may occur due to final inspection of the shipment.  DD-Master 
has the ability to review all of the shippers it has on file at any time to generate the most 
accurate status possible. 
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Printing 

DD-Master documents can be printed on any Windows supported ink jet or laser printer.  
With the Form-Specific Printer Configuration feature, each form may be automatically printed 
to a designated printer or print tray. 

For example, you may set your configuration to print all DD250s to the Bypass tray of 
your HP LaserJet, at the same time having all SF1443s print to a legal size paper tray in a 
Xerox printer. 
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Once you have printed a form, you may find it necessary to make an adjustment to the 
positioning of the form on the paper. 

The dialog box that is accessed with the Options>Form command in the FormEditor 
will allow you to make any horizontal or vertical adjustments.  Refer to the FormEditor Tutorial 
section titled Form-Specific Printer Configuration for detailed information on this feature. 

 

 

NOTE:  The FormEditor is automatically activated whenever you open or edit a form. 
 

Generating Reports 

One of the most useful features of DD-Master is its ability to generate a number of 
different contract history and status reports.  DD-Master comes with a number of standard 
reports that enable the user to track shipments and determine the status of contracts.   

To print a report, open the contract, access the Report command from the main menu, 
then select the report you wish to print.  The following standard DD-Master reports are 
currently supported: 

Contract Status Report 
The Contract Status Report summarizes what has been shipped to date and what 

remains to be shipped.  To print this report, use the Reports>Contract Status command from 
the main menu while the contract is open.  The Contract Status Report contains the following 
information about each line item: 

Contract Requirements 
Units - total number of units to be shipped under the contract 
Price - unit price of each item 
Dollars - the extended amount for this line item 

Shipped 
Units - total number of units shipped so far 
Dollars - the total dollar amount shipped for this item 

Remaining 
Units - total number of units remaining to be shipped  
Dollars - the total dollar value for the remaining quantity of this item 
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NOTE:  The Contract Shipment Number Log, Open Items, and Contract Status reports 
will be printed.  At this time, they cannot be displayed on the screen. 

Shipment Number Log 

The Shipment Number Log provides a one-line summary of each shipment made 
against a contract, sorted by shipment number.  Use the Reports>Shipment Number Log 
command from the main menu.  The following is a description of the report columns: 

Shipment:  The shipment number as it appears on the shipper (or assigned by 
user) 

Date: The date of shipment, taken from the shipping document 
Ship-To: The CAGE code of the address to which the shipment was made 
Mark-For: The CAGE code of the entity/activity to which the shipment was 

consigned 
Transportation Control Number:  The TCN or other applicable shipment tracking 

number 
Shipment Reference:  A number assigned by the user to identify the shipment 

mpt/DD-Master
CONTRACT NUMBER (PIIN) ORDER NUM (SPIIN) REPORT DATE SHIPMENTS PAGE

DLA900-98-B-2001 R918 4/19/00-13:07:09 2 1

ITEM
NUMBER UNITS PRICE DOLLARS UNITS DOLLARS

0001 100 1,922.18 192,218.00 52 99,953.36

0002 200 466.67 93,334.00 0 0.00

0003 300 2,799.57 839,871.00 4 11,198.28

0004 400 3,695.50 1,478,200.00 15 55,432.50

0005 500 3,875.00 1,937,500.00 0 0.00

0006 600 2,389.00 1,433,400.00 0 0.00

0007 0 0.00 0.00 0 0.00

5,974,523.00 166,584.14 5,807,938.86

600 1,433,400.00

0 0.00

385 1,422,767.50

500 1,937,500.00

200 93,334.00

296 828,672.72

UNITS DOLLARS

48 92,264.64

CONTRACT STATUS REPORT
  CONTRACT STATUS

OPEN

CONTRACT REQUIREMENTS SHIPPED REMAINING
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Open Items Report 

The Open Items Report lists the line items remaining to be shipped on a contract.  Use 
the Reports>Open Items command from the main menu to access this report.  The Open 
Items Report is available in three different collating orders: 

By Line Item (CLIN) 
By National Stock Number (NSN) 
By Part Number 

Other standard reports will be added in future upgrades to this program, along with the 
ability to export contract and shipment data in database formats compatible with popular off-
the-shelf report generators. 
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DD-Master Reference Section 

Defining a Master Document 

DD-Master supports a wide range of contracts, from those in which all shipments go to 
the same location to those that have a multitude of different Ship-To, Mark-For and Ship-From 
addresses.  Line items can include large blocks of text for detailed descriptive information 
such as certification language. 

You may notice that the text in the examples appears in both upper and lowercase.  DD-
Master allows you to enter it this way because most people find it easier to read.  However, 
you can make your shipping documents appear in all UPPERCASE by accessing the General 
Configuration Options dialog.  Go to Options>General, then check the [Force To All 
Uppercase] option in the dialog. 

Creating a Master Template 

A Master Template can be created to save time and data entry by including information 
that is consistently used on many DD250 contracts. 

To create a Master Template, use the Access>Edit Template command from the Main 
Menu.  The following Confirmation dialog will be presented: 
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The first time this option is opened, there will not be an existing template.  Therefore, 
the following warning dialog will appear: 

 
Click [Yes] to create a new template.  This will open the FormEditor, where a blank 

DD250 document will be displayed, along with the Jump To Block dialog. 

Notice that Block 1 displays the word, “TEMPLATE” and that Block 2 displays 
*MASTER*.  You can use the Jump To Block dialog to go directly to any block to enter 
information for your template. 

Enter information that will be consistent throughout most of the Master documents you 
will use the template to create. 

To enter Prime Contractor information, go to block 9, then enter the CAGE code for the 
Prime Contractor.  Enter the name and address in the main portion of the block.  To add the 
Prime Contractor CAGE code and address to the database, use the Ctrl>P command.  Refer 
to the section titled “Accessing and Building the CAGE Code Database” for more information 
on this feature. 

The Template can be edited at any time by first opening it using the Contract>Open 
command.  Select Template, then go to Master>Edit.  Make the desired changes and save 
changes when the document is closed. 

Accessing and Building the CAGE Code Database 

One of the features that DD-Master offers is an address database for each DD250 
address block.  The database is created as you enter information into a Master document.  
Once the database is built, you can access the address for a specific CAGE code or DODAAC 
within a block by entering the CAGE code or DODAAC then pressing <Ctrl-G>: 
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If there is no address specified for the CAGE code or DODAAC entered for this block, 
you will see the above Warning dialog. 

To add the address to the database, complete the name and address information in the 
appropriate block, and then use the <Ctrl-P> command to add it to the database: 

 

After the address has been saved for the specified block, you will only need to enter the 
CAGE code or DODAAC within that block then press <Ctrl-G> to have the name and address 
automatically entered. 

Single-Point Contracts 
The simplest type of Master is for a Single-Point Contract, in which all shipments come 

from one Ship-From point and share the same Ship-To and Mark-For addresses.  In this case 
the Master is completed just as it would if the entire contract were being delivered in a single 
shipment.  The Shipment Number and Date Shipped blocks will be filled in by DD-Master.  
Other blocks that will change with each shipment can be left blank, and then completed when 
the shipment is made. 
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Item # | Stock/Part No. / Description  |   Qty |Unit |  Price  |  Amount 
-------|-------------------------------|-------|-----|---------|-------- 
       |                               |       |     |         | 
0017   | 8470-00-141-0936              |    10 | EA  | $150.00 |  $1,500 
       | Field Service Kit             |       |     |         | 
       | P/N: FSK-23-00723             |       |     |         |    
       |                               |       |     |         | 
       | This article was manufactured |       |     |         | 
       | with CFC-free materials and   |       |     |         | 
       | processes                     |       |     |         | 
       |                               |       |     |         | 
0018   | 8470-00-141-0443              |    12 | EA  | $100.00 |  $1,200 
       | Operators Manual              |       |     |         | 
       | P/N: MAN-23-00553             |       |     |         |         
       |                               |       |     |         | 

Figure 1.  Basic Line Item 

When a shipment is made, each of the blocks on the Master is copied to the new 
document, along with the line items selected for that shipment.  The next shipment number is 
assigned and the current date is entered.  Then the newly created form is presented to the 
user to allow for entry of any additional information. 

Line items for a Master typically appear as shown in the simple example above, with the 
NSN on the first line, the Nomenclature (noun) on the next and the manufacturer’s part 
number on the third.  However, the line item description is not limited to appearing in this 
format; it can be any text that meets your contractual requirements. 

The description of an item that is transferred to the shipping document is everything 
starting from the first line of the item to the start of the next line item, as indicated by a new 
line item number (CLIN) in the leftmost column.  However, what is copied over is limited to the 
description block (i.e. Block 16 on a DD250).  Also note that the quantity, unit of issue and 
price must appear on the same line as the CLIN. 
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Multi-Point Contracts 
In Single-Point Contracts, the Ship-From (S/F), Ship-To (S/T) and Mark-For (M/F) 

address blocks transfer directly from the Master document to the shipper.  A Multi-Point 
Contract is one in which any one of these addresses is different on any shipment.  The 
specific addresses for a line item are identified by placing them in the line item description 
anywhere after the NSN, Noun and Part Number lines.   Any or all three of the addresses for 
an item can be specified.  The rule is that when a shipment is made, the addresses in the S/F, 
S/T and M/F blocks are transferred from the Master to the new document unless a specific 
address is defined for the item.  The example below shows an item with a Ship-To address. 

Item # | Stock/Part No. / Description |   Qty |Unit |  Price |  Amount 
-------|------------------------------|-------|-----|--------|-------- 
       |                              |       |     |        | 
0017   | 8470-00-141-0936             |    10 | EA  | 150.00 |  $1,500 
       | Field Service Kit            |       |     |        | 
       | P/N: FSK-23-00723            |       |     |        |        
       |                              |       |     |        | 
       | @S/T: DAAL04-D6              |       |     |        | 
       | USA Materials Technology Lab |       |     |        | 
       | Arsenal Street               |       |     |        | 
       | Watertown, MA  02172         |       |     |        | 
       |                              |       |     |        | 
0018   | 8470-00-141-0443             |    12 | EA  | 100.00 |  $1,200 
       | Operators Manual             |       |     |        | 
       | P/N: MAN-23-00553            |       |     |        |        
       | @S/T: DAAL04-D6              |       |     |        | 
       |                              |       |     |        | 

Figure 2. Items with individual Ship-To addresses 

The example above shows two items that are both going to a location other than that 
defined in the Ship-To block of the Master document.  When these two items are drawn from 
the Master, the address specified here will be used instead.  Notice in the example that the 
complete address is included only as part of item 0017.  Item 0018 needs only to refer to it by 
CAGE code, since it was already defined as part of item 0017.  Ship-From and Mark-For 
addresses are handled in exactly the same manner. 
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Defining Addresses 
The addresses transferred to shippers are taken from the Master document address 

blocks, unless a specific address is identified for an item, in which case that address is 
substituted.  Addresses can be specified for the Ship-From (S/F), Ship-To (S/T) and Mark-For 
(M/F) address blocks.  Addresses are entered as part of the line item description in the format 
shown below and in the example in Figure 2:  

@A/B: CAGE Code 
Address Line 1 
Address Line 2 
Address Line 3 

where “@A/B” is one of the following codes identifying the address block: 

@S/F: Ship From 
@S/T: Ship To 
@M/F: Mark For  

The CAGE Code following the address block identifier is optional.  If provided, it will be 
placed into the appropriate part of the address block on the shipper.  In cases where CAGE 
codes are not used on the form, such as the DD1149, the CAGE code serves simply as an 
identifier so other items can use it.  If an address has no CAGE code you may leave it blank.  
However, if you want to use such an address in another item, you will need to give it an 
Internal CAGE code, as described below. 

Internal Address Codes 
In some cases you may need to create your own code for an address that does not 

have one specified in the contract.  This is often the case for Mark-For addresses on DD250 
contracts.  DD-Master allows you to create address codes which are for internal use only.  
This allows you to identify an address so other items can share it, without the code being 
transferred to the shipper. 

Internal codes are created by placing an asterisk at the beginning of the code, as shown 
in the following example. 
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Item # | Stock/Part No. / Description |   Qty |Unit |  Price |  Amount 
-------|------------------------------|-------|-----|--------|-------- 
       |                              |       |     |        | 
0017   | 8470-00-141-0936             |    10 | EA  | 150.00 |  $1,500 
       | Field Service Kit            |       |     |        | 
       | P/N: FSK-23-00723            |       |     |        |      
       | @S/T: DAAL04-D6              |       |     |        | 
       | @M/F: *0017                  |       |     |        | 
       | Receiving Officer            |       |     |        | 
       | MILSTRIP: V0469601850750XY   |       |     |        | 
       |                              |       |     |        | 
0018   | 8470-00-141-0443             |    12 | EA  | 100.00 |  $1,200 
       | Operators Manual             |       |     |        | 
       | P/N: MAN-23-00553            |       |     |        |        
       | @M/F: *0017                  |       |     |        | 
       |                              |       |     |        | 

Figure 3. Items using Internal CAGE Codes. 

In the example shown in Figure 3, the Mark-For address for item 0017 is given an 
internal CAGE code; in this case it is the same as the item number.  This is done so that the 
address can be used for item 0018 without the need to re-enter it.  The asterisk at the 
beginning of the CAGE code denotes that the code is for internal use only.  Such codes are 
recognized only by DD-Master - they do not get transferred to shipping documents. 

Another use for internal codes is to create variants of an address.  In some cases an 
address may appear in several variations in a contract, each having the same CAGE code 
which must be included on the shipper as stated in the contract. 

Item # | Stock/Part No. / Description |   Qty |Unit |  Price |  Amount 
-------|------------------------------|-------|-----|--------|--------- 
       |                              |       |     |        | 
0023   | Item 0023                    |    10 | EA  | 150.00 |  $1,500 
       |   ...                        |       |     |        | 
       | @M/F: DAAD05*0023            |       |     |        | 
       | Lab Support Activity         |       |     |        | 
       | Attn:  STEAP-PR              |       |     |        | 
       |                              |       |     |        | 
0024   | Item 0024                    |    20 | EA  | 300.00 | $6,000 
       |   ...                        |       |     |        | 
       | @M/F: DAAD05                 |       |     |        | 
       | Lab Support Ops              |       |     |        | 
       | Attn:  STEAP-PR              |       |     |        | 
       |                              |       |     |        | 
0025   | Item 0025                    |    12 | EA  | 250.00 | $3,000 
       |   ...                        |       |     |        | 
       | @M/F: DAAD05*0023            |       |     |        | 
       |                              |       |     |        | 

Figure 4. Items using Internal Variant CAGE codes. 

Figure 4 demonstrates the use of internal codes for identifying address variants.  Item 
0023 creates an internal variant of CAGE code DAAD05 by appending an internal identifier to 
it with an asterisk.  When this item is drawn only the part of the code up to the asterisk is 
transferred to the shipper.  Notice that item 0025 also uses this Mark-For address.  The code 
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for item 0024 was entered normally, because it was the most prevalent use of the address.  In 
all three cases, the CAGE transferred to the shipper will be the exact same “DAAD05” code. 

Named Text Blocks 
Each line item description in a Master document can include descriptive text beyond the 

standard NSN, Noun and Part Number.  This text, placed in the description block, can include 
up to 64,000 characters of text.  Text blocks which are used for more than one item can be 
given a name, and then used for other items by referring to that identifier. 

Item # |      Stock/Part No. / Description        |   Qty |Unit |  Price  
-------|------------------------------------------|-------|-----|------- 
       |                                          |       |     |    
0043   | 8470-00-141-0443                         |    12 | EA  | 100.00 
       | Operators Manual                         |       |     |        
       | P/N: MAN-23-00553                        |       |     |     
       |                                          |       |     |   
       | @TEXT: CFC-Free                          |       |     |   
       |    This article was manufactured with    |       |     |   
       |    CFC-free materials and processes.     |       |     |     
       |                                          |       |     |   
0044   | 8470-00-141-0778                         |    10 | EA  |  30.00 
       | System 43 Cable Set                      |       |     |     
       | P/N: MAN-23-00635                        |       |     |      
       |                                          |       |     |      
       | @TEXT: Recyc-Pkg                         |       |     |    
       |    Packaging is certified to include a   |       |     |       
       |    minimum of 50% post-consumer recycled |       |     |       
       |    material.                             |       |     |       
       |                                          |       |     |       
0045   | 8470-00-141-0936                         |    12 | EA  | 150.00 
       | Field Service Kit                        |       |     |       
       | P/N: FSK-23-00723                        |       |     |       
       |                                          |       |     |       
       | This article conforms in all respects to |       |     |  
       | the following contract clauses:          |       |     |       
       | @INCLUDE: CFC-Free                       |       |     |       
       | @INCLUDE: Recyc-Pkg                      |       |     |       
       |                                          |       |     |       

Figure 5.  Definition and use of named text blocks. 

The example in Figure 5 shows how to share text blocks by giving them names.  Items 
0043 and 0044 define a small block of text included after the description.  The line above the 
text, e.g. “@TEXT: CFC-Free” assigns an identifier to the text block so that it can be used 
by other items.  This identification line is removed when the items are transferred to the 
shipping document. 
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Item 0045 shows how a named text block is used.  It includes both of the text blocks 
created in items 0043 and 0044, following a section of unnamed text.   When the item is drawn 
it would appear as follows: 

       |                                            | 
 0045  | 8470-00-141-0936                           | 
       | Field Service Kit                          | 
       | P/N: FSK-23-00723                          | 
       |                                            | 
       | This article conforms in all respects to   | 
       | the following contract clauses:            | 
       |    This article was manufactured with CFC- | 
       |    free materials and processes.           | 
       |                                            | 
       |    Packaging is certified to include a     |  
       |    minimum of 50% post-consumer recycled   | 
       |    material.                               |  
       |                                            |  

Figure 6.  Example of text blocks after processing. 

Named text blocks can appear anywhere in the Master document, before or after items 
that use them.  More than one text block can be defined in an item.  Each is simply preceded 
by its own “@TEXT: Text-ID” identification line.   

Text blocks can also be defined as a group at the very end of the Master document as 
shown below in Figure 7.  The first one must be preceded by the “@DEFINITIONS” operator 
so as to separate them from the last item. 

Item # |      Stock/Part No. / Description        |   Qty |Unit | Price  
-------|------------------------------------------|-------|-----|------- 
       |                                          |       |     |       
0043   | 8470-00-141-0443                         |    12 | EA  | 100.00 
       | Operators Manual                         |       |     |       
       | P/N: MAN-23-00553                        |       |     |       
       | @INCLUDE: CFC-Free                       |       |     |       
       |                                          |       |     |       
       |                                          |       |     |        
       | @DEFINITIONS                             |       |     |       
       |                                          |       |     |       
       | @TEXT: Recyc-Pkg                         |       |     |       
       |    Packaging is certified to include a   |       |     |       
       |    minimum of 50% post-consumer recycled |       |     |       
       |    material.                             |       |     |       
       |                                          |       |     |       
       | @TEXT: CFC-Free                          |       |     |       
       |    This article was manufactured with    |       |     |       
       |    CFC-free materials and processes.     |       |     |       
       |                                          |       |     |       

Figure 7.  Definition of text blocks following last item. 
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Importing a DD-FormStation Document 
To create a new Master from an existing DD-FormStation document, start by selecting 

the Contract>New command on the main menu.  Then select Import from DD-FormStation 
from the menu and press [Ok]. 

An Import Contract Master dialog will be presented with a list of the DD-FormStation 
document files found in the DD-Master In-Box directory.  If the file to be imported is not there, 
use the browse feature in the dialog to locate the correct one.  Since it can be difficult to 
identify DD-FormStation documents by their filenames, it may be best to start by using the 
DD-FormStation to first locate the document and look at its Document Details dialog.  The 
name of the file will be shown in the Doc File field.  From DD-FormStation, the file can be 
exported to the DD-Master In-Box, a common network directory, or to a floppy disk for 
importing into DD-Master. 

 
Once a document file has been selected, DD-Master will open it and display the 

document’s Contract and Order numbers as well as the type of form it is.  If this is the desired 
document, press [Ok] to accept it.  If not, pressing the [Browse] button will allow you to look 
at another file. 

If the import file is accepted, the Add New Contract dialog will be presented, with the 
Contract and Order Numbers and the Form Type of the import form.  Generally speaking, 
these two numbers will be the PIIN and SPIIN of a contract.  However, these two numbers can 
be whatever you want to use to identify the contract, such as a subcontract or purchase order 
number.  The Contract Number is limited to 25 characters and the Order Number to 10 
characters.  DD-Master will check to see that the Contract and Order number are not already 
in the system.  If they are, you must either delete the pre-existing contract, or change the way 
the imported one is stored by altering its Contract or Order Number. 

Once the imported file has been logged into the system, it may be viewed by using the 
Master>View menu command. 



DD-Master  REFERENCE 

- 45 - 

Importing a Contract in Plain-Text Format 
Master Documents may be imported in plain-text files using the M12 format.  This allows 

contract data contained in other business and manufacturing systems to be downloaded into 
the DD-Master.  Refer to the M12 File Specification section for information on creating these 
files. 

To create a new Master from a plain text file, start by using the Contract>New 
command on the main menu.  Then select Import Master From:  Text File [M12] from the 
Create New Contract Master dialog and press [Ok]. 

 

An Import Contract Master dialog will be presented with a list of the M12 files in the DD-
Master In-Box directory.  If the file to be imported is not there, use the browse feature in the 
dialog to locate the correct one.  Once an import file has been selected, DD-Master will open it 
and display the document’s Contract and Order numbers as well as the type of form it is.  If 
this is the desired document, press [Ok] to accept it.  If not, pressing the [Browse] button will 
allow you to look at another file. 

If the import file is accepted, the Add New Contract dialog will be presented with the 
Contract and Order Numbers and the Form Type of the import form.  Generally speaking, 
these two numbers will be the PIIN and SPIIN of a contract.  However, these two numbers can 
be whatever you want to use to identify the contract, such as a subcontract or purchase order 
number.  The Contract Number is limited to 25 characters and the Order Number to 10 
characters.  DD-Master will check to see that the Contract and Order number are not already 
in the system.  If they are, you must either delete the pre-existing contract, or change the way 
the imported one is stored by altering its Contract or Order Number. 

Once the imported file has been logged into the system, it may be viewed by using the 
Master>View menu command. 
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Serial Number Processing 
Serial numbers can be incorporated into shipping documents at four distinct stages 

during document preparation, depending on at what point they are available to the user: 

Entered on Master.  In the rare cases where the serial numbers are predetermined, 
they can be entered into the Master. 

During Shipment Draw.  Pressing the [Edit Serial Numbers] button when drawing 
an item will present the Edit Serial Number List dialog into which the 
numbers can be entered.  Lists can be entered manually or pasted from 
another application via the cut and paste Windows command.  To help 
ensure accuracy, the list of serial numbers is counted and compared with 
the quantity to ship.  If a quantity has not yet been entered, the serial 
number count will be entered automatically. 

Included from a File.  This is method allows large numbers of serial numbers to be 
imported during the shipment draw process.  This is particularly useful 
when the serial numbers come from sources such as barcode scanners or 
QA databases. 

Entered into Document.  Serial numbers can be entered into the shipping 
document if not known at the time it is drawn from the Master. 

 
 

A contract Master does not require any special setup to allow serial numbers to be 
entered during the draw process.  DD-Master will place them immediately following the line 
item description, below the part number line.  However, placing the label “S/N:” on a line by 
itself in the line item description will do two things:  1) It will allow the user to control where the 
serial numbers are placed in the line item when it is created, and 2) it will also prompt DD-
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Master to remind the user that serial numbers are required.  If they are not entered at this 
point, the “S/N:” label will be transferred to the shipping document as a further reminder that 
serial numbers should be entered for the item. 

Serial Number Lists 
DD-Master can handle lists of serial numbers that appear individually in any order and 

may include ranges of numbers.  They are entered into the Edit Serial Number List dialog 
when an item is selected for shipment, by pressing the [Edit Serial Numbers] button found on 
the Line Item To Ship dialog.  Individual numbers can be separated by spaces, commas or 
placed on individual lines. 

Ranges of serial numbers are separated by either a dash or the word “thru” with a space 
on either side. Examples of acceptable styles of serial numbers in a list are: 

WDG01018, WDG01019  WDG01022 
WDG01025  
WDG01026, WDG01029 - WDG01035 
WDG01044 thru WDG01049 

Lists can be entered in any desired order and will be transferred to the shipper in the 
order entered.  DD-Master will place them as compactly as possible into the shipper, 
separated by commas.  The list processor will count the items in the list and warn the user if it 
does not match the quantity to be shipped. 

Ranges of serial numbers can be properly interpreted and counted as long as they meet 
two criteria. They must be no more than twenty-five (25) characters in length, and the 
incremented part must be at the end of the string.  The remainder can be composed of any 
other characters. For example: WIDGET030018; 351-135155; A-020535; 01-BETA-01235. 
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Reviewing Past Shipments
Shipping documents created by DD-Master are saved until the contract is closed.  Once 

the contract is closed, they are archived off of the system.  Using the Review command on the 
main menu can retrieve previous shipments.  If the desired contract is not already open, this 
must be done first using the Contract>Open command. 

 
The Review command brings up a list of the shipments made against the contract.  

Simply choose the one you want and either double-click on it or press the [Select] button. 
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The Review Shipping Document dialog will be displayed.  From there the shipping 
document can be viewed, edited, printed, exported or used to generate barcode labels or EDI 
transactions. 

Multi-User Capability 
DD-Master’s modular design allows its various functions to be performed by different 

people sharing the information in the contract database.  One person can develop and 
maintain contract Masters while others ship from them, and still others generate reports on 
demand.  Its design will also allow DD-Master to limit the functions that individual users are 
allowed to perform in order to maintain tighter control over contract shipments.   

Shipping data and documents can be shared with other systems for purposes such as 
barcode labeling and updating contract and accounting databases.  DD-Master has built-in 
linkages for easy generation of plain-text export files and EDI transaction files.  Documents 
can be shared directly with DD-Master and DD-FormStation and can automate barcode label 
generation by connecting with Mil-Pac’s Std-Barc Mil-Std 129 barcoding system. 
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Sharing Documents with Others 

The data contained in DD-Master documents such as DD250s can be shared with other 
external systems.  This data can be used to create barcode labels, advise accounts 
receivables systems, and update databases.  DD-Master has built-in linkages for easy 
generation of plain-text export files, EDI transaction files and Mil-Std 129 barcode labels.  
Buttons for these functions are found on the Review Shipping Document dialog. 

DD-Master uses plain-text files to supply other applications with data from documents 
created by it.  The M12 export file is a plain unformatted text file using field names to delimit 
the data. Refer to the M12 File Specification for a description of the file format.  Other export 
formats may be available; contact Mil-Pac Technical Assistance for information. 

The first step in exporting data is to determine a network directory that is accessible to 
DD-Master and each of the applications that might use the data.  Enter this location into the 
Direct Method Path and set the Format to “Plain-Text File”. 

Next, determine if document passing will occur manually (by clicking on a dialog button) 
or automatically whenever a document is changed.  Automatic exporting is enabled within the 
Document Export Configuration dialog. 

Should you choose to export documents manually, use the [Data Export] button on the 
Review Shipping Document dialog to export the currently selected document: 
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The Document Export Confirmation dialog will be presented so the destination and format 
of the export file can be modified or simply confirmed: 
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Guide to DD-Master Menus & Dialogs 

Create New Contract 

After selecting the Contract>New command on the main menu, the Create New 
Contract Master dialog will be presented.  From here, choose one of the following methods for 
creating a new Master: 

Create New Master: Allows the user to create a Master from a blank form. 

Use Master Template: Creates a new Master from the Master Template.  Refer to 
the section titled “Creating a Master Template” for instructions on how to 
create a Master Template. 

Copy Existing Master: Allows the user to copy an existing Master to create a new 
Contract Master. 
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Import From: 

DD-FormStation - Imports a Master from an existing DD-FormStation form: 

Text File (M12) - Creates a new Master from a text file that is in M12 format: 
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Add New Contract 

Once you have chosen the document source from the Create New Contract Master 
dialog, the Add New Contract dialog is presented.  This is the point where a new contract is 
logged into the system and given a unique identifier by the user. 

Dialog Fields 

Reference Number is an internal number that would be helpful in locating a 
particular DD250. Sometimes DD-Master users use a sales order number or 
commonly-understood contract name. 

Contract Number is the identifier by which a contract is stored.  For DD250s this 
number is associated with the contract’s PIIN (block 1).  However, this can be 
whatever you want to use to identify the contract, such as a subcontract or 
purchase order number.  The Contract Number is limited to 25 characters. 

Order Number is a supplementary identifier of the Contract Number, identifying a 
unique instance of the contract.  For DD250s this number is generally the 
delivery order number, associated with the SPIIN (block 1).  The Order Number 
is limited to 10 characters.  This field is optional. 

Form Type indicates the type of form, such as DD250 or DD1149, to use when 
creating shipping documents. 
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Open Contract Master 

After selecting the Contract>Open command on the main menu, the Select Contract 
dialog will be presented.  From here, choose one of the existing contracts to open by either 
double-clicking the contract or clicking once to highlight and then clicking the [Select] button: 

Note that you can change the sort order by clicking the button beside the words “Sort 
by”. 
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Contract Status Panel 

Once you create a new contract or open an existing contract, DD-Master displays the 
Contract Status Panel. The Contract Status Panel provides information about the contract and 
makes available more main menu options necessary to manage the contract and shipments. 

Reference Fields 

Reference Number, Contract Number, Order, and Form fields show the 
data entered when the Contract was created. 

Prefix is a sequential counter that DD-Master uses to distinguish shipment files from 
different contracts. This information is useful when seeking technical support 
from Mil-Pac Technology, but is not required for day-to-day operations. 

Shipments to date is the number of shipments that have been made against this 
contract. 

Date of first and Date of last the dates of the earliest and latest shipments that 
have been made. 

Last Shipment is the shipment number of the latest shipment made. 
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Preliminary shipper(s) indicates how many Preliminary Shippers currently exist 
for this contract. 

Contract Status indicates the current contract status. 

Include Prices determines if unit and extended prices of items will be transferred to 
shipping documents drawn from the Master.  This allows pricing information to be 
included with the Master for reporting purposes, without revealing it on shipping 
documents. 

Est. Ship Dates appends an ‘E’ to the Ship-Date field of shipping documents where 
applicable.  

4Y Mil Dates uses four digits for the year on military style dates, e.g. 2000JAN01. 

Uppercase forces all documents to uppercase. 

Validate Master -  Determines if the Master is properly formatted, to ensure that it 
can be used as a source for shipping and/or reporting. 

Mil-Std Pkging  – enables Mil-Std-2073 packaging support for the contract. 

MS-2073-xx fields determine the version of Mil-Std 2073 that is referenced. 

Notes button and field allow users to add free-text notes to the contract. 

Draw from Contract Master 
The Draw from Contract Master dialog allows the user to create shipping documents for 

the currently open contract.  The Master document for the contract is used as a template.  To 
open a contract, use the Contract>Open command from the main menu.  For instructions on 
how to create a Master document, please refer to the Creating a Master Document chapter in 
the DD-Master Tutorial section. 
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When the dialog is accessed, some of the fields such as the shipment number and 
address blocks will be blank.  Selecting the first item for shipment determines this information, 
which will be filled in at that point. After selecting the first item, the list of items to ship may be 
reduced by the actions of the Item Filter, which pares the list down to just those items with the 
same Ship-From, Ship-To, and Mark-For addresses as the first item.  Pressing the [Show All] 
button (the [Filter] button changes to read [Show All] when it is clicked on) turns the filter off. 

The Item Filter excludes those items with zero remaining units to be shipped.  Pressing 
the [Filter] button to activate it before the first item is selected will reduce the list of items to 
just those remaining to be shipped. 

Reference Fields 

The following fields display information about the shipment.  None of them can be 
changed directly. 

Contract & Order numbers refer to the identification given to the contract when it was 
established in DD-Master.  Generally speaking, these will correspond to the 
PIIN and SPIIN found on the shipper. 

Shipment Number is the sequential number proposed for this document.  It is assigned 
based on the Ship-From address of the first item selected for shipment.  This 
field cannot be changed, but before the shipping document is created the user 
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will be prompted to confirm or modify the shipment number by the Confirm 
Shipment Number prompt. 

Doc File is the filename that the document is stored as.  The file’s extension, “.FED”, is 
not shown.  The document can be found in the Data Directory defined in 
General Configuration Options.  This field will be empty initially. 

Ship From is the CAGE code of the address from which the shipment shall originate. 

Ship To Code is the CAGE code of the address to which the shipment will be 
addressed.   

Mark For Code is the CAGE code of the individual or activity to which the shipment will 
be consigned. 

Item Filter indicates that the Item Filter is active.  It can be turned on and off by 
pressing the [Item Filter / Show All] button. 

Dialog Fields 

Ship Date is the shipping date proposed for this shipment.  It defaults to the current 
system date, but can be changed now, or after the shipping document is 
created.  The use of 4-digit years and the estimated ship date indicator (‘E’) is 
controlled by settings in the General Configuration Options. 

Item List contains a complete list of the line items defined in the contract Master.  The 
order in which the items appear can be changed by pushing one of the [Sort 
Items By] buttons described below.  A number in the Quantity column 
indicates that the item has been selected for shipment. 

Dialog Buttons 

[Select]  brings up the Line Item To Ship dialog for the item highlighted in the list.  
Double-clicking on the item will do the same thing.  This is the method for 
designating items to be shipped. 

[Done]  indicates that all items to be shipped have been designated.  A shipping 
document will now be created. 

[Cancel] aborts the shipment.  There is no effect on the contract status.  The proposed 
shipment number will be recycled. 

[Item Filter / Show All] turns the Item Filter on and off, respectively.  The box above 
the button will be checked if the Item Filter is active. 

Item Sort Order changes the current sorting order for the item list to one of the 
following: 

[CLIN] - sorts items by Contract Line Item Number 

[NSN] - sorts items by National Stock Number 

[PN] - sorts items by manufacturer’s Part Number 
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The default sorting order is set in the General Configuration Options. 

Line-Item To Be Shipped 
The Line-Item To Be Shipped dialog is invoked when an item is selected for shipment 

from the Draw from Contract Master dialog: 

Reference Fields 

The following fields display information about the shipment.  None of them can be 
changed from this dialog. 

Contract & Order numbers refer to the identification given to the contract when it 
was established in DD-Master.  Generally speaking these will correspond to the 
PIIN and SPIIN found on the shipper. 

Item, NSN, Noun and Part Num identify the selected line item. 

Price is the Unit Price of the item, if provided on the Master. 

UOI is the Unit of Issue as it will appear on the shipper when drawn. 
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Remaining is the total number of this item (in UOI units) that is yet to be shipped. 

Serial Numbers Required is checked if “S/N:” was found in the Master description 
of the line item. 

Dialog Fields 

The following fields can be accessed and edited by the user. 

Quantity is completed by the user to indicate the number (in UOI units) to be 
shipped in this shipment.  A warning will be given if this exceeds the 
Remaining quantity.  If the user chooses to exceed the remaining 
quantity, the item will show as over-shipped until the Master is updated to 
reflect an increased requirement. 

A non-zero quantity has to be entered in order for the item to appear on 
the shipper.  If a zero quantity really is desired, make that change to the 
shipper itself.  The contract status will reflect the quantity as found on the 
actual shipper. 

Ship UIDs from Database allows the user to select UIDs to attach to the shipment 
from a database of available UIDs. See the section on titled Ship UIDs 
from Database on page 63. 

Serial Numbers can be entered into this field, or into the shipper itself after it is 
created. 
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Edit Serial Number List 
The Edit Serial Number List dialog allows the user to enter lists and ranges of serial 

numbers associated with an item.  It is accessed when creating a new shipment by pressing 
the [Edit Serial Numbers] button on the Line Item To Ship dialog. 

This section describes the fields and buttons on this dialog.  

  

Dialog Fields 

Item Quantity is the number of parts to be shipped as indicated by the Quantity field on 
the Line Item To Ship dialog. 

Number in List is the number of serial numbers counted by the serial number processor, 
including those implied by any ranges of numbers.  This number is updated when 
coming into and leaving this dialog.  Use the [Count] button to check on the 
count while editing the list. 

[Count] counts the serial numbers in the list, including any ranges, and updates the 
Number in List field. 

[Expand] converts ranges into discrete list of numbers. (This feature is not yet 
implemented.) 
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[Shrink] sorts the list after expanding any ranges.  It then reduces the list by creating 
ranges wherever possible.  The result is the smallest possible ordered list.  (This 
feature is not yet implemented.) 

Ship UIDs from Database 
The Ship UIDs from Database dialog allows the user to select UIDs to add to the 

current shipment.  It is accessed when creating a new shipment by pressing the [Ship UIDs 
from Database] button on the Line Item To Ship dialog. 

 This section describes the fields and buttons on this dialog.  

Dialog Fields 

Search Criteria filters the list of available UIDs to a list matching entered criteria. When 
this dialog is first displayed, the search criteria is automatically set to match the 
selected line item, including Contract, Order, CLIN, and Part Number. Change 
the list of displayed UIDs by changing the search criteria. Change the search 
criteria by checking and un-checking the search criteria checkboxes and by 
changing the data in the Shipment, CLIN, and Part Number fields. 

Auto (Search Criteria) refreshes the displayed list of UIDs immediately when search 
criteria are changed. Unchecking Auto would require the user to click the 
[Refresh List] button to display the UIDs. 

Refresh List (Search Criteria) displays UIDs with the defined search criteria. Clicking this 
button is necessary when the Auto checkbox is un-checked. 

Sort View By changes the sequence in which UID records are displayed. 

Commit adds highlighted UIDs to the current line item for the current shipment.  
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Done exits the UID screen and returns to the Line Item To Ship dialog.  

Confirm Shipment Number Dialog 

The Confirm Shipment Number dialog is invoked each time a shipment number is 
about to be assigned to a shipment created by the Draw From Contract Master process. The 
Shipment Number Log keeps track of the sequential shipment numbers for each contract.  A 
separate sequence is maintained for each address that is shipped from.  Each time a new 
shipment sequence is started the three letter prefix is presented by the Assign Shipment 
Number Prefix dialog for confirmation or alteration. 

The sequence number 
automatically assigned can be overridden 
by typing a new value into the dialog 
field.  DD-Master will assume that this is 
an attempt to reset the Shipment Number 
Log for the contract and will ask if that is 
the intended action.  A positive reply will 
make the revised shipment number the 
last one in the sequence, and the next 
shipment will be assigned a shipment 
number that is greater by one (i.e.: If the current shipment number is MPT0001, the next one 
will be assigned MPT0002).  A negative response allows this shipment number to be used for 
the current shipment without affecting the number that will be assigned to the next shipment 
number. 
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Assign Shipment Number Prefix 
The Assign Shipment Number Prefix dialog is encountered the first time a shipment is 

made from a Ship-From address.  It allows the user to assign the three character alpha prefix 
for shipment numbers, such as MPT0001. 

A shipment number is composed of a three 
alpha character prefix and a four-digit numeric 
sequence number.  The three character alpha 
prefix is controlled and assigned by the prime 
contractor, such as the MPT in MPT0001.  The 
shipment number prefix must be different for 
each Ship-From address and should remain 
constant throughout the life of the contract/ order.  
DD-Master maintains a log of shipment numbers 
used for each contract.  A separate sequence is 
for each Ship From address, per the DD250 
usage regulations stated in the DFARs: 

The prime contractor shall 
control and assign the shipment 
number prefix. The shipment 
number shall consist of three 
alphabetic characters for each "Shipped From" address (Block 11). 
The shipment number prefix shall be different for each "Shipped 
From" address and shall remain constant throughout the life of the 
contract.  The prime contractor may assign separate prefixes when 
shipments are made from different locations within a facility 
identified by one "Shipped From" address. 

Number the first shipment 0001 for shipments made under the 
contract or contract and order number shown in Block 1 from each 
"Shipped From" address, or shipping location within the "Shipped 
From" address.  All subsequent shipments with the identical 
shipment number prefix shall be consecutively numbered.  Use 
alpha-numeric serial numbers when more than 9,999 numbers are 
required.  Serially assign alpha-numeric numbers with the alpha in 
the first position (the letters I and O shall not be used), 
followed by the three position numeric serial number. 

Dialog Fields 

Ship From Point is the address and CAGE/FSCM code for which a new prefix is being 
requested.  (Read only) 
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Shipment Number Prefix is the three character alphabetic prefix to be used for the 
Ship From address shown.  Enter any three characters from A to Z, except the letters I 
and O. 

Review Shipping Document 
The Review Shipping Document dialog allows access to previously created shipments 

so that the shipping document can be viewed, edited, printed, exported or used to generate 
barcode labels and EDI transactions.  This dialog appears after creating a new shipper (see 
Making a Shipment) or after retrieving a previously created one (see Reviewing Past 
Shipments). 

The CAGE codes for the Ship-To and Mark-For addresses are displayed as found in the 
shipment history.   

To exit this dialog, be sure to use the [Close] button, not the  in the upper right hand 
corner of the screen. 

Reference Fields 

The following fields display information about the shipment.  None of them can be 
changed directly. 

Contract & Order numbers refer to the identification given to the contract when it 
was established in DD-Master.  Generally speaking these will correspond 
to the PIIN and SPIIN found on the shipper. 

Shipment Number is the sequential number given to this document. 
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Doc File is the filename that the document is stored by.  The file’s extension, 
“.FED”, is not shown.  The document can be found in the Data Directory 
defined in General Configuration Options. 

Ship Date is the shipping date extracted from the shipping document, if applicable.  
Otherwise, it is the date the document was created. 

Address Codes: 

Ship To is the CAGE code of the address to which the shipment was 
addressed. 

Mark For is the CAGE code of the individual or activity to which the shipment 
was consigned. 

Ship From is the CAGE code of the address from which the shipment 
originated. 

Dialog Buttons 

The following buttons perform operations on the currently selected document. 

[View / Edit] invokes the FormEditor with the current document.  Changes made 
to the document are incorporated in the contract history. 

[Print] prints a copy of the document. 

[Delete] deletes the document from DD-Master.  This does not affect the 
shipment number sequence, nor does it affect the shipment history, unless 
a contract status reconciliation is performed.  Care should be taken when 
deleting shippers. 

[Data Export] creates a copy of the document for use by another software 
application, in plain-text, EDI or DD-FormStation format, and places the file 
in the directory/location indicated by the user.  The action to be taken is 
presented to the user for adjustment or confirmation in the Document 
Export Confirmation dialog.  The default operation of this button is set in 
the Document Export Configuration dialog. 

[Barcode Labels] creates an export file for use by a barcode labeling software, 
such as Mil-Pac’s Std-Barc.  The operating characteristics of this button 
are determined by the settings in the Barcode Labeling Options dialog. 

Address Labels – This feature is not yet implemented 

Mil-Std Packaging – This feature is not yet implemented 

Document Export Confirmation 
The Document Export Confirmation dialog occurs whenever a document is about to 

be exported from the document database.  It allows the user to modify the method, format 
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and/or destination of the export file before the export is allowed to occur.  The default values 
displayed in these fields are established in the Document Export Configuration dialog.  
Changing them here affects only the export of this document, not the default values 
themselves.  Should you wish to perform a number of ad hoc exports to a location other than 
the default path, the easiest approach is to temporarily change the Document Export 
Configuration (responding No when asked to save it), prior to performing the exports. 

 

This dialog is invoked as a confirmation whenever the currently selected document is 
exported. 

Dialog Fields 

Export Method determines how this document is to be exported: 

Standard Direct Method creates a copy of the document file in the location 
defined in the Standard Out-Box Path field below.  This option is used 
when documents are generally sent to only one location. 

EDiForm is an obsolete feature and included only for backwards compatibility. 

Database / Data Warehouse outputs data in a columnar file with each record on 
a separate line and each field on the line separated by commas.  

Path\File is the drive\subdirectory and filename to which this exported document will be 
created. 

Format determines the type of file created by the export process. 

DD-FormStation Doc (.FED) is the file type used by the FormEditor, and should be 
used when sending a document to another DD-FormStation. 
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Plain-Text Flat-File (.M12) is a plain ASCII file, using field names to delimit the 
data.  This format is used when the document is to be read by other 
applications.  Refer to the M12 File Specification for a description of this 
file format. 

X12-810 is an ANSI-X12 Commercial Invoice document format for Electronic Data 
Interchange (EDI).  This format is used to transmit a DD250 as an invoice 
to the payment office. 

X12-856 is an ANSI-X12 Ship Notice document format for Electronic Data 
Interchange (EDI).  This format is used to transmit a DD250 to the DCMR 
for acceptance.  This electronic format is designed to replace the 
distribution of some paper copies of the DD250. 

General Configuration Options 
The General Configuration Options dialog contains a number of fields which affect the 

general operation of DD-Master.  This dialog is accessed with the main menu 
Options>General command. 

Dialog Fields 

Data Directories: 
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DD-Master is the drive\subdirectory that the document and contract status files are 
stored in. For normal installations this will be the C:\DDMASTER\DM-DATA 
folder.  It can also be a shared directory on a Local Area Network (LAN) 
accessible by other DD-Master users. 

In-Box is the drive and sub-directory from which DD-Master will import new Contract 
Masters. 

Archives is where DD-Master stores archived Contracts. 

Default Form is the type of form suggested whenever a new contract is created. This is 
the default value for that field, which can be changed at the time the contract is 
being created. 

Pending Form is the type of form printed for pending shipments. 

Sort Items By is the default method of sorting line items displayed in Draw From Contract 
Master: 

CLIN:   Contract Line Item Number 

NSN:  National Stock Number 

Part Num: Manufacturer’s Part Number  

Sort Contracts By is the default method of sorting Contracts. 

Force to All Uppercase generates documents with all uppercase data, regardless of how 
it was entered on the contract Master. 

Include Prices on Shippers determines if unit and extended prices of items will be 
transferred to shipping documents drawn from the Master.  This allows pricing 
information to be included with the Master for reporting purposes, without 
revealing it on shipping documents. 

Use Estimated Ship Dates appends an ‘E’ to the Ship-Date field of shipping documents 
where applicable. 

Use 4-digit Military Dates uses four digits for the year on military style dates, e.g. 
2000JAN01. 

Validate Master – validates the Master prior to shipping or reporting. 

Multi-User Control – locks contracts to prevent access by more than one user at a time. 

User’s Name – name to be reported to other users attempting to access a locked 
contract. 

Network ID – formal ID of user, such as a network ID. Defaults to product serial 
number. 

Use Contract File Lock – enables the feature. 
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Document Export Configuration 
The Document Export Configuration dialog determines the method, format and 

destination of documents exported from the DD-Master document database.  This dialog is 
accessed with the main menu Options>Exporting command. 

 

Dialog Fields 

Export Method determines how this document is to be exported: 

Standard Direct Method creates a copy of the document file in the location 
defined in the Standard Out-Box Path field below.  This option is used 
when documents are generally sent to only one location. 

EDiForm is an obsolete feature and included only for backwards compatibility. 

Database / Data Warehouse outputs data in a columnar file with each record on 
a separate line and each field on the line separated by commas.  

Path\File is the drive\subdirectory and filename to which this exported document will be 
created. 
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Format determines the type of file created by the export process. 

DD-FormStation Doc (.FED) is the file type used by the FormEditor, and should be 
used when sending a document to another DD-FormStation. 

Plain-Text Flat-File (.M12) is a plain ASCII file, using field names to delimit the 
data.  This format is used when the document is to be read by other 
applications.  Refer to the M12 File Specification for a description of this 
file format. 

X12-810 is an ANSI-X12 Commercial Invoice document format for Electronic Data 
Interchange (EDI).  This format is used to transmit a DD250 as an invoice 
to the payment office. 

X12-856 is an ANSI-X12 Ship Notice document format for Electronic Data 
Interchange (EDI).  This format is used to transmit a DD250 to the DCMR 
for acceptance.  This electronic format is designed to replace the 
distribution of some paper copies of the DD250. 

Automatically Export Modified Documents will cause DD-Master to automatically export 
documents that you modify in the FormEditor.  DD-Master checks for modifications 
every time the user exits the FormEditor. 

Prompt First causes DD-Master to request confirmation before performing the 
export function. 

Display Export Settings Dialog causes DD-Master to display the Export Settings 
Dialog prior to exporting documents. 

Barcode Labeling Configuration 
The Barcode Labeling Configuration dialog determines the method by which DD-

Master uses the Std-Barc barcode labeling application to automatically generate labels using 
the data from documents created by it.  The fields below determine what action is taken when 
the [Barcode] button is pressed on the Review Shipping Document dialog. 

This dialog is accessed with the main menu Options>Barcoding command. 
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Dialog Fields 

Method determines what action is taken when the [Barcodes] button is pushed on the 
Review Shipping Document dialog: 

Run Barcode Application will cause DD-FormStation to create a document export 
file and invoke the barcoding application with it.  It is assumed that the 
barcoding application is in the Barcode Application Path named below. 

Auto-Barc is an obsolete application and is provided for backwards 
compatibility. 

Std-Barc will cause Std-Barc to start when the [Barcodes] button is pushed. 

Create Export File Only generates a document export file for the current document 
in the In-Box path indicated below, but no other action is taken.  This 
option is useful when the barcoding application is performed at another 
computer connected via a LAN.  It also allows the user to simply generate 
the file for use on the same system at a later time. 

None will disable automatic barcoding operation. 

Barcode Application Paths 

Exe-file  is the location of the Barcode Labeling Software.  It is used only when the 
Method option above is Run Barcode Application. 

In-Box is the directory to which DD-Master will generate the document export file.  
This should be set to the In-Box folder for the barcoding application, which 
is generally c:\Std-Barc\In-Box. 
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DD-FORMSTATION 
 

Tutorial Section 
The main DD-FormStation screen displays a list of the documents currently stored in 

your database.  When first installed, the database will contain only one document, a sample 
DD250.  In the figure below, the reference to that document, TEST-250-PP-001, is shown with 
an inverse bar, indicating that it is the document currently selected.  This means that the next 
command, such as Edit, will be performed on that document. 

 
 

Main DD-FormStation Screen – The Document Database 
 

A B C D E GF
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The DD-FormStation Document Database is a summary of the descriptive information 
stored in the database about each document.  From left to right, the data items displayed are: 

 

A. Document Reference Number - An internal number, such as a work order or 
sales order number, assigned by you to refer to a contract or a single 
shipment. 

B. Form Type – Indicates the type of form by its name and/or number. 

C. Contract-Order Number - Identifies the contract or purchase order for which 
the document was prepared (if necessary). 

D. Shipment Number - Used when more than one shipment is made against a 
contract or purchase order.  It also can be used as a sequence number for a 
series of documents. 

E. Form Date - Refers to the shipment date on the document, if applicable, or 
the date the form was prepared.  The default for this field is the current day’s 
date. 

F. Form Status - Indicates whether the form is currently being processed, or 
whether it has been completed, submitted, or closed out. 

G. Template Flag - Indicates if the document is a special read-only document, 
used as a basis to create others. 
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Document Details Dialog 

 

Of the data elements described on the previous page, the Document Reference Number 
and Form Type are the most critical.  Together, they form an index that is used to store 
document information in the DD-FormStation database for later retrieval. 

More detailed information about each document is available on the Document Details 
dialog, which you can access by pressing the <Enter> key or using the View>Details 
command, while a document is selected.  This dialog displays more detailed information about 
a document, including who created and processed it, as well as notes about it. 

With the exception of the Reference Number, Form Type and Document File fields, the 
information in the Document Details dialog can be modified and updated as needed.  You may 
have noticed that the Notes field has horizontal scroll bars.  This is because data entered here 
can be longer than the display area.  In fact, you can store up to 32,000 characters of 
information in this field. 

Looking back at the Document Details dialog, you will see that the [First] button 
appears to be dimmed.  This button is only available when a number of document summaries 
are being viewed, and is used to get back to the top of the list.  More than one document 
summary can be selected for review. 
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Multiple documents can be selected on DD-FormStation’s main screen by holding down 
and dragging the mouse when making a selection, or by holding down the <Ctrl> key and 
clicking on individual entries.  In this example, the “Item x of y” legend at the top of the dialog 
will show your current place in the list.  The [First] button will be active (unless you are on 
number 1) and the [Ok] button will read [Next] to allow you to easily page through the 
summaries of the documents selected. 

Editing an Existing Document  

To review or edit an existing document, the first step is to select it by moving the inverse 
bar on the DD-FormStation’s document list using the mouse or the cursor keys.  Then click on 
[Edit] or press <Alt E> to invoke the form editor.  Or simply double-click the document in the 
list. 

Printing an Existing Document  

 
DD-FormStation Print Dialog 

 

To print an existing document directly from the DD-FormStation, first select it by moving 
the inverse bar on the DD-FormStation’s document list using the mouse or the cursor keys.  
Then click on Perform and Print (or press <Ctrl P>) to invoke the form editor print module.  
The document will be displayed, and then the standard Windows print dialog will appear.  If 
the Printer shown is the one you intend to use, simply click on [Ok] or press the <Enter> key.  
Otherwise select an appropriate printer with the Printer Setup button, and then [Ok] to print. 
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DD-FormStation In-Box 

The DD-FormStation provides two simple ways of receiving documents from external 
sources, such as other DD-FormStation users, or business systems such as ERP, order-entry, 
or database management systems.  DD-FormStation is capable of accepting such documents 
in either its own format, or a simplified plain-text import format which can be readily produced 
by almost any computer system.  Accepting externally-sourced documents in either format is 
very straightforward. 

DD-FormStation maintains an in-box subdirectory for each user.  In networked 
environments, this subdirectory should be made public to allow other users and external 
systems to deposit files to be processed by the user.  Examining this directory gives the user 
an idea of what forms need processing. 

There are two options for viewing the DD-FormStation In-Box.  You may either view the 
normal IN-Basket dialog or it can be displayed in Preview List mode.  To access these 
options, click Options on the main menu bar.  This will open the In-Box Configuration dialog: 

In-Box Configuration dialog 

To view the Preview List dialog, click on the box to the left of Display Preview List.  (To 
return to normal view, remove the check mark by clicking on it again.) 
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The following dialogs show the two viewing options.  The first example shows the IN-
Basket as accessed by using the In-Box command from the main menu bar: 

DD-FormStation In-Box in Normal View 

The In-box dialog shown in the example above has two new documents waiting to be 
processed.  The first document file (a0410001.fed) was produced by another DD-FormStation 
and passed to the user via a modem or network connection of some type (or transferred from 
a floppy disk).  The second one (a0410002.m12) was exported in a flat-file format from 
another application. 
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The second example is the In-Box Preview display, accessed by using the In-box 
command with the Display Preview List option enabled.  This shows all pending documents 
contained in the in-box: 

DD-FormStation In-Box in Preview List View 

 

In the example above, the same two files are viewed in the In-Box Preview dialog. 

 

When DD-FormStation imports an ASCII import-file, it goes through a translation 
process, attempting to identify relevant data items and place them within the appropriate form 
block. 

The use of an ASCII flat-file format is beneficial to those attempting to create data for 
the DD-FormStation, as it is fairly simple to generate an acceptable file, even using another 
program’s report generator. 
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As the DD-FormStation translates an import file, it produces a status report in the form 
of a running log.  An example of the display created when importing a file is shown below. 

 

 
ASCII-Import Status Log 

 

It shows a line for each line item in the file, reporting the item’s CLIN, National Stock 
Number (NSN), quantity and price (if provided).  The import process can automatically format 
the data and do price extensions. 

Any errors encountered will be reported.  Use the scroll bars to review the report. 
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Copying an Existing Document  

The DD-FormStation allows the user to select one document to use as the basis of 
another, simplifying the generation of similar documents.  To copy an existing document, the 
first step is to select it.  Do this by moving the selection (inverse) bar on the DD-FormStation’s 
document list using the mouse or the cursor keys.  Then click on [File] and then [Copy-Form] 
(or press <Alt F> and then the C key).  This will bring up the Document Copy/Rename dialog, 
which you may notice looks similar to the New Document dialog. 

 
Document Copy/Rename Dialog 

 

To complete the copy process, simply change any of the details you wish on the dialog, 
then click on the [Ok] button, or press <Enter> (in the Notes section you must press <Alt O> 
instead of <Enter>).  Remember that the Document Reference Number and the Form Type, 
taken together, form the index used to store and retrieve documents.  Since duplicate entries 
are not allowed, at least one or the other must be altered to create a new retrieval index. 

The Copy/Rename dialog also allows the user to copy data from one form type to 
another, transferring information between related blocks on the two forms.  To do this, simply 
change the Form Type instead of the Reference Number.  This will create a separate 
document with the new form type.  Changing the form type during a rename operation will 
change the form associated with the existing document, without creating a new document.  Be 
careful doing this, as the Form Editor will discard any blocks which do not exist on the new 
form type. 
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Creating a New Document 

The first step in creating a new document begins on DD-FormStation's main screen.  
Click on the [File] menu choice, then on [New-Form] (or press <Alt F> then N).  This will 
bring up the new document summary dialog, as seen below.  You will notice that some of the 
fields are already filled in with current or default information, such as the date and the form 
status. 

The most important and only required field is the Document Reference Number.  This, 
together with the Form Type, identifies each document stored in the DD-FormStation 
database so that they can be retrieved later.  Therefore, a unique number must be entered in 
this field.  DD-FormStation will warn you if a form with that identifier is already in the system, 
and will allow you to use a different number or to overwrite the original. 

 
New Document Summary 

 

The Document Reference Number can be any string of numbers, letters, spaces and 
dashes, up to twenty-five characters long.  Generally, if compatibility with other systems is a 
consideration, use of spaces should be avoided (use dashes instead).  Enter something such 
as "TEST-1" as the name of the document to create.  Then press <Tab> to move on to the 
next field, Form Date.  The current system date will already be filled in.  Modify it if you desire, 
then press <Tab> again to move on to the next field. 

Complete the Contract Number and Shipment Number fields, with something like 
"XYZ001-95-A-TEST" and "ABC0001Z", pressing <Tab> after entering each.  Since we are 
creating a DD250, these fields will be transferred into Blocks 1 and 2 on the new form.  These 
numbers are not necessarily required for other types of documents created by the DD-
FormStation (in future versions). 
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The Originator field refers to the person or process responsible for origination of the 
document.  The name of the person actually processing the form should be placed in the 
Completed By field.  If desired, fill in this information, or skip over it with the <Tab> key.  If 
either or both of these fields are generally the same most of the time, you may instruct the DD-
FormStation to enter those names automatically.  This is accomplished by entering them as 
default values in the General Configuration Options dialog.  To access this dialog, use the 
Options>General command. 

 
DD-FormStation General Configuration Dialog 

 

The Form Type field is a combination box, meaning that you can scroll up and down 
through its choices with the up and down cursor keys, or see its list by clicking on the arrow 
button.  Remember that the Form Type is combined with the Reference Number to create a 
retrieval index for each document, so only one of a form type is allowed per reference number.  
Currently, only the DD250 is supported by the DD-FormStation.  Press <Tab> to move onto to 
the next field. 

The next field to be completed would be Notes, into which you can place information 
describing the nature of the document, its current status, or list changes to it.  Future versions 
of the DD-FormStation will support automatic logging into the Notes section, which will occur 
whenever the document is edited.  The date, time, and user name will be appended to the log, 
and the user will be given the chance to add to further specifics. 

The Notes section allows the user to press the <Enter> key to add another line of text, 
as would be expected.  However, this means that <Enter> will not terminate the dialog, as it 
does in other fields.  To do so, you must either click on the [Ok] button, press <Alt O>.  
Similarly, you may also choose to Cancel the dialog.  You may also move to another field in 
the dialog by pressing the <Tab> or <Shift Tab> keys, or clicking on the desired field. 
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You may notice that the Form Status and Template fields are skipped over, as the 
dialog focus goes from Form Type to Notes and then on to the [Ok] button.  The DD-
FormStation assumes that a new document is still "In Process".  You will be given the 
opportunity to change this to "Complete", if desired, after editing the document when the 
document summary will reappear.  The Template box can be checked if you want to designate 
this is as a read-only document to be used to create similar documents. 

Future versions of the DD-FormStation will prevent this document from being modified 
and/or deleted.  The DD-FormStation will also allow the user to select from a list of templates 
when creating a new document. 

At this point, click on the [Ok] button, or press <Enter> or <Alt O> to create the new 
document, or <Alt C> to cancel it. 

Entering Data into a New Document 

Use the File>New Form command from the main menu to access the New Document 
Summary dialog.  After completing the New Document Summary and pressing the [Ok] 
button, the DD-FormStation form editor, called the FormEditor, will display a new, mostly 
blank, DD250 form.  Notice that the contract and shipment numbers that you entered in the 
New Document dialog were transferred to the form. 
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For your convenience, you can use the Jump To Block dialog to go directly to a specific 
block.  Or, you can press the <Enter> key to navigate block to block through the document, 
and watch the cursor (also called the insertion point) move.  First it moves to the second line 
of Block 1, then to the Order Number block, then to the next line of the block.  Pressing the 
<Enter> key will traverse the entire form in this manner, moving to the beginning of each line 
of each block in succession.  This may prove to be a little slow in the blocks with more lines, 
such as the address blocks. 

Press the <Tab> key a few times and notice that each time you do, the cursor moves to 
the first line of the next block.  As you will see later, pressing <Tab> will sometimes move 
within a block, if that block contains multiple fields or sub-blocks.  For example, keep pressing 
<Tab>, and notice that in Block 4, pressing <Tab> goes to the Bill of Lading part of the block, 
then to the TCN, then to the Method of Shipment. 
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DD-FormStation Reference Section 
 

This section explains in detail the specific use of the DD-FormStation dialogs and 
functions. 

Selecting a Default Form Type 

When a new document is created on a DD-FormStation with more than a form type, the 
user must choose the form type for the new document.  If the user does not select a form type, 
DD-FormStation will select the default form.  The Default Form Type selection in the 
Configuration Options dialog allows the user to control which form is used as the default 
selection.  For convenience, this option should be set to the most commonly used form. 

 
Selecting a Default Form Type 
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Focusing the Document Database Listing 

The DD-FormStation document database display is limited to the first 1200 documents 
in the Document Database.  Documents beyond that limit cannot be displayed (use [Search] 
to access documents not listed).  The scope of the list can be narrowed by using Document 
Display Filters to limit the list to only those of interest, and reduce the number loaded into the 
list. 

It is suggested that the number of old documents in the database be periodically 
reduced by either deleting or moving them to the Document Archive.  Refer to the Archiving 
Document Data section for more information. 

Maximizing the Document Database List 

The maximum number of documents in the listing can be increased to approximately 
3100 documents by instructing the DD-FormStation to display less information about each 
document.  Use the View>Ref-Numbers Only command to switch to this mode.  The option 
will be check-marked to show that the mode is active.  Select it again to restore the display to 
normal.  The mode select is only in effect during the current session.  To select the mode in 
which the program normally starts, use the Options>List Reference Numbers Only option. 

Document Type Filter 

The document display filters allow the user to focus the Document Database Listing by 
limiting the documents read into the list.  The display criteria, set using the View>Type-Filter 
command, can be any combination of a partial reference number, document status or 
template designation.  In the example below, the display is being limited to only those Closed 
documents with reference numbers beginning with “DLA”. 

 
Database-View Type Filter 
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Once the user has activated a filter, the DD-FormStation will reload the listing using the 
criteria.  Use the [Reset] button to return the DD-FormStation to the normal, non-filtered 
mode. 

One use of the Document Display Type Filter is to locate document templates when 
using them to create new documents.  However, an easier method is to use the File>Copy 
Template menu command (see Using Document Templates). 

Document Age Filter 

Another way to restrict the documents displayed in the Database Listing is to use the 
Document Age Filter.  Using this feature allows the user to look only at documents newer 
than, or older than a specific number of days.  Use the [Reset] button to return the DD-
FormStation to the normal, non-filtered mode.  In the example below, the DD-FormStation is 
being instructed to only display documents created within the last 30 days. 

 
Database-View Age Filter 

 

Another example of Age Filter use would be the selection of old documents to delete or 
archive.  To do this, select Greater than, enter the number of days, and then press [Ok].  Use 
the Perform>Delete or Perform>Archive commands. 

Using Document Templates 

The DD-FormStation allows the user to use any document as the skeleton or boilerplate 
for creation of a new document.  One method is simply to select any document, then use 
File>Copy to create a copy of it and give it a new reference number.  Then use [Edit] to 
access the newly created document.  Using the Document Templates feature makes this 
process faster, simpler and safer through the use of document templates.  Selecting, naming 
and editing the new document is reduced to one step.  Locating a template to select from is 
easier because the function lists only templates.  Designating a document as a template also 
affords it extra protection from accidental deletion. 
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Selecting a Template to Copy 

 

To designate a document as a template, select it then check the [Template] box on the 
Document Detail dialog.  To create a document using a template, select the File>Copy 
Template menu command, which will display a list of templates to select from, as shown 
above. 

Once a template has been selected, DD-FormStation will display the template’s 
document header, which includes the Reference Number and Form Type, as seen below.  
Since documents are stored by these two values, you will need to enter a new Reference 
Number for this document.  Note that DD-FormStation highlights the Reference Number to 
remind you to do this. 

 
Template Copy Dialog 
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Database Maintenance Procedures 

Document Archives Database 

The DD-FormStation document database display is limited to about 1200 documents.  
Those documents beyond the limit cannot be displayed without using one of the database 
(see Focusing the Document Database Listing).  It is probably better to limit the number of 
active documents in the database.  It is recommended that the number of old documents in 
the database be periodically reduced by deleting them, or moving them to the Document 
Archive. 

Archiving Document Data 

There are two methods of archiving an active document.  Individual documents can be 
archived directly from the Document Details Dialog by pressing the [Archive] button.  This will 
remove the document from the Active Documents database.  The document file, “ECMO-
0901.FED” in the example above, will be renamed by changing the extension to “.~ED” in 
accordance with standard Windows practices.  The user should periodically delete all such 
backup files to maintain the greatest possible amount of available hard disk space. 

 
Document Details Dialog 
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Multiple documents can be archived by first tagging them (by hand, or with the [Tag] 
command) and followed by the Perform>Archive command.  (See Document Age Filter.) 

 

 

 

 

 

 

Retrieving Archived Documents 

The Document Archives database is viewed in the same manner as the active 
Documents Database.  The archive is accessed via the View>Document Archive menu 
command. 

Exit   File   In-Box   Edit   Search   Tag   Perform   Options   View 

Document Archive 
List 
Detail 
Type Filter 
Age Filter 
Ref-Numbers Only 
Refresh Doc List 

 

This command changes the menu to the following: 

 

 

The Archive menu has many of the same commands as the Document Database menu, 
with the addition of the [Retrieve] command.  To retrieve documents from the archive into the 
active database, they must first be tagged.  This may be done by hand, clicking on individual 
documents (clicking while pressing the <Ctrl> key), or a range of documents (clicking while 
pressing the <Shift> key).  Once the desired documents are tagged, select [Retrieve] to copy 
them back into the active database, where they may be viewed, edited or printed. 

The Search, Tag and View menu commands work in generally the same manner as 
they do in the active document display.  Use the Exit>Archive command to return to the 
active document display. 

Print Ctrl+P

Delete Del 

Move 

Archive

Document Archives

Exit   File   In-Box   Edit   Search   Tag  Perform   Options   View

Exit Archive Retrieve Search  Tag View 
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Document Archive Database 

The Document Archive is implemented as a single table Paradox database, composed 
of three files: DBDocArc.PX, DBDocArc.DB and DBDocArc.MB.  Backup and recovery of 
these files must always be performed as a single unit in order to maintain their integrity.  The 
individual document files created by the DD-FormStation, listed in the active Document 
Database, are assimilated directly into the archive database tables to reduce the number of 
files stored within the DD-FormStation data directory. 

Rebuilding the Document Database 

You may find the need to rebuild your Documents Database should it ever be acci-
dentally deleted, or become corrupted by a hardware glitch.  Database recovery is possible 
because the document database is really just an index for the documents, which exist as 
individual files. 

 
Database Rebuild Document Review Dialog 

 

Rebuilding the database is initiated by using the File>Database ReBuild command.  
During the process, each document file in the data directory is read in turn, and information 
about the document is presented in the Document Review Dialog shown above.  The user can 
step through each document file deciding to keep it [Keep] or skip it [Skip This], deciding at 
any point to keep all of the remaining files. 

The database rebuilding process is not perfect, and cannot recover deleted document 
(.FED) files.  It starts by deleting the existing database.   Rebuilding should be avoided as a 
standard practice.  Instead, Mil-Pac recommends that the DD-FormStation data be backed up 
on a regular basis to avoid the need to rebuild the database, and to avoid the incidental loss of 
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document files, addresses, parts and/or text block databases.  Refer to the Backing Up DD-
FormStation Data section for instructions. 

As an alternative to rebuilding the entire database, individual documents can be 
restored by dropping the document files into the user’s In-Box, and then processing them with 
the In-Box command.  This allows these documents to be added to the document index 
without the need to rebuild the entire database. 

Backing Up DD-FormStation Data 

Mil-Pac highly recommends periodic backup of your DD-FormStation data files to 
minimize the impact of unforeseen disasters such as disk crash, sector or cluster loss, or 
inadvertent human error.  In addition, it is recommended that copies of your original product 
distribution disks be made. 

The following list includes all of the data files generated by the user and the 
configuration files generated by the DD-FormStation and the FormEditor.  All other files 
located in the DD-FormStation directory are provided on the product distribution disk(s). 

File(s) Usage  
FS-Idx.DB, *.PX, *.MB DD-FormStation Document Database  

FEd-Addr.DB, *.PX, *.MB Address Blocks Database  

Part250.DB, *.PX, *.MB Parts Database  

DD250B23.DB, *.PX, *.MB DD250 Block 23 Database  

DDFS.UCF DD-FormStation User Configuration 

FEditor.UCF FormEditor User Configuration 

data\*.FED Document files  

in-box\*.M12, *.FED Unprocessed In-Box files  

FD-Forms.INI Forms Catalog (if applicable)  

 

NOTE: 

The first four entries are databases, each of which consists of three files.  For 
example, the Document Database consists of FS-Idx.DB, FS-Idx.PX, and FS-Idx.MB.  All 
three files must be backed up and restored as a unit. 

As installed, the DD-FormStation creates its own data subdirectory (usually 
C:\DDFS\DATA) in which to store document (.FED) files.  However, the user has the option 
of specifying a different location. Refer to the Document Storage Directory entry of the DD-
FormStation’s Options>Configuration dialog to determine the location of FED files. 
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The in-box location can also be specified by the user.  Refer to the In-Box Path entry 
of the DD-FormStation’s Options>Configuration menu dialog for its location. 

In many instances there will not be a FD-Forms.INI file.  This is normal. 

DD-FormStation Program Configuration 

The operational characteristics of the DD-FormStation under the user’s control are set 
by the configuration dialog described below. 

 
DD-FormStation Configuration Options Dialog 

Configuration Options Dialog 

Document Storage Directory.  Determines where the DD-FormStation stores individual 
document files.  Default is the Data subdirectory of the working directory. 

Default User Name.  Default value placed in Completed By field in document summaries 

Default Originator.  Default value placed in Originated By field in document summaries. 

In-Box 

Path.  Where the DD-FormStation looks for In-Box files. 

Tag for periodic purge after n days.  Determines how often processed files are deleted from 
system.   

Delete files after import.  If checked, files read from the In-Box are immediately deleted from 
the In-Box.  Otherwise, they are marked by changing the first letter of the file extension 
to a tilde (~).  Files n days old are then purged. 
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FORMEDITOR 
 

Tutorial Section 
The FormEditor, used by DD-FormStation and DD-Master has many features that make 

form completion quick and painless.  In this section, a few of the FormEditor features will be 
demonstrated by walking through the process of creating a new form. 

 
FormEditor Display of a DD250 

 

Notice that the onscreen form, while bearing considerable resemblance to a real 
DD250, is slightly different.  The FormEditor attempts to replicate the form as closely as 
possible, so those users of the form will feel more comfortable working with it.  The software 
goes one step further by adding descriptive information to the onscreen form to make it easier 
to use.  Block 4 is a good example, in that the "TCN" label and "M/S" sub-block have been 
added to make form completion more obvious.  In cases where language on the form is 
unnecessary to the completion of the form, it has been abbreviated or abridged in the 
onscreen form by FormEditor.  None of these modifications to the form will be visible when it is 
printed.  The data you enter on the form is extracted and printed on a standard DD250 form 
using Mil-Pac's standard laser form technology. 
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While skipping through the form, we forgot to complete the Acceptance Point, Block 8.  
Hold down the <Shift> key, then press the <Tab> key a few times.  Notice that the cursor 
moves backwards through the blocks.  Keep doing this until you reach Block 8.  Then press 
the S key, to indicate Source as the acceptance point.  Of course, since this is a Windows 
program, you can just use the mouse to point and click on the field you want.  However, many 
keystroke commands have been included in the FormEditor to make it just as simple to use 
with the keyboard.  A complete list of keystroke commands is found in the Appendix. 

 
Jump-to-Block Dialog 

Jumping To A Block 

In the FormEditor it is possible to jump directly to the block you want by pressing the 
<F7> key (or the menu's Search>Jump-To-Block command).  This will bring up the Jump-to-
Block Dialog that allows you to enter the block number desired.  You can also look through the 
list of blocks and select it by name.  This list also includes fields within a block, such as those 
discussed above for Block 8.  You will find this feature particularly helpful if you are less 
familiar with using the DD250 form.  Press <Tab> to change the focus to the list of block 
descriptions, and notice that the first one is now surrounded by a faint box.  Now use your 
<Down Arrow> to scroll down through the list, noticing many of the sub-blocks in the list. 
Press the M key three times, until the Method of Shipment entry is selected.  Press <Enter> 
and the cursor will jump right to the selected field, Block 4. 

Selection Lists 

The Method of Shipment field of Block 4 is a good place to demonstrate the 
FormEditor's selection list capability.  The FormEditor provides users with a list of the 
possible, or most likely, entries for blocks requiring specific entries or codes.  For example, the 
Method of Shipment is a one-character code defined by Mil-Std 129.  Press <Ctrl F> (Find 
Entry command) while in this block and the following selection list will appear: 
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Selection List for Method of Shipment 

 

As you press the <Down Arrow>, notice the shipment code in the Selection field 
changes.  Select UPS by pressing the U key, twice.  The first time, "Unassigned" is selected.  
The second time you press U, "United Parcel Service" is selected, along with its shipment 
code "5".  Press <Enter> and notice that this code is inserted into the proper place in the 
DD250 form.  Then press <Tab> a couple of times to move to Block 9, Prime Contractor. 

Address Block Databases 

To speed your work and make it more accurate, the FormEditor maintains a database 
for all six of the address blocks.  To see a quick example of this feature, first type "98765" with 
the cursor in the Code section of Block 9.  Then press <Ctrl G> (to get the entry) and you will 
notice that Mil-Pac's address appears.  The FormEditor stores each address by its CAGE or 
FSCM code, keeping them separated by block of use.  This allows you to maintain a number 
of different addresses for the same code, depending on their usage.  You may store 
addresses which have no CAGE by assigning your own code. 

An address retrieved into the form can be changed on the current copy of the document 
by editing what is in the block.  You can also modify, or update, the address on the form and 
save it on the database version.  This will be discussed later on. 

Addresses can be retrieved even if you do not know the appropriate code. To see a 
example of this feature, press <Tab> a couple of times, or <Enter> until the cursor is 
somewhere in Block 10, Administered By.  Press <Ctrl F> to find an address.  The Address 
Database Dialog will appear, as shown below. 
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Address Block Database Dialog 

 

Notice that the CAGE code field is highlighted.  Press the <Down Arrow> and <Up 
Arrow> keys a few times.  As the displayed code changes, the address that is associated with 
it is displayed in the field in the middle of the dialog.  However, the address type that is 
checked remains the same: "Admin Ofc".  Because you accessed the database from Block 10, 
it is assumed you do not want to see addresses for all of the other blocks.  You can look at all 
of the address categories by accessing the database from the Databases>Address menu 
command.  This allows you to copy addresses between blocks, and perform other kinds of 
operations on the database. 

You also can scroll through the address CAGE codes with the mouse by clicking on the 
arrow button to the right of the field.  This action displays a selection list of CAGEs.  Its scroll 
bars can be used to scroll the list up and down.  However, unlike using the cursor keys, the 
address displayed does not change until you leave the CAGE field by clicking on another field 
or pressing the <Tab> key.  Press <Enter> (or <Alt O>) or click on the Ok button to accept 
your address selection (use any address for the tutorial).  The confirmation message shown 
below will be displayed before the selected address is copied into the current document. 

 
Address Insertion Confirmation 
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Addresses not in your database can be added very easily.  To try this procedure, first 
press the <Tab> key a couple of times to move to the Code section of Block 11, Shipped 
From.  Type in "TEST-1" then <Tab> a couple of times to get into the block. Then type in: 
   ACME MILITARY SUPPLY   
   123 MAIN STREET 
   ANYTOWN, USA  12345 

 
following each line with the <Enter> key.  Then press <Ctrl P> to put the address in the 
database.  If it already exists, you will be warned before the new one is saved.  To confirm that 
the address was saved, press <Ctrl F> (find).  Press the T key, until TEST-1 appears in the 
CAGE code block and confirm that the address is correct.  You can correct this address or 
modify others by looking them up, then clicking the [Modify} button or pressing <Alt M>. 

Use of some of the other Address Database dialog features is explained in the 
Reference Guide.  Also explained is the use of the Address Database Tool, which allows for 
the import and export of address data.  Of particular use to MasterWriter users is the facility 
which imports the MasterWriter address database for use with the FormEditor. 

Cursor-Movement Keystrokes 

There are quite a few keystroke commands which control the FormEditor's cursor or 
text insertion point.  They are listed fully in the Keystroke Guide found in the appendices, and 
are summarized below.  Whenever possible, the keystroke commands are contrasted to those 
found in the MasterWriter, for the benefit of users familiar with that product.  In general, the 
same keystroke commands used by the MasterWriter have been replicated in the FormEditor.  
Some have been changed to reflect current standards, and many new commands have been 
added. 

Three keystroke commands changed for Windows compatibility have already been 
discussed.  The address block Get, Find and Put commands, <Alt G>, <Alt F> and <Alt P> in 
the MasterWriter were changed in the FormEditor to <Ctrl G>, <Ctrl F> and <Ctrl P>, 
respectively.  This change was required because the <Alt> key is used to access menus in 
Windows. 

The FormEditor design includes a number of keystroke commands that make it easier 
to move the cursor around in a block of text.  These include the <Ctrl Right-Arrow> and <Ctrl 
Left-Arrow> keystrokes, which move the cursor forward and backwards a word at a time, 
each time placing the cursor at the first letter of the word or number.   

The function of the <Home> and <End> keys also has been enhanced in the 
FormEditor.  The operation of these keys is dependent on where the cursor is when they are 
pressed.  The first press of the <Home> key will cause the cursor to move to the beginning of 
the current line.  The next press will move it to the beginning of the first line in the current 
block.  In a similar fashion, the first press of the <End> key moves the cursor to the end of the 
text on the current line so that you can add more to the line.  The next press of <End> moves 
the cursor to the last character position on the current line, and pressing <End> again moves 
the cursor to the very end of the block. 
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A very significant improvement over the MasterWriter is the addition of a true insert 
mode.  By default, the FormEditor starts in overstrike mode, meaning that text entered will 
write over and replace whatever is already there.  By pressing the <Ins> key, the FormEditor 
switches into insert mode, in which the existing text is moved over to make room for each new 
character entered.  Press the <Ins> key several times and notice that the small status window 
in the bottom-left corner of the screen toggles between OVR and INS, indicating the current 
mode.  Be sure to switch back to OVR before continuing this tutorial.  The default startup 
insertion mode can be set by the user in the Configuration Options dialog. 

Entering Line Items Into Block 16 

Contract Line Items (CLINs) shipped on a DD250 are entered into Blocks 15 through 20 
of the DD250, referred to as the CLIN section in this manual.  The operation of some 
keystrokes is unique to this block and is discussed below. 

 
Line Item (CLIN) Section 

 

The operation of some keystrokes in the CLIN section differs slightly from other blocks 
in order to accommodate the way data is generally formatted.  The most significant differences 
are with the <Tab> key, which moves the cursor to the first line of the next block in the rest of 
the form.  In the CLIN section, the <Tab> key moves from Block 15 through Block 20, staying 
even with the top of the current item in Block 16. 

For example, if a line item is started on the fifth line of Block 15, the <Tab> key will 
move the cursor onto the same line of Block 16.  After several lines of line item description are 
entered into Block 16 (each followed by <Enter>), pressing <Tab> will place the cursor up on 
the fifth line of Block 17, Quantity.  The cursor will continue to stay on the fifth line as it moves 
through Blocks 18 through 20, the Units, Price and Total blocks.  Pressing <Tab> in Block 20 
will return the cursor to Block 15, Item No, leaving a blank line after the item description in 
Block 16. 
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Data Calculations and Formatting 

To demonstrate the action of the <Tab> key, and the automatic formatting in the CLIN 
section, first move the cursor to Block 15 by using the <Tab> key, <F7>, or the mouse.  Once 
in Block 15, press <Enter> a couple of times to move down to the third line.  Now type in 
"0001", and then <Tab>.  Notice that the cursor moves to the same line of Block 16.  Type in 
"1111-22-333-4444" as a sample NSN number, then <Enter> to move to the next line in Block 
16.  Type in "WIDGET" for the nomenclature then <Tab>.  Notice that the cursor moves back 
up, even with the top line of the CLIN as it moves to Block 17.  Type "10" for the quantity, then 
<Tab>.  Notice that the cursor again stays on the same line, and that the "10" has been 
moved to the right for proper numeric alignment. 

 

 Block 15 after inserting an item 

 

Finally, enter "1250" as the unit price, and press <Tab>.  Again the cursor moves to the 
same line of the next block.  Notice also that the price has been decimally aligned, a comma 
was added along with ".00" to properly format the number.  DD-FormStation does not 
automatically add a “.00”, leaving the decision to the user. Notice that the extended price has 
been calculated automatically for you.  Finally press <F2> to have FormEditor calculate and 
insert the grand total.  In this case, since the DD250 is only one page, the grand total is placed 
on the first page.  Otherwise it would have been placed automatically after the last item on the 
continuation pages. 

Automatic alignment, formatting, and calculations are generally welcome, but can be 
bothersome in some situations.  The FormEditor can be configured to not perform these 
functions, or to only do some of them, some of the time. 

Line Item Databases 

One of the selection lists provided for the DD250 is linked to the Units of Issue, Block 
18.  Assume for example that Widgets are sold by the Kit, but you cannot remember if Kit is 
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abbreviated KI or KT.  Click on the "EA" in Block 18, then press <Ctrl F> (as you would in one 
of the address blocks).  The selection list shown above/below appears, with the official units of 
measure as defined by Mil-Std 129.  Press <Enter> and that abbreviation is placed into the 
form, replacing “EA” that was there. 

 
Unit of Measure Selection List 

Like the MasterWriter, the FormEditor has a database of part descriptions to simplify 
data entry in Block 16.  The FormEditor parts database is dual keyed, so that you can retrieve 
items by either their NSN or your part number.  To access the parts database, move the 
cursor to the line in Block 16 where you wish the item description to be placed and press <Ctrl 
F>. 

You may notice that the Parts Database dialog looks much like the Address Database 
dialog described in a previous section.  It also operates in much the same manner.  Press the 
<Down Arrow> and <Up Arrow> keys a few times.  Notice that as the NSN changes, the part 
description in which it is associated with is displayed. 

 
Block 16 Parts Database Dialog 
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The Parts Database adds a second independent index, labeled Part Number, which is 
intended for that purpose.  In actuality, the values of both indices used to store part 
descriptions are at the discretion of the individual user. 

The two separate index fields operate totally independently.  The NSN field is the 
primary database index.  A unique NSN for each part is required in order to store and retrieve 
them from the database. The secondary index is optional, and can be repeated in the 
database.  This allows you to use this field as a category or group name for parts.  The part 
description displayed is dependent on the active index values, as indicated by the Primary Key 
and Secondary Key selection buttons next to the index fields.  You may toggle the activation 
between them by alternately pressing <Alt P> and <Alt S>.  Notice that the part description 
displayed changes as you do.  Selecting an index value from either of the lists will also make 
that list the active key. 

You may examine the index values associated with a particular entry by clicking on 
Modify or pressing <Alt M>.  Clicking the [New] button will create a blank entry, and [Copy] 
will allow you to create a new entry similar to the current one.  Clicking on [Ok], or pressing 
<Enter> or <Alt O> will accept the entry and insert it into the form at the current location of the 
cursor.  New parts also can be added to the database by first typing them into the DD250, 
then pressing <Ctrl P> (put) while the cursor is located somewhere within the description. 

You can use the dialog to modify entries without placing them into the form by selecting  
[Cancel] instead of [Ok] when finished, or by accessing the dialog through the 
Database>Parts menu command.  Use of Parts Database dialog features is further explained 
in the Reference Guide.  Also explained is the use of the Address Database Tool, which 
allows the import and export of parts data.  Of particular use to MasterWriter users is the 
facility which imports the MasterWriter parts database for use with the FormEditor. 

Leaving the CLIN Section 

As discussed above, pressing the <Tab> key while in the CLIN section causes the 
cursor to cycle through Blocks 15 through 20, then back to Block 15.  The <Shift Tab> has the 
same effect but in the other direction.  Pressing the <Enter> key within any of these blocks 
moves to the next line, until the last line is reached, then goes to the next block.  Thus it would 
appear that you could get stuck in the CLIN section forever, but this is not the case.  To leave 
this section, use the mouse to click on some other block, or use <F7> or <Ctrl J> to jump to 
another block or page. 
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Printing the Current Document 

To print the current document, you may do so at any time from within the FormEditor by 
clicking on [Print] (or press <Alt P>).  If your default printer is a LaserJet compatible printer, 
simply click on [Ok] or press the <Enter> key.  This will open the Print-Time Options dialog 
that offers you the chance to print to a different form.  Make your selection and click on [Ok]. 

Print-Time Options Dialog 

 

The Print dialog will appear, where you may continue to print using the default printer or 
select an optional printer: 

FormEditor Print Dialog 
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Form-Specific Printer Selection 

All of Mil-Pac’s powerful form processing applications are further enhanced by the 
ability to designate specific printers and print trays for each type of form created.  This enables 
the user to print a specific form to a designated printer and/or print tray with just the click of a 
button. 

The diagram on the following page illustrates an example of how this feature can be 
used to automatically print each form to a specified target printer or print tray. 
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Configuring Printers for Specified Forms 

From the Options>Forms command, the following dialog will appear: 

Print-Time Options dialog 

 

Select a form from the drop down menu under Print with Alternative Form, then click on 
[Ok].  The Form Pinting Attributes dialog will then be presented. 
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In the following example, a DD-FormStation user needs to print all DD250s to a printer 
with the proper paper already loaded.  The user will set up the required printer for this form in 
the Form Printing Attributes dialog: 

Form Printing Attributes dialog 

This dialog is where you would make any necessary adjustments to the position of the 
form when printed.  At any time, you can revert all adjustments to the default values, or to the 
values that you set with the latest change. 

Click here to open 
the printer set up 

dialog 
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To set up a printer for this form other than the default, click on the [Set Print Device] 
button, which will open the following dialog: 

 

 

To select a different printer than the default, click on [Setup]: 

 

Print Setup Dialog 
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The program will allow you to select from all printers currently set up on your computer 

or network. Depending on the printer, you may even be able to specify a specific tray into 
which you may load different size or color of paper: 

The example below demonstrates how you can select different paper sizes: 

 

You may then follow the same procedure for selecting a specific printer and/or print tray 
for each form. 

Saving the Current Document 

To save the current document, you may do so at any time by pressing <Ctrl S>.  This 
may be done as often as desired to ensure that the current version of your work is safe.  You 
also may choose to wait until you are ready to exit the editor, and the document will be saved. 

Exiting the FormEditor 

To exit the editor after completing work on a document, click on [Exit] or press the <Alt 
X> key.  If any changes have been made to the document, you will be asked if you would like 
to save it.  Click on [Yes] or press the Y or <Enter> key.  If you have made changes you do 
not wish to save, click on [No] or press the N key.  If you have exited by mistake, pressing 
<Esc> or selecting [Cancel] will return you to the FormEditor. 
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FormEditor Reference Section 
 

This section explains the FormEditor dialogs and functions in greater detail. 

Internal Address Block Codes 

On some forms, such as the DD250, the need may arise to create an address in the 
Address Database using an index (CAGE code) that is not to be printed on the form.  Such is 
the case if a particular address does not have an official CAGE code (e.g. many DD250 Mark-
For addresses).  The user is free to create an internal reference for his own use.  To prevent 
internal codes from printing, start them with an asterisk, such as the “*RCV-OFCR” in the 
example below. 

  

Non-Printing Address Code 

Internal CAGE codes are also relevant to forms which provide only a space for the 
address, but not for the code itself (e.g. DD1149).  In such cases, there is no need to use a 
leading asterisk character since the code is not going to be printed. 



FormEditor  REFERENCE 

- 114 - 

FormEditor Configuration 

The operational characteristics of the DD-FormStation under the user’s control are set 
by the configuration dialog described below. 

 
Editor Options Dialog 

 

Editor Options Dialog 

The Editor Options dialog controls the way some editor features work. The individual 
controls are described below: 

Default Input Mode:  Determines whether the FormEditor starts up in Insert Mode or 
Overstrike Mode (default). 

Error Checking: Determines the start up error checking mode. 

Strict: User is not allowed to leave a block containing an error until the error is  
corrected or error checking is toggled off. 

Passive: User is warned about error conditions, and given the opportunity to return to 
the offending block. 

None: No error checking is performed (the default). 

Required Fields: User is warned if any required fields are blank before saving or printing. 
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Auto Field Alignment: If checked, some fields are automatically centered, right- or 
decimal-aligned.  This setting can be overridden by the two 
selections below: 

Not this Form: The alignment is disabled for this form, regardless of the setting 
above, during this and future sessions.   

Not this Session: The setting is disabled, but only for the remainder of the session. 

Auto Currency Formatting: If checked, financial fields are automatically formatted with the 
addition of commas, decimal points, cents and where appropriate, 
dollar signs.  Negative values are shown in parentheses.  This 
setting can be overridden as described above. 

Auto Price Extensions: If checked, extended prices are automatically calculated.  This 
setting can be overridden as described above. 

 
Printing Options Dialog 

 

Printing Options Dialog 

Printing Method: Determines the method of printing the graphical forms: 

LaserJet-II PCL: LaserJet-II commands are sent to the printer, bypassing all 
Windows print-driver translation.  This produces the best and fastest output on 
most LaserJet-II compatible printers. 

Windows Drivers: The form is printed using the driver for the currently selected 
printer.  This option must be used for printers that are not LaserJet-II 
compatible, and for all fax-modems.  Results may vary depending on the 
capabilities of the printer driver. 
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Download Forms: Determines when forms are downloaded.  This is only in effect if the 
current Printing Method is LaserJet-II PCL. 

Always: Fonts and forms are downloaded automatically every time a 
document is printed.  Suggested for shared printer environments. 

Always, Ask: Same as Always, but the user is prompted first (default). 

Once, Ask: Forms are downloaded once per session, user is prompted first. 

Never: Forms are never downloaded.  It is assumed that they are printer 
resident or are downloaded separately. 

Common Error Messages 

Paradox Database Engine Errors 

DD-Master and DD-FormStation’s editor employ the Paradox Database Engine to 
maintain various databases for things such as address blocks, part descriptions, and form 
status.  These databases require simultaneous access by multiple applications, which is not 
inherently permitted by DOS.  The DOS "Share" driver overcomes this basic deficiency, and 
therefore must be in place in order to run the DD-FormStation and DD-Master. 

Many computer systems running Windows already have the Share driver running.  
Should you encounter an "Error opening or initializing the Paradox Engine" message when 
bringing up the DD-FormStation, you may need to install Share.  To do this, follow these 
simple steps: 

Edit AUTOEXEC.BAT file, found in the root directory. 

After the path statement(s) which define the DOS directory, place the 
word "SHARE" on a line by itself somewhere after the PATH 
statements. 

Exit and save the file. 

Reboot your system and try running DDFS again. 

If this problem occurs after upgrading a DD-FormStation, ensure that only one Paradox 
lock file exists. Should more than one file with the .LCK file extension exist in the DDFS 
directory, delete both of them.  Contact the Mil-Pac Technology Technical Support Division 
should you have any questions or encounter any problems with this procedure. 
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WAWF TRANSACTIONS 
 

Transactions Supported 
 DDMaster DD-FormStation RFID Load Mgr 

DD250 Receiving Report ● ●  

Invoice ● ●  

Combo (Receiving Report & Invoice) ● ●  

Receiving Report Pack Update (RFID ASN)   ● 

Public Cost Voucher  ●  

Progress Payment  ●  

Direct UID Submittal ● ●  

 

DD250 Receiving Reports 

The WAWF Receiving Report is the electronic equivalent of the DD250.  Submitting it 
using Mil-Pac’s EDI or UDF-FTP format is roughly the same as manually entering the same 
data in web-WAWF.   

Invoices 

The standard invoice supported is a billing for shipments made on a DD250.  A DD250 
must be submitted and in the system before, or at the same time as the invoice.  The invoice 
is held in WAWF, until forwarded to the appropriate payment system after the DD250 is 
accepted by the government quality representative.    

Combos 

The Combo is a DD250 that includes invoice data.  It acts roughly the same, except that 
it does not allow for RFID data to be submitted as an update.  The government’s EDI Combo 
transaction does not provide an RFID To Follow flag.  The current Mil-Pac implementation 
does not allow for embedded RFID, although this is slated to change in the future.  For now, if 
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you are going to submit RFID data it must be done with an RFID Pack Update, which requires 
a DD250 rather than a Combo. 

DD250/Invoice (Both) 

The DD250/Invoice (Both) option is a shortcut that submits both DD250 and an invoice 
in the same operation.   It has the same effect as sending the DD250, then sending the 
invoice.  If the DD250 is not successfully imported the invoice will bounce as well.  

RFID Pack Update (ASN) 

RFID data is submitted separately, at any point after a DD250 has been successfully 
imported or manually entered into web-WAWF.  Since RFID submittal is not a condition of 
acceptance, it does not have to be done before the shipment can be accepted, however, the 
RFID data must arrive at the destination before the shipment does.  Remember, you must 
mark the DD250 with the Pack Later (or RFID to Follow) flag in order to be able to submit 
RFID data in this manner.   

Public/Cost Voucher 

The Public/Cost Voucher is supported as a variant of the 810 Commercial Invoice 
transaction.  Complete the SF1034/1035 form to create the required data set. 

Progress Payment 

The Request for Progress Payment is supported as another variant of the 810 
Commercial Invoice transaction.  Complete the SF1443 form to create the required data set. 

Direct UID Submittal 

In most cases, UID data is submitted to the UID Registry by simply including on a 
DD250 Receiving Report, as described below.  In those cases where that is not possible, for 
instance when the receiving activity is not WAWF-compatible, a regular DD250 can be 
completed for submission as a paper document and the UIDs submitted directly to the UID 
Registry. 

 

Data Formatting for WAWF Transactions 
Mil-Pac created a modernized DD250 form, the WA250, specifically for creating WAWF 

Receiving Reports. It is very similar in appearance to the paper DD250 but has some added 
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fields that simplify data entry and make it easier for WAWF to interpret the data.  Either form 
can be used to prepare data for WAWF submittal.  The DD250 must be used when an 
inspector’s physical signature is required (i.e. not processed through WAWF). 

Data entered onto a DD250 or WA250 form must follow certain formatting conventions 
in order to be successfully processed into the highly regimented electronic transactions 
specified by WAWF.  Following these guidelines accomplishes that while also ensuring 
compliance with the DFARS rules for paper DD250s. 

Line Item Formatting  

Line item descriptions, which can be a challenge for an electronic system to 
understand, may be successfully translated into WAWF transactions by observing the 
following guidelines. 

National Stock Number (NSN) 

Generally speaking each line item should appear as follows: 

 

0001  1111-22-333-4444 
WIDGET 
P/N: 343634-009 
< other lines> 
S/N:  (if needed) 

2 EA $2,200.00

 

The first line should be the NSN, with nomenclature on the second line and part number 
on the third.  Serial numbers are always the last part of the item.  Other data such as 
MILSTRIP, ACRN, etc. can appear in any order between the Part Number (if one) and the 
Serial Number (if applicable). 

The NSN is not required if not applicable, but the message “Warning: No National Stock 
Number” will be given.  This is to remind you to check the data, in case the NSN was forgotten 
or not properly formatted.   

 

0002  NSN: NONE 
WIDGET 
  < etcetera > 

2 EA $15,500.00
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The No NSN warning can be ignored, or eliminated by stating “NSN: NONE” on the first 
line of the item. In either case, the transaction will be properly encoded to indicate that no 
NSN is present.  The warning is there to draw your attention in case the lack of a proper NSN 
was due to a data-entry error.  However, there are cases where certain data formats may fool 
the WAWF translator into thinking there is an NSN, resulting in a WAWF error.  Use of NSN: 
NONE eliminates this problem. 

MILSTRIPs 

When it is necessary to include a MILSTRIP number, place it anywhere after the Part 
Number (if any) and before the first Serial Number (if any): 

 

 0017 4452-01-551-9007 
WIDGET 
P/N: 343634-009 
MILSTRIP: 29723598724460 
S/N:  (if needed)  

2 EA $5,200.00

Multiple MILSTRIPs 

In cases where an item is allocated to multiple MILSTRIPs, the item should be 
formatted as such: 

 

0017  4452-01-551-9007 
WIDGET 
P/N: 343634-009 
MILSTRIP: 29723598723801  EA 10 
MILSTRIP: 29723598723802  EA 12 
MILSTRIP: 29723598723803  EA  2 
S/N:  (if needed)  

40 EA $1,807.00 

 

In the case above, only 24 of the 40 units were allocated to individual MILSTRIP 
numbers.  The remainder would be allocated to "NONE" for proper accounting of the quantity 
shipped.  In this case, a warning will be issued, so that it does not occur inadvertently. 
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ACRNs 

Single ACRNs are entered as shown below, with ACRN placed anywhere after the part 
number and before the first serial number (if any). 

 

0017  4452-01-551-9007 
WIDGET   
P/N: 343634-009  
ACRN: XY   
MILSTRIP (if necessary)  
S/N:  (if needed) 

2 EA $500.00 $1,000.00 

Multiple ACRNS 

     

0003  4452-01-551-9007 
WIDGET 
P/N: 343634-009 
ACRN: XY  $750 
ACRN: XZ  $250 
S/N:  (if needed) 

2 EA $500.00 $1,000.00 

Multiple ACRNs can be listed as shown above.  They must add up to the extended 
price of the item.  Note that single ACRNs do not require a dollar amount. 

Zero-Lot Items 

For partial lot shipments, the quantity shown on each partial shipment will be 0 LT.  The 
shipment that completes the lot indicates this by stating a quantity of 1 LT.  This confuses 
more than just people.  When WAWF is trying to figure out how many MILSTRIPs to allocate, 
or UIDs to expect, it needs to know the actual number of THINGEEs you sent. Starting in 
WAWF-3.0.9 we have the concept of Actual Quantity: 

 

 0017  4452-01-551-9007 
ELECTRICAL CONNECTOR 
P/N: RE11-442S 
MILSTRIP N005354281X001XXX EA 2 
MILSTRIP N005354281X002XXX EA 3 
ACTUAL: 5 
UID: TYPE2 
S/N: 4087002, 4087005, 4087008 

0 LT $5,200.00 
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S/N: 4087009, 4087012 

 

For Zero-Lot, Mil-Pac now requires the "ACTUAL: n" line to appear somewhere 
between the P/N and the S/N, if applicable.  For UIDs and MILSTRIPs this is a critical error-
checking item.  For non-serialized items, it is the only way that the Mil-Pac software knows 
what quantity was actually shipped, which became an absolute requirement in WAWF-3.0.10. 

Government Furnished Property  (GFP) 

 

0017  4452-01-551-9007 
WIDGET 
P/N: 343634-009 
GFP               
S/N:  (if needed)  

2 EA $5,200.00 

 

Placing the GFP flag in a line item will set the Shipping Advice code to indicate that the 
item includes, or is, Government Furnished Property  (GFP). 
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Continuation Beyond End of Page 1  

This is an example of an item that continues beyond Page 1.  Do not enter anything 
besides the data at the end of Page 1 or the beginning of the Continuation Page.  Entries such 
as  "0017 | Continued" will create a second item 0017 or a serial number “Continued” 
depending on how you do it. 

 
|-------|------------------------------|-------|-----|--------|--------| 
|Item # | Stock/Part No. / Description |   Qty |Unit |  Price |  Amount| 
|-------|------------------------------|-------|-----|--------|--------| 
|       |                              |       |     |        |        | 
|0017   | 8470-00-141-0936             |    10 | EA  | 150.00 |  $1,500| 
|       | Field Service Kit            |       |     |        |        | 
|       | P/N: FSK-23-00723            |       |     |        |        | 
|       | MILSTRIP N005354281X001XXX   |       |     |        |        | 
|       | ACRN AB $1,500.00            |       |     |        |        | 
|       | ACRN: AC $500                |       |     |        |        | 
|       | UID: TYPE2                   |       |     |        |        | 
|       | S/N: 4087002, 4087005        |       |     |        |        | 
|       | 4087021, 4087022, 4087023,   |       |     |        |        | 
|----------------------------------------------------------------------| 
| 21.   ...                                                            | 
|                                                                      | 
|----------------------------------------------------------------------| 
|              CONTINUATION SHEET                                      | 
|-------|------------------------------|-------|-----|--------|--------| 
|Item # | Stock/Part No. / Description |   Qty |Unit |  Price |  Amount| 
|-------|------------------------------|-------|-----|--------|--------| 
|       | 4087025, 4087027, 4087028,   |       |     |        |        | 
|       | 4087029, 4087030, 4087033    |       |     |        |        | 
|       |                              |       |     |        |        | 
|-------|------------------------------|-------|-----|--------|--------| 
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Proper Address Formats 

Address blocks require special formatting to allow for the identification of the entity 
(company or activity) and the city, state and zip code, and in the case of foreign (OCONUS) 
addresses, the country code.  The main rule is that City, ST Zip must be on the last line.  The 
Entity should be the first line.  Anything else, like a phone number, or ATTN, should go on the 
second line. 

CONUS Address Blocks 

Domestic addresses must be at least three lines, with the “City, ST Zipcode” appearing 
on the last line.  The WAWF translator cannot properly interpret other formats.  Always follow 
these rules: 

• Must be at least three lines 
• City, ST Zipcode must always be the last line  
• Two letter State Code, without a period 
• Five or nine digit Zip Code. If using a nine-digit Zip Code, be sure to include a 

hyphen (example: “65336-3201”). 

    CODE:  DODAAC 
Entity  
Division / Attn / Phone / etc. 
Bldg / Suite / etc.  
Street Address  
City, ST Zipcode 
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Foreign Address (OCONUS) Blocks 

Foreign addresses must be at least three lines, with the “City, Postal Code (Country Code) as 
the last line of the block. 

• City, Postal Code (Country Code) is always last line  
• Country Code is required  (two or three characters in parenthesis) 
• When there is no Postal Code, use the country name instead:  

 
 MONTREAL, H3Y 5T7 (CAN)  
 KANDAHAR, AFGHANISTAN (AF)     
 

Mark-For Address Blocks 

The Mark-For block can contain either a physical address, in cases where the Ship-To 
is not the ultimate consignee.  It may also contain non-address data, referred to as Mark-For 
Instructions. 

• If the DODAAC is the same as the Ship-To, leave Mark-For CODE blank. 

• If the DODAAC and address are the same as the Ship-To, leave the entire Mark-For 
block blank, unless adding Mark For Instructions, as described below. 

• When DODAAC is placed in the CODE field, the address must be properly formed: 

    CODE:  DODAAC 
Entity  
Division or Attn 
Bldg/Suite/etc.  
Street Address  
City, Postal Code (Country Code)  

14.  MARK FOR   CODE:  DODAAC 
 
Entity  
Division / Attn / Phone / etc. 
Bldg / Suite / etc.  
Street Address  
City, ST Zipcode 
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• When not a proper address, the contents of the block are referred to as Mark For 
Instructions.   In this case, do not put a DODAAC in the CODE field. (It may, however 
be placed in the text): 

 

14.  MARK FOR   CODE:   
 
M/F:  DODAAC   
Contract: XYZ123-05-A-0001 
Proj: XYZ 
TP: 1 
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CAGE Code Extensions 

A CAGE code other than the Prime Contractor’s may appear in the Ship-From block in 
cases where a shipment is made on behalf of the prime by a sub-entity, sub-contractor or 
packaging contractor.  In order to be properly recognized by WAWF, the Prime can establish 
the CAGE of the Sub entity as a CAGE-Extension.  This process is initiated by the Sub in 
web-WAWF, which will forward the request for an extension to the Prime.  Once granted the 
Sub will have the ability to submit on behalf of the Prime and view documents the Sub 
submits.  More information on this subject is available from WAWF. 

 

Mil-Pac’s WAWF Support Library can generate CAGE extensions, but only after being 
so enabled by the user.  Check the Append Ship-From CAGE to Prime option in DD250 
Options.  
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Cage Extensions in RFID Load Manager  

Cage Extensions are automatic in RFID Load Manager, as long as both the Prime and 
the Ship-From CAGE codes are created by Std-Barc.  Ship-From will always be present, as it 
is required to generate RF Tag IDs.  The Prime is only present if RF Tags are printed in the 
Exterior Container Label format.   

 

 
 

 

Whenever shipping as an entity other than the Prime contractor, it is important that both 
the Ship-From and Prime CAGE codes appear in Review Shipment Details, which appears 
when you create and submit an RFID Pack Update (ASN).  You can also review these details 
before creating the ASN.  If the Prime is different from the Ship-From, and it does not appear, 
you must enter it, as shown above. 

Inspector / QAR Office 

The office code and optional extension of the QAR/QAS to inspect and accept the 
DD250 is placed in Block 21A next to "TITLE:" legend.  The address and phone number of the 
QAR is optional and should be left out.  The form of the code is: 

 

  TITLE:  S0504A 

    or TITLE:  S0504A-123 
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For CQA at Destination (i.e. when Block 21B CQA is checked) place the DODAAC of 
the QAR/QAS in Block 21B instead. 

 

Note that the ACCEPTANCE checkboxes in both 21A and 21B are ignored for WAWF 
transactions.  Block 8 is the sole determiner of Acceptance Point.  Note also that checking 
CQA in 21A/B does not imply that CQA has been performed - it is a required informational 
item for WAWF transactions. 

Local Processing Office  (LPO) 

For contracts where it is necessary to include the DODAAC of the Local Processing 
Office  (LPO), place it as the last line in the Payment Office block (12).  For example: 

 

If you are sending just CAGEs/DODAACs (Options > WAWF > DD250 Options > Strip 
Addresses) then the LPO can appear anywhere in the (Payment Office) block.  WA250 Form 
users should put the LPO DODAAC in the appropriate field in Block 21. 

 

Ship-In-Place 

The phrase "Ship-In-Place" can be used in place of the address text in the Ship-To 
block.  This also triggers submittal of the proper Shipping Advice code.  Users of the WA250 
form can just check the Ship-In-Place checkbox to get the same effect.  In either case, no 
Ship-To address is submitted, only the block's CAGE/DODAAC code.   Use of a DODAAC is 
allowed if your bonded storage area has been assigned one. 

 

12.  PAYMENT WILL BE MADE BY  CODE: N68688
 
DFAS CLEVELAND CENTER & OPLOCS 
SAN DIEGO 
4181 RUFFIN ROAD 
SAN DIEGO, CA 92123-1819 

LPO:  N68937 
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ARP, COC, RFID (To Follow) and SERVICES 

The WA250 form includes checkboxes to indicate 

 

   ARP  Alternative Release Procedure 

   COC Certificate of Conformance (attached by reference) 
   RFID Data to Follow in Pack Update 

   SERVICES DD250 is for Services vs Goods/Supplies 

 

The DD250 has no such checkboxes.  To indicate these conditions simply place one or 
more of the key words (ARP, COC, RFID, SERVICES) anywhere on the Govt. Rep Signature 
line (Block 21A).  They may appear in any order. 
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UID Format Options  
This section describes the use of Mil-Pac generated Receiving Reports to properly convey 

UID data to the UID Registry via WAWF in transactions generated by DD-FormStation and 
DD-Master. A number of techniques are provided to fit different circumstances and process 
flows.  

UID registry requires several pieces of data for each item in addition to contract and 
shipment numbers, the item number (CLIN), product identifier (NSN/PN) and unit cost:  

 1. UID Type (Construct 1 or 2)  
 2. Entity Identifier (such as CAGE) of company assigning the UID  
 3. IAC (Issuing Agency Code) which controls the Entity ID  
 4. Part Number (Construct 2 only)  
 5. Serial Number  
 6. Fully constructed UID, built from the items above  

This information may be explicitly provided for each UID submitted, or automatically 
generated from DD250 data. Mil-Pac software can simplify the specification of UID data for 
contracts that use UID Construct 2, combining the Prime Contractor’s CAGE code, with the 
part number and serial numbers for each item to automatically create UIDs.  

The following examples show how to format DD250s for both automatic and explicit 
(manual) UID data submittal.  

Automatic Generation of Construct 2 UIDs  

Mil-Pac software will automatically generate these UIDs when it encounters the operator 
UID: Type2, which can appear anywhere between the nomenclature (second line) and the 
first Serial Number.  

0001  1112-01-434-0001  
LN-200 IMU HOUSING  
P/N: 31-142  
MILSTRIP: N005354281X001XXX  
UID: TYPE2  
S/N: 2044492, 2044498, 2044499, 2044501, 
2044507  

5 EA $1,750

Automatic Construct 2 UID  

In this example the Prime CAGE code "1HLD9" (DD250 Block 9), part number "31-142" 
and each of the five serial numbers listed would be used to automatically construct the 
following five UIDs:  

 • D1HLD931-1422044492       • D1HLD931-1422044498      • D1HLD931-1422044507 
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 • D1HLD931-1422044499       • D1HLD931-1422044501  

Mixing UID and Non-UID Items  

UID generation occurs only for line items that include UID operators, such as the “UID: 
TYPE2” in the previous example. Intermixed line items, such as the one below, would not 
have UIDs automatically generated. By the same token, you may mix UID generation 
methods, as there are no assumptions from one line item to the next.  

 

0001  
 
 
 
 
 
 

0002 

1112-01-434-0001  
LN-200 IMU HOUSING  
P/N: 31-142  
MILSTRIP: N005354281X001XXX  
UID: TYPE2  
S/N: 2044492, 2044498, 2044499, 2044501, 
2044507 

4452-01-341-9980  
ELECTRICAL CONNECTOR  
P/N: RE11-442S  
MILSTRIP: N005354281X002XXX  
S/N: 4087002, 4087005 

5 
 
 
 
 
 
 
 

2 

 

EA 
 
 
 
 
 
 
 

EA 

 

$1,750
 
 
 
 
 
 
 

$586 

 

Mixing UID and Non-UID Line Items  

Using a Different Part Number and/or Entity  

It is also possible to utilize automatic UID construction in cases where the Prime uses 
the UID Part Number and Serial Numbers assigned by a sub-contractor or other vendor. The 
placement of UID-ENTITY and/or UID-PN operators before the first Serial Number overrides 
the prime contractor CAGE (DD250 Block 9) and/or part number (X22-5525 in the example 
below).  

0004  1224-01-122-0044  
CIRCUIT HOUSING  
P/N: X22-5525  
UID-ENTITY: 07700  
UID-PN: 311875-1N42  
S/N: 5525-0001, 5525-0003, 5525-0004, 5525-0006, 5525-0007, 
5525-0009, 5525-0012  

Alternative Part Number and Entity  
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This example will override the prime's Part Number for UID construction and submittal only. 
On the WAWF Receiving Report this item would still be listed as P/N X22-5525, and the prime 
contractor 1HLD9 (DD250 Block 9). The following UIDs would be constructed:  

• D07700311875-1N425525-0001,  D07700311875-1N425525-0003 . . .-0012  

In the examples above we have been assuming that the Entity ID was a CAGE Code. In 
some cases the prime may wish to utilize part numbers and serial numbers assigned using 
one of the other internationally recognized Issuing Agency Codes (IAC), such as DUNS. 
Stating the IAC after the Entity ID, using one of the officially recognized codes, does this. 

 

0005  1224-01-788-9917  
POWER REGULATOR  
P/N: X22-7566  
UID-ENTITY: 6445227111 [IAC: UN]  
UID-PN: PNG911-032-5525 S/N: 7566-0008, 7566-0012, 7566-
0017  

Non-CAGE Entity Identifier 

This example is similar to the one above it, except that the Entity Identifier is a DUNS 
number instead of a CAGE Code. The following UIDs would be constructed:  

• UN6445227111PNG911-032-55257566-0008  
• UN6445227111PNG911-032-55257566-0012  
• UN6445227111PNG911-032-55257566-0017  

Explicitly Named UID Components  

It may be desirable to explicitly state each UID component. This is possible by providing 
a UID-ENTITY/IAC, UID-PN and UID-SN for (after) every serial number listed for an item.  

 

0006  1112-01-434-0005  
LN-200 INERTIAL MEASUREMENT UNIT  
P/N: 31-142  
MILSTRIP: N005354281X001XXX  
S/N: 407090  
UID-ENTITY: 06481 [IAC: D]  
UID-PN: 06481-311875-1N42  
UID-SN: 407090  
S/N: 407091  
UID-ENTITY: 06481 [IAC: D]  
UID-PN: 06481-311875-1N42  
UID-SN: 407091  

Explicit UID Components  
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The example above demonstrates arbitrary UID assignments, in which each UID 
component is explicitly stated. This example would produce the following UIDs:  

• D0648106481-311875-1N42407090  
• D0648106481-311875-1N42407091  

UID Construct 1 

Automated generation of UIDs is not possible for Construct 1 UIDs, since unlike 
Construct 2 UIDs, the UID Construct 1 is not likely to be associated with an item serial 
number.  Keep in mind that the Construct 1 serial numbers are independent of the Part 
Number, and must be unique across the Prime’s product line.  Composite Construct 1 UIDs 
may be entered onto the DD250 in S/N - UID pairs: 

 

0017  4452-01-551-9007 
ELECTRICAL GENERATOR 
P/N: EG61-400942  
S/N: 5000296 
UID1: D1HLD900000001 
S/N: 5000297 
UID1: D1HLD900000002 

 

2 EA $5,200.00

Entering Construct 1 UIDs  
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APPENDIX 

FormEditor Keystroke Guide 

Block Movement Commands (Menu Equivalent) 

<Tab> Go to the next block. 

<Shift-Tab> Go to the previous block. 

<Enter>  Go to next line of a multi-line block.  From single-line  
block or last line of a block it goes to the next block. 

<F7> Jump to a block or field.  (Search>Block) 

<Ctrl-J> Jump to a page. (Search>Page) 

 

Cursor Movement Commands  
<Up> Moves cursor to the character above, unless already at top of block. 

<Down> Moves cursor to the character below, unless already at bottom. 

<Left> Moves cursor one character to the left, unless already at left edge. 

<Right> Moves cursor one character to the right, unless already at right edge. 

<Enter> Goes to the beginning of the next line of a multi-line block. 

<Home> Goes to beginning of line.  If already there, goes to top of block. 

<End>  First goes to end of text on line, then to end of current line, then to 
end of block. 

<Ctrl-Left> Moves cursor one word to the left, within the current block. 

<Ctrl-Right> Moves cursor one word to the right, within the current block. 

<Ctrl-Home> Jump to first block on form page. 

<Ctrl-End> Jump to last block on form page. 

<PgDn> Scrolls form down 10 lines, moves cursor accordingly.  Within a 
continuous block, the text is scrolled - form does not move on screen.  
Use <Tab>, <Sh-Tab>, <F7>, or <Ctrl-J> to move to a different block 
or part of the form. 

<PgUp> The opposite of <PgDn>. 



Appendix   Keystroke Guide 

- 136 - 

FormEditor Keystroke Guide (cont.) 
 

Editing Commands  (Menu Equivalent) 
<Insert> Toggles between Insertion Mode and Overstrike Mode. 

<Ctrl-I> Inserts line into current block. (Insert>Blank Line) 

<Delete> Deletes the character at the cursor position. 

<Ctrl-D> Deletes line from current block. (Edit>Delete Line) 

<F12> Erases the current block. (Edit>Clear Block) 

<Ctrl-B> Inserts a page break (cont. sheet only). (Insert>Page Break) 

<F2> Extends unit price, calculates grand total. (Insert>Grand Total) 

 

Database Access Commands  
<Ctrl-F> Finds/retrieves data by displaying database associated with a block. 

<Ctrl-G> Gets address block associated with its CAGE code, P/N, etc. 

<Ctrl-P> Puts/stores address block under the associated CAGE, P/N, etc. 

 

Miscellaneous Commands  
<Ctrl-S> Save current document. (Exit.>Yes) 

<Ctrl-R> Repaginate (continuous forms only). (Tools>Repaginate) 
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